Ravi Nori has posted comments on this change. Change subject: core: Fail tasks that dont have Vdsm Id ......................................................................
Patch Set 23: (1 inline comment) .................................................... File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/VdcReturnValueBase.java Line 21: * Holds the ids of the async task place holders in the database. Line 22: * On server restart this list used to clean up and fail all the tasks Line 23: * that have place holders but don't have a vdsm task id. Line 24: */ Line 25: private ArrayList<Guid> asyncTaskIdList = new ArrayList<Guid>(); I have renamed it, I will add comments to taskIdsList when I rename it to vdsmTaskIdList in the later patches, is that okay? Line 26: private ArrayList<Guid> taskIdList = new ArrayList<Guid>(); Line 27: private final ArrayList<Guid> _internalIdList = new ArrayList<Guid>(); Line 28: private boolean _endActionTryAgain = true; Line 29: private final ArrayList<String> _executeFailedMessages = new ArrayList<String>(); -- To view, visit http://gerrit.ovirt.org/14368 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I110c483842027d1596f64dd8c3f635d62924a93f Gerrit-PatchSet: 23 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Ravi Nori <rn...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com> Gerrit-Reviewer: Ravi Nori <rn...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches