Michael Kublin has posted comments on this change. Change subject: engine: connectStorageServer is not sent for inactive domains before connectStoragePool ......................................................................
Patch Set 3: (2 inline comments) .................................................... File backend/manager/dbscripts/storages_san_sp.sql Line 537: LANGUAGE plpgsql; Line 538: Line 539: Line 540: Line 541: Create or replace FUNCTION Getstorage_server_connectionsActiveUnknownInactiveByPoolId(v_storage_pool_id UUID) If someone suggest another name in most cases I change a name, but I don't agree to try a guess a better name, such game is lost of time, it is strange that it is not obvious. Line 542: RETURNS SETOF storage_server_connections Line 543: AS $procedure$ Line 544: BEGIN Line 545: RETURN QUERY SELECT distinct storage_server_connections.* .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ConnectHostToStoragePooServerCommandBase.java Line 72: List<StorageDomain> exportDomains = Line 73: getStorageDomainsByStoragePoolId(allDomains, StorageDomainType.ImportExport); Line 74: Line 75: Set<StorageServerConnections> connections = new HashSet<StorageServerConnections>( Line 76: DbFacade.getInstance().getStorageServerConnectionDao().getActiveUnknownInActiveForStoragePool(getStoragePool().getId())); Done Line 77: if (isoDomains.size() != 0) { Line 78: _isoType = isoDomains.get(0).getStorageType(); Line 79: Set<StorageServerConnections> isoConnections = Line 80: new HashSet<StorageServerConnections>( -- To view, visit http://gerrit.ovirt.org/12805 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ibb3710bb83ef81485715577ae939014ffcae693f Gerrit-PatchSet: 3 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Michael Kublin <mkub...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Ayal Baron <aba...@redhat.com> Gerrit-Reviewer: Barak Azulay <bazu...@redhat.com> Gerrit-Reviewer: Eli Mesika <emes...@redhat.com> Gerrit-Reviewer: Liron Ar <lara...@redhat.com> Gerrit-Reviewer: Michael Kublin <mkub...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches