Arik Hadas has posted comments on this change. Change subject: core: cleanup Vm ......................................................................
Patch Set 1: (3 inline comments) .................................................... File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VM.java Line 189: this.mVmDynamic.setId(value); Line 190: this.mVmStatistics.setId(value); Line 191: } Line 192: Line 193: public String getVmName() { I suggest to rename it to getName() Line 194: return this.mVmStatic.getvm_name(); Line 195: } Line 196: Line 197: public void setVmName(String value) { Line 193: public String getVmName() { Line 194: return this.mVmStatic.getvm_name(); Line 195: } Line 196: Line 197: public void setVmName(String value) { I suggest to rename it to setName(..) Line 198: this.mVmStatic.setvm_name(value); Line 199: } Line 200: Line 201: public int getMemSizeMb() { Line 201: public int getMemSizeMb() { Line 202: return this.getVmMemSizeMb(); Line 203: } Line 204: Line 205: public int getVmMemSizeMb() { why keeping two methods getVmXXX that delegates to VmStatic and getXXX that delegates to getVmXXX for each attribute? I think we should remove the getVmXXX methods and make the getXXX methods delegate to VmStatic directly.. Line 206: return this.mVmStatic.getmem_size_mb(); Line 207: } Line 208: Line 209: public void setVmMemSizeMb(int value) { -- To view, visit http://gerrit.ovirt.org/9394 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ia02ddd858626553eca5de2310e8921cfac71957c Gerrit-PatchSet: 1 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Laszlo Hornyak <lhorn...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Laszlo Hornyak <lhorn...@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com> Gerrit-Reviewer: Roy Golan <rgo...@redhat.com> Gerrit-Reviewer: Sharad Mishra <snmis...@linux.vnet.ibm.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches