Maor Lipchuk has posted comments on this change.

Change subject: core: Adding force extend support to extendVG
......................................................................


Patch Set 1: Looks good to me, but someone else must approve

(3 inline comments)

Looks good, minor comments/suggestions

....................................................
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/ExtendSANStorageDomainParameters.java
Line 41:         super(storageDomainId);
Line 42:         setLunIds(lunIds);
Line 43:     }
Line 44: 
Line 45:     public ExtendSANStorageDomainParameters(Guid storageDomainId, 
java.util.ArrayList<String> lunIds, boolean force) {
Why not using simply ArrayList instead the full package name
Line 46:         super(storageDomainId);
Line 47:         setLunIds(lunIds);
Line 48:         setForce(force);
Line 49:     }


....................................................
File 
backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/ExtendStorageDomainVDSCommand.java
Line 15:     @Override
Line 16:     protected void ExecuteIrsBrokerCommand() {
Line 17:         String storageDomainId = 
getParameters().getStorageDomainId().toString();
Line 18:         String storagePoolId = 
getParameters().getStoragePoolId().toString();
Line 19:         List<String> deviceList = getParameters().getDeviceList();
Why add a new parameter(deviceList) that is not used
Line 20:         String[] deviceArray = deviceList.toArray(new 
String[deviceList.size()]);
Line 21:         boolean isForce = getParameters().isForce();
Line 22: 
Line 23:         status = getParameters().isSupportForceExtendVG() ?


Line 19:         List<String> deviceList = getParameters().getDeviceList();
Line 20:         String[] deviceArray = deviceList.toArray(new 
String[deviceList.size()]);
Line 21:         boolean isForce = getParameters().isForce();
Line 22: 
Line 23:         status = getParameters().isSupportForceExtendVG() ?
Suggestion: You already assigned all the parameters objects into new 
parameters, why not already do it also to the 
getParameters().isSupportForceExtendVG()
Line 24:                 getIrsProxy().extendStorageDomain(storageDomainId, 
storagePoolId, deviceArray, isForce) :
Line 25:                 getIrsProxy().extendStorageDomain(storageDomainId, 
storagePoolId, deviceArray);
Line 26: 
Line 27:         ProceedProxyReturnValue();


--
To view, visit http://gerrit.ovirt.org/9343
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I3b9196333f680bfad8bb421ad0dad8843b9c8e2b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <de...@redhat.com>
Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to