Roy Golan has posted comments on this change.

Change subject: core:Added affinity Group collision validation.
......................................................................


Patch Set 9: Code-Review+1

(4 comments)

last comments. all in all its straight forward

https://gerrit.ovirt.org/#/c/41805/9/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/commands/AffinityGroupCRUDCommand.java
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/commands/AffinityGroupCRUDCommand.java:

Line 112: (ag.isPositive()
is that deliberately not an 'else' of line 98 for readability reasons?


Line 127: 
Line 128:         return true;
Line 129:     }
Line 130: 
Line 131:     private Set<Guid> popVmGroupByGuid(Set<Set<Guid>> uag, Guid id) {
document this as well. can be a different patch
Line 132: 
Line 133:         for(Iterator<Set<Guid>> iterator = uag.iterator(); 
iterator.hasNext();) {
Line 134:             Set<Guid> s = iterator.next();
Line 135: 


Line 142: Guid
the generic GUID decleration is redendent. it is inferred from the method 
return type.


https://gerrit.ovirt.org/#/c/41805/9/frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
File 
frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java:

Line 3701: contradictio
other files you phrased with "collision" which is more appropriate I think too. 
make sure the phrasing is consistent.


-- 
To view, visit https://gerrit.ovirt.org/41805
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I56c483023ed14e238c8a67ec0890812158ecd0b2
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tomer Saban <tsa...@redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchap...@redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msi...@redhat.com>
Gerrit-Reviewer: Roy Golan <rgo...@redhat.com>
Gerrit-Reviewer: Tomer Saban <tsa...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to