David Caro has posted comments on this change.

Change subject: reorg repoclosure + tests
......................................................................


Patch Set 17:

(2 comments)

https://gerrit.ovirt.org/#/c/39249/17/jobs/packaging/repo_closure_check.sh
File jobs/packaging/repo_closure_check.sh:

Line 133: d="$( echo "${lm}" | cut -d: -f1 )"
        :         l="$( echo "${lm}" | cut -d: -f2 )"
> good readability advice :)
it's more robust, safer and faster


Line 506: #    check_repo_closure
Line 507:     check_repo_closure_new "${DISTRIBUTION}" "${DISTRIBUTION_VERSION}"
Line 508: }
Line 509: 
Line 510: if [[ ${TEST_RUN} -eq 0 ]]; then
> this is implicit approach, and it depends on bash.
we don't care about bashisms, that's why we put bash in the shebang.

I don't agree on it being clearer, and I really dislike using env vars. That 
forces you to set the var before sourcing and thus, setting any specific one 
for each script you source.
Line 511:     # only runs when TEST_RUN is 0.
Line 512:     main "${@}"
Line 513:     exit $?


-- 
To view, visit https://gerrit.ovirt.org/39249
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I207c5c59ca3149c17897c231e391e15e7eec4363
Gerrit-PatchSet: 17
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Max Kovgan <m...@redhat.com>
Gerrit-Reviewer: David Caro <dcaro...@redhat.com>
Gerrit-Reviewer: Max Kovgan <m...@redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbona...@redhat.com>
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to