Moti Asayag has posted comments on this change. Change subject: core: Introduce ChangeQuotaCommand - disks (#848310) ......................................................................
Patch Set 2: (2 inline comments) I strongly suggest you refer Omer's comment regarding overriding setActionMessageParameters when introducing the new command and not as a dependency on other bug, else your new code isn't complete. You can add tests to cover the canDoAction(), as usually done for commands. .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ChangeQuotaForDiskCommand.java Line 12: Line 13: public class ChangeQuotaForDiskCommand extends ChangeQuotaCommand { Line 14: Line 15: private static final long serialVersionUID = 1165911489949172000L; Line 16: private DiskImageBase _disk; why private member name start with underscore ? it doesn't follow the naming convention. Line 17: Line 18: public ChangeQuotaForDiskCommand(ChangeQuotaParameters params) { Line 19: super(params); Line 20: } .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/quota/ChangeQuotaCommand.java Line 21: setStoragePoolId(getParameters().getStoragePoolId()); Line 22: } Line 23: Line 24: @Override Line 25: protected abstract void executeCommand(); why do you need to redefine it here ? it is already abstract on CommandBase and this class is declared as abstract. Line 26: Line 27: @Override Line 28: protected boolean canDoAction() { Line 29: // check if SP exist -- To view, visit http://gerrit.ovirt.org/7357 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I0017a18109faecd1acab52897bba5474b6600390 Gerrit-PatchSet: 2 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Gilad Chaplik <gchap...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com> Gerrit-Reviewer: Gilad Chaplik <gchap...@redhat.com> Gerrit-Reviewer: Moti Asayag <masa...@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches