Juan Hernandez has posted comments on this change.

Change subject: packaging: Block 3.1 upgrade if DC/cluster 2.2 present (#799707)
......................................................................


Patch Set 1: (5 inline comments)

The error message printed when the query fails needs to be changed.

....................................................
File packaging/fedora/setup/engine-upgrade.py
Line 604:     # objects present. If yes, stop the upgrade
Minor: I would suggest to move this check to its own function. That way you can 
easily move its invocation around in the future, if you need to.

Line 605:     query_check_dc_versions="SELECT compatibility_version FROM 
storage_pool;"
Minor: The rest of the script uses a different style for variable names, 
something like "queryCheckDcVersions", "dcVersions", so on. Not that I prefer 
one over the other, but is better to be consistent.

Line 613:         MSG_ERROR_RENAME_DB,
This will print ""Error: Database rename failed ..." if something fails. Better 
add a new generic message something, like this:

MSG_ERROR_QUERY_FAILED="Error: Database query failed ..."

Line 623:         MSG_ERROR_RENAME_DB
Same as before.

Line 626:     for versions in (dc_versions, cluster_versions):
Minor: No need for parenthesis here.

--
To view, visit http://gerrit.ovirt.org/5186
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0277b73628872e8c0fa163fee0b89bd5cb724f05
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alex Lourie <alou...@redhat.com>
Gerrit-Reviewer: Alex Lourie <alou...@redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com>
Gerrit-Reviewer: Moran Goldboim <mgold...@redhat.com>
Gerrit-Reviewer: Ofer Schreiber <oschr...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to