Juan Hernandez has posted comments on this change. Change subject: packaging: Moving to use execCmd in all scripts (#731686) ......................................................................
Patch Set 2: Looks good to me, but someone else must approve (2 inline comments) See some minor style suggestions inline. .................................................... File packaging/fedora/setup/engine-setup.py Line 1003: cmd = ["/bin/sh", basedefs.DIR_DB_SCRIPTS + "/" + basedefs.FILE_DB_UPGRADE_SCRIPT] + dbScriptArgs I would suggest to use the following "pattern" when building lists for commands: cmd = [ "-a", "a.txt", "-b", "b.txt", "-c", "c.txt", ] Not that each part of the command goes into one line, and that the last line has a trailing comma. This makes things easier later if you need to reorder/add/remove arguments. Line 1006: output, rc = utils.execCmd(cmd, None, True, output_messages.ERR_DB_UPGRADE_FAILED) I would suggest to use argument names, even if they are not required, speically when values are things line "None" or "True": execCmd(cmd, cwd=None, failOnError=true, msg=...) And maybe omit the parameters with a default value: execDmd(cmd, failOnError=True, msg=...) It makes code easier to read. -- To view, visit http://gerrit.ovirt.org/4943 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: If5428890f9dcf8eafaa1ab059ee5d9e84f3f7f9a Gerrit-PatchSet: 2 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Alex Lourie <alou...@redhat.com> Gerrit-Reviewer: Alex Lourie <alou...@redhat.com> Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com> Gerrit-Reviewer: Ofer Schreiber <oschr...@redhat.com> Gerrit-Reviewer: moran goldboim <mgold...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches