Roy Golan has posted comments on this change.

Change subject: engine: Add support for IBM Tivoli Directory Server.
......................................................................


Patch Set 1: (3 inline comments)

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/LdapVendorNameEnum.java
Line 14:     public String getName() {
1.this whole enum should be merged into LdapProviderType. i.e  move the "name" 
field to (and rename it to vendorName). it'll be a nicer meta-data holder for 
the providers
 IBM("vendor name" , "other stuff")
2. the 2 LdapProviderType should be merged (appear under 2 different packages)

Yair - didn't you had a patch to do the LdapproviderType refactor?

....................................................
File 
backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ipa/SimpleAuthenticationCheck.java
Line 22: public class SimpleAuthenticationCheck {
Are we Using this at all in manage-domains? I think this is obsolete. Oved?

....................................................
File 
backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/kerberos/JndiAction.java
Line 176:         query = "(&(objectClass=person)(uid=" + userName + "))";
I think too the there's a formatting problem.
Sharad pls make sure your using the project formatter file under 
config/engine-code-format.xml

--
To view, visit http://gerrit.ovirt.org/4633
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Iffe980022787936fc79370104bb7f5c1129f0ce5
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sharad Mishra <snmis...@linux.vnet.ibm.com>
Gerrit-Reviewer: Oved Ourfali <oourf...@redhat.com>
Gerrit-Reviewer: Roy Golan <rgo...@redhat.com>
Gerrit-Reviewer: Ryan Harper <ry...@us.ibm.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to