Liron Ar has posted comments on this change. Change subject: core: Verifying storage space for AddDiskCommand ......................................................................
Patch Set 6: (2 comments) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddDiskCommand.java Line 536: } Line 537: return list; Line 538: } Line 539: Line 540: protected StorageDomainValidator getStorageDomainValidator() { i'd rename to "createStor.." to not have this in getter/setter convenation and also provide better readability of what this method does. Line 541: return new StorageDomainValidator(getStorageDomain()); Line 542: } .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/StorageDomainValidator.java Line 79: private static Integer getLowDiskSpaceThreshold() { Line 80: return Config.<Integer> GetValue(ConfigValues.FreeSpaceCriticalLowInGB); Line 81: } Line 82: Line 83: public ValidationResult hasSpaceForNewDisks(Collection<DiskImage> diskImages) { question just to be on the safe side - are we sure that those are the allocated sizes in all the vdsm versions? no chance for causing regression with old vdsm version/etc? Line 84: double availableSize = storageDomain.getAvailableDiskSizeInBytes(); Line 85: double totalSizeForDisks = 0.0; Line 86: Line 87: for (DiskImage diskImage : diskImages) { -- To view, visit http://gerrit.ovirt.org/15377 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I1a33502683ec77fba09efffba1438beb552082f7 Gerrit-PatchSet: 6 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Vered Volansky <vvola...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Daniel Erez <de...@redhat.com> Gerrit-Reviewer: Liron Ar <lara...@redhat.com> Gerrit-Reviewer: Sergey Gotliv <sgot...@redhat.com> Gerrit-Reviewer: Tal Nisan <tni...@redhat.com> Gerrit-Reviewer: Vered Volansky <vvola...@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches