Allon Mureinik has posted comments on this change.

Change subject: core: Take 2: Prepration for query permissions
......................................................................


Patch Set 4: (4 inline comments)

Agreed with most of your comments (and fixed accordingly in the next patchset).
Disagree about the getter/setter method name - let's discuss.

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/QueriesCommandBase.java
Line 47:     private final VdcQueryType _type;
Fixed in a later patch

....................................................
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryParametersBase.java
Line 178:     private boolean isRunAsUser = false;
Changed the name of the member, regarding the names of the method - don't 
agree. Let's discuss?

Line 212:     @XmlElement(name = "runAsUser", defaultValue = "false")
Removed.

....................................................
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryType.java
Line 277:         return authType.equals(VdcQueryAuthType.Admin);
Done

--
To view, visit http://gerrit.ovirt.org/1272
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I7ccc044e8527a5f901ad13dcb5289fa8c7b87204
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Livnat Peer <lp...@redhat.com>
Gerrit-Reviewer: Michael Kublin <mkub...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to