Yair Zaslavsky has posted comments on this change. Change subject: core: Take 2: Prepration for query permissions ......................................................................
Patch Set 4: (4 inline comments) Minor comments. .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/QueriesCommandBase.java Line 47: private final VdcQueryType _type; If you introduced final, why not also change the ugly (non java convention field name? .................................................... File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryParametersBase.java Line 178: private boolean isRunAsUser = false; I would rather have this flag be called "runAsUser" and then have a getter method of isRunUser and setter of setRunUser. Line 212: @XmlElement(name = "runAsUser", defaultValue = "false") Not needed anymore (the @XmlElement annotation , not your code :) ) .................................................... File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryType.java Line 277: return authType.equals(VdcQueryAuthType.Admin); In case of enums, please use == and not equals (better performance, and it's ok to use ==, as u have only single object of each enum literal (in your case - VdcQueryAuthType.Admin) -- To view, visit http://gerrit.ovirt.org/1272 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I7ccc044e8527a5f901ad13dcb5289fa8c7b87204 Gerrit-PatchSet: 4 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Livnat Peer <lp...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches