Hi Khem, On Wed, Dec 20, 2023 at 08:43:57AM -0800, Khem Raj wrote: > This patch seem to work fine
Thanks for double checking. I pushed it as: commit a2194f6b305bf0d0b9dd49dccd0a5c21994c8eea Author: Khem Raj <raj.k...@gmail.com> Date: Sun Dec 10 12:20:33 2023 -0800 Add helper function for basename musl does not provide GNU version of basename and lately have removed the definiton from string.h [1] which exposes this problem. It can be made to work by providing a local implementation of basename which implements the GNU basename behavior, this makes it work across C libraries which have POSIX implementation only. [1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7 * lib/system.h (xbasename): New static inline functions. Poison basename. * libdw/dwarf_getsrc_file.c (dwarf_getsrc_file): Use xbasename. * libdwfl/core-file.c (dwfl_core_file_report): Likewise. * libdwfl/dwfl_module_getsrc_file.c (dwfl_module_getsrc_file): Likewise. * libdwfl/dwfl_segment_report_module.c (dwfl_segment_report_module): Likewise. * libdwfl/find-debuginfo.c (find_debuginfo_in_path): Likewise. * libdwfl/link_map.c (report_r_debug): Likewise. * libdwfl/linux-kernel-modules.c (try_kernel_name): Likewise. * src/addr2line.c (print_dwarf_function): Likewise. (print_src): Likewise. * src/ar.c (do_oper_insert): Likewise. And cast away const in entry.key assignment. * src/nm.c (show_symbols): Use xbasename. * src/stack.c (module_callback): Likewise. * src/strip.c (handle_elf): Likewise. * tests/show-die-info.c: Include system.h. (dwarf_tag_string): Use xbasename. * tests/varlocs.c: Likewise. * debuginfod/debuginfod.cxx: Move include system.h to the end. (register_file_name): Rename basename to filename. Signed-off-by: Khem Raj <raj.k...@gmail.com> Signed-off-by: Mark Wielaard <m...@klomp.org> BTW. There is a musl tracking bug: https://sourceware.org/bugzilla/show_bug.cgi?id=21002 Could you take a peek at that and say if there are still patches needed either in elfutils or musl? Thanks, Mark