On 07/04/2022 11:56, gabriel.moy...@dlr.de wrote:
On 07/04/2022 10:36, Gabriel Moyano wrote:
diff --git a/cpukit/include/sys/timepps.h
b/cpukit/include/sys/timepps.h index 5703381ffa..a72579d5d7 100644
--- a/cpukit/include/sys/timepps.h
+++ b/cpukit/include/sys/timepps.h
@@ -149,6 +149,12 @@ struct mtx;
#define PPSFLAG_MTX_SPIN 0x01 /* Driver mtx is MTX_SPIN type.
*/
+#ifdef __rtems__
+struct pps_state;
+typedef int (*wait_event_func)(struct pps_state *pps, struct timespec
+timeout); typedef void (*wakeup_func)(struct pps_state *pps); #endif
+/* __rtems__ */
+
struct pps_state {
/* Capture information. */
struct timehands *capth;
@@ -164,6 +170,11 @@ struct pps_state {
int ppscap;
struct timecounter *ppstc;
unsigned ppscount[3];
+#ifdef __rtems__
+ wait_event_func wait_event;
+ wakeup_func wakeup;
+#endif /* __rtems__ */
+
/*
* The following fields are valid if the driver calls pps_init_abi().
*/
Why do we need the typedefs?
Just for clarity
At the moment, they just pollute the namespace. I would remove them
until you have to store the callbacks in a variable.
Please don't change the formatting.
Do you mean that wait_event should be waitevent?
No, please use the FreeBSD coding style.
I would use "wait" and "wakeup", or "wait_for_event" and "send_event".
Please add comments how the callbacks are used and that they shall not
be NULL.
No changes outside the #ifdef __rtems__ markers please.
Sorry, could you point to the changes?
You add blank lines after the #endif.
--
embedded brains GmbH
Herr Sebastian HUBER
Dornierstr. 4
82178 Puchheim
Germany
email: sebastian.hu...@embedded-brains.de
phone: +49-89-18 94 741 - 16
fax: +49-89-18 94 741 - 08
Registergericht: Amtsgericht München
Registernummer: HRB 157899
Vertretungsberechtigte Geschäftsführer: Peter Rasmussen, Thomas Dörfler
Unsere Datenschutzerklärung finden Sie hier:
https://embedded-brains.de/datenschutzerklaerung/
_______________________________________________
devel mailing list
devel@rtems.org
http://lists.rtems.org/mailman/listinfo/devel