Felix, On 11/24/15 3:47 PM, Felix Schumacher wrote: > Am 23.11.2015 um 03:19 schrieb Huxing Zhang: >> Hi fschumacher, >> >> Just a friendly reminder that I had a discussion with kkolinko about >> this before. >> I seems that it is better to explicitly define the default value >> rather than the Boolean.getBoolean syntactic sugar. > Thanks for the hint. > > I will change it.
I'm not sure why Konstantin had a strong opinion on this; Boolean.getBoolean has a well-defined default value of Boolean.FALSE. I suppose it's a little more readable when you have the default explicitly in there. But: >> - >> Boolean.getBoolean(System.getProperty("org.apache.tomcat.jdbc.pool.onlyAttemptCurrentClassLoader", >> "false")); This was definitely wrong... it's looking-up the system property called "[something]" or "false" depending upon the value of org.apache.tomcat.jdbc.pool.onlyAttemptCurrentClassLoader. This is what was intended: Boolean.valueOf(System.getProperty("org.apache.tomcat.jdbc.pool.onlyAttemptCurrentClassLoader","false") >> + >> Boolean.getBoolean("org.apache.tomcat.jdbc.pool.onlyAttemptCurrentClassLoader"); ... and I have no objection to the above. -chris --------------------------------------------------------------------- To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org For additional commands, e-mail: dev-h...@tomcat.apache.org