theraven added a comment. In https://reviews.llvm.org/D39365#910622, @mstorsjo wrote:
> In https://reviews.llvm.org/D39365#910590, @theraven wrote: > > > This makes things worse for us. On CHERI, `[u]intptr_t` is a (`typedef` > > for a) built-in type that can hold a capability. Having `unw_word_t` be > > `uintptr_t` > > > For understanding, I guess you meant "Having `unw_word_t` be `uint64_t`" > here? Because othewise, that's exactly the change I'm doing - currently it's > `uint64_t` while I'm proposing making it `uintptr_t` - that you're saying is > easier to work with? Sorry - it looks as if I read the diff back to front. I seem to be less awake than I thought today... Reading the diff the correct way around, this seems like a definite improvement. >> though the use of `PRIxPTR` vs `PRIXPTR` seems inconsistent (as is the >> original use of `%x` vs `%X`. > > Yes, I've kept these as inconsistent as they were originally - if peferred I > can make the ones I touch consistently either upper or lower case. I'd generally prefer `PRIxPTR`, because most of the time I either don't care or want to copy and paste for comparison with objdump output (which uses lower case). https://reviews.llvm.org/D39365 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits