pengfei added inline comments.
================ Comment at: clang/lib/Basic/Targets/X86.h:99 + bool HasAVX10_1 = false; + bool HasAVX10_512BIT = false; bool HasAVX512CD = false; ---------------- goldstein.w.n wrote: > Maybe should be HasAVX10_1_512? As brought up the rfc, there might be an > avx10.2-512 > > Likewise elsewhere, or is this to match GCC? No. `HasAVX10_512BIT` is a single feature which can be combined with `HasAVX10_1`, `HasAVX10_2` etc. AFAIK, GCC chooses the similar idea here. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D157485/new/ https://reviews.llvm.org/D157485 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits