hctim marked an inline comment as done.
hctim added inline comments.

================
Comment at: clang/lib/CodeGen/SanitizerMetadata.cpp:48-50
+  GVSanitizerMetadata Meta;
+  if (GV->hasSanitizerMetadata())
+    Meta = GV->getSanitizerMetadata();
----------------
kstoimenov wrote:
> Would it make sense to create two separate functions something like 
> reportGlobalNew and reportGlobalLegacy to make it more clear which one is 
> which? Then you code will be something like the one below? You can come up 
> with better names for functions, I am sure. 
> 
> ```
> reportGlobal(...) {
>   reportGlobalNew(...);
>   reportGlobalLegacy(...);
> }
> ```
> 
I think there's too much crossover (like calculating `IsExcluded` and setting 
of `Meta.Sanitizer`) to warrant splitting them out; and the follow-up patch is 
going to immediately delete the legacy code anyway :).


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D126929/new/

https://reviews.llvm.org/D126929

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to