compnerd added a comment. This looks good to me. Thanks for picking this up! And thanks for the perf numbers!
================ Comment at: lib/Basic/VirtualFileSystem.cpp:401 @@ +400,3 @@ + IntrusiveRefCntPtr<FileSystem> Base) + : Base(Base) {} + ---------------- Probably can inline this in the header. ================ Comment at: lib/Basic/VirtualFileSystem.cpp:410 @@ +409,3 @@ + std::error_code EC; + directory_iterator I = Base->dir_begin(Dir, EC), E; + ---------------- Thats slightly difficult to read (the `E` directory_iterator. ================ Comment at: lib/Basic/VirtualFileSystem.cpp:481 @@ +480,3 @@ + return Base->setCurrentWorkingDirectory(Path); +} + ---------------- These two can probably be inlined into the header. http://reviews.llvm.org/D21113 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits