airlied added inline comments.

================
Comment at: clang/lib/Headers/opencl-c.h:13678
+uintptr_t __ovld atomic_fetch_sub_explicit(volatile __local atomic_uintptr_t 
*object, ptrdiff_t operand, memory_order order, memory_scope scope);
+#endif
+#endif
----------------
Anastasia wrote:
> airlied wrote:
> > Anastasia wrote:
> > > can we annotate `#endif` with a comment, please to improve readability? 
> > > The same applies to other places.
> > Isn't this the same problem we talked about before? how to annotate
> > 
> > #if defined(__opencl_c_generic_address_space)
> > <decls>
> > #else 
> > <alt decls>
> > #endif 
> > 
> > does it make sense to put //defined(__opencl_c_generic_address_space) on 
> > the endif?
> Yes indeed!
with the change to add elif for OPENCL_C_VERSION these now get those comments 
instead of generic address space.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D106778/new/

https://reviews.llvm.org/D106778

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to