abhina.sreeskantharajan requested review of this revision. abhina.sreeskantharajan marked 4 inline comments as done. abhina.sreeskantharajan added inline comments.
================ Comment at: llvm/utils/lit/lit/llvm/config.py:349-354 + if (re.match(r's390x-.*-zos', triple)): + self.config.substitutions.append(('%err_no_such_file_or_directory', '\'EDC5129I No such file or directory.\'')) + elif (re.match(r'.*windows.*', triple)): + self.config.substitutions.append(('%err_no_such_file_or_directory', '\'no such file or directory\'')) + else: + self.config.substitutions.append(('%err_no_such_file_or_directory', '\'No such file or directory\'')) ---------------- jhenderson wrote: > These lines are quite long, so probably want reflowing. > > I wonder if `%errc_...` might be a better name? That way, it ties to the > `std::errc` values these match up with. Thanks, I've changed the error messages to your suggestion. ================ Comment at: llvm/utils/lit/lit/llvm/config.py:369-370 + if hasattr(self.config, 'host_triple'): + self.add_err_msg_substitutions(self.config.host_triple) + ---------------- jhenderson wrote: > Under what conditions can there not be a `host_triple`? In those cases, what > happens to the tests that use the new substitution? This was not defined for lld. I added changes to define this for lld and removed the check. I think this is defined in all the other projects. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95246/new/ https://reviews.llvm.org/D95246 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits