eugenis added inline comments.
================ Comment at: llvm/lib/Transforms/Instrumentation/MemorySanitizer.cpp:3513 + assert(InsPoint); + if (!InsPoint) { + return; ---------------- guiand wrote: > TODO: Remove this redudant call you've already checked it with assert(isa<CallInst>) - which could be changed to isTerminator(), and this could be simplified to NextIRB(CB.getNextNode()). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D85559/new/ https://reviews.llvm.org/D85559 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits