aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land.
LGTM! ================ Comment at: clang-tools-extra/clang-tidy/readability/QualifiedAutoCheck.cpp:262 + << (Var->getType().isLocalVolatileQualified() ? "volatile " : "") + << Var->getName() << FixItHint::CreateInsertion(InsertPos, "const "); + } ---------------- Not specific to this patch, so feel free to address in another one -- I think you should be passing `Var` instead of `Var->getName()` -- the diagnostics engine does magic to format the name properly for any `NamedDecl`, including proper quoting. (Similar applies elsewhere.) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D73548/new/ https://reviews.llvm.org/D73548 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits