xazax.hun added inline comments.

================
Comment at: lib/StaticAnalyzer/Core/MemRegion.cpp:636
@@ +635,3 @@
+std::string MemRegion::getVariableName() const {
+  std::string VariableName{""};
+  std::string ArrayIndices{""};
----------------
Small nit, I prefer to call the default constructor here.

================
Comment at: lib/StaticAnalyzer/Core/MemRegion.cpp:638
@@ +637,3 @@
+  std::string ArrayIndices{""};
+  const clang::ento::MemRegion *R = this;
+  llvm::SmallString<50> buf;
----------------
Small nit: the mentioning the namespaces explicitly here and for smallstring 
and at some other places is redundant.


http://reviews.llvm.org/D16044



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to