hliao added a comment. In D63335#1543854 <https://reviews.llvm.org/D63335#1543854>, @tra wrote:
> In D63335#1543845 <https://reviews.llvm.org/D63335#1543845>, @hliao wrote: > > > it's requested from debugger people. they don't want to the host-side stub > > could match the device-side kernel function name. the previous scheme > > cannot prevent that. > > > I understand that you want a different name for the stub. My question is why > the ".stub" suffix was not sufficient and how does having a prefix instead > helps? Making the name un-demangleable is undesirable, IMO. There should be a > good reason to justify it. Is it OK for us to mangle `__device_stub __` as the nested name into the original one, says, we prepend `_ZN15__device_stub__E`, so that we have `_ZN15__device_stub__E10kernelfuncIiEvv` and $ c++filt _ZN15__device_stub__E10kernelfuncIiEvv __device_stub__(kernelfunc<int>, void, void) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63335/new/ https://reviews.llvm.org/D63335 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits