Marin Ramesa, le Sun 08 Dec 2013 12:40:09 +0100, a écrit : > Member n_strx can be used instead of strx.
But that's less readable. A variable here is really not a problem, the compiler will most probably put it in a register anyway. > * ddb/db_aout.c (aout_db_sym_init): Remove unnecessary variable. > > --- > ddb/db_aout.c | 10 ++++------ > 1 file changed, 4 insertions(+), 6 deletions(-) > > diff --git a/ddb/db_aout.c b/ddb/db_aout.c > index 9e1c3d4..5cb3911 100644 > --- a/ddb/db_aout.c > +++ b/ddb/db_aout.c > @@ -101,15 +101,13 @@ aout_db_sym_init(symtab, esymtab, name, task_addr) > #undef round_to_size > > for (sp = sym_start; sp < sym_end; sp++) { > - long strx; > - strx = sp->n_un.n_strx; > - if (strx != 0) { > - if (strx > strlen) { > - db_printf("Bad string table index (%#x)\n", strx); > + if (sp->n_un.n_strx != 0) { > + if (sp->n_un.n_strx > strlen) { > + db_printf("Bad string table index (%#x)\n", > sp->n_un.n_strx); > sp->n_un.n_name = 0; > continue; > } > - sp->n_un.n_name = strtab + strx; > + sp->n_un.n_name = strtab + sp->n_un.n_strx; > } > } > > -- > 1.8.1.4 > > -- Samuel <s> je la connaissais pas celle la : "make: Entering an unknown directory" -+- #ens-mim -+-