Variable 'found' already receives values TRUE and FALSE, so why not make
it a boolean.

* device/dev_name.c: Use boolean_t instead of an int.

---
 device/dev_name.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/device/dev_name.c b/device/dev_name.c
index a9056ff..dc5f835 100644
--- a/device/dev_name.c
+++ b/device/dev_name.c
@@ -216,7 +216,7 @@ boolean_t dev_change_indirect(iname, dname, unit)
 {
     struct dev_ops *dp;
     struct dev_indirect *di;
-    int found = FALSE;
+    boolean_t found = FALSE;
 
     dev_search(dp) {
        if (!strcmp(dp->d_name,dname)) {
-- 
1.8.1.4


Reply via email to