I would argue that it should be:
first <- function(x, ...) head(x, n=1L, ...)
So it's simpler and we don't have people using first() and head()
interchangeably for non-default 'n'. first() should mean "the" first. That
also avoids forcing 'n' to be in the formals of every generic+method. Of
cours
On Thu, Apr 30, 2015 at 3:44 AM, Martin Maechler <
maech...@lynne.stat.math.ethz.ch> wrote:
[...]
>
> If I have understood your main point correctly, you are
> suggesting that 'R CMD check' should start putting out a NOTE
> when package code calls a function from one of a set of
> "standard packa