On Friday 13 August 2010, Richard Moore wrote:
> bool openFile() { return true; }; inline method and dubious
This one is actually OK in ReadOnlyPart derived classes.
If you reimplement openUrl(), then openFile() can be just "return false" (the
docs say to return false, not true, but it really doe
On Thursday, August 12, 2010, Ryan Rix wrote:
> I've moved PlasmaKPart, a KPart which can be used by any application who
> wishes to enable a dashboard/summary page in their application, into
i don't think that the config UI should be in the kpart. it's likely going
to be different for each app.
On Friday, August 13, 2010, Richard Moore wrote:
> Note that the dpointer issues matter since people will have to link
> directly to the class to make use of the methods that are not standard
> kpart ones so binary compatibility would be needed. An alternative
> would be to use a KParts extension f
- KPartView
This is a bad name to have in an unnamespaced class. Rename to
KPartPlasmaView perhaps?
KConfigGroup config() - missing docs and should not be inline
static int mainViewId() { return 1; } broken by design it appears
No dpointers
- PlasmaKPart
Not in namespace and no K prefix. Dubi