D20257: Fix incorrect vertical spacing between main layout and individual wallpaper plugins

2019-04-04 Thread Nathaniel Graham
ngraham accepted this revision. ngraham added a comment. This revision is now accepted and ready to land. Yep, looks like the correct solution to me. Nice find! REPOSITORY R119 Plasma Desktop BRANCH beautiful-vertical-spacing (branched from master) REVISION DETAIL https://phabricator.k

D20186: [libinput-touchpad-kcm] Use wayland specific touchpad KCM UI when libinput is used on X11

2019-04-04 Thread Roman Gilg
romangg requested changes to this revision. romangg added a comment. This revision now requires changes to proceed. Nice work. Most of the stuff in libinputtouchpad.cpp and its header file are copy-paste from the Wayland backend. It would make sense to have a new abstract parent class such th

D20237: Port to new KWorkspace API

2019-04-04 Thread David Edmundson
davidedmundson added a comment. > Personally I tend to prefer just readable, explicit code for simple cases. Now the timing of my comment becomes awkward :/ INLINE COMMENTS > systementry.cpp:86 > +{ > +++s_instanceCount; > you increment this on every refresh, only decrement once i

D20256: Add --replace option in krunner

2019-04-04 Thread Aleix Pol Gonzalez
This revision was automatically updated to reflect the committed changes. Closed by commit R120:f546973b4ced: Add --replace option in krunner (authored by apol). REPOSITORY R120 Plasma Workspace CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D20256?vs=55435&id=55444 REVISION DETAIL

D20257: Fix incorrect vertical spacing between main layout and individual wallpaper plugins

2019-04-04 Thread Filip Fila
filipf updated this revision to Diff 55443. filipf added a comment. apparently anchoring the stack view wasn't the only solution; settings spacing to 0 achieves the same result and doesn't spew out an "anchors in a layout" error REPOSITORY R119 Plasma Desktop CHANGES SINCE LAST UPDATE h

D20257: Fix incorrect vertical spacing between main layout and individual wallpaper plugins

2019-04-04 Thread Filip Fila
filipf added a comment. I know I'm not supposed to anchor items in a layout but this was the only solution I could find for now. REPOSITORY R119 Plasma Desktop REVISION DETAIL https://phabricator.kde.org/D20257 To: filipf, hein, mart, #plasma, ngraham Cc: plasma-devel, jraleigh, GB_2, r

D20257: Fix incorrent vertical spacing between main layout and individual wallpaper plugins

2019-04-04 Thread Filip Fila
filipf created this revision. Herald added a project: Plasma. Herald added a subscriber: plasma-devel. filipf requested review of this revision. REVISION SUMMARY As elaborated in D19873 the vertical spacing between the master form layout and a specific wallp

D20237: Port to new KWorkspace API

2019-04-04 Thread Eike Hein
hein added inline comments. INLINE COMMENTS > broulik wrote in systementry.cpp:26 > QSharedPointer :P Personally I tend to prefer just readable, explicit code for simple cases. REPOSITORY R119 Plasma Desktop BRANCH master REVISION DETAIL https://phabricator.kde.org/D20237 To: hein, #pl

D20237: Port to new KWorkspace API

2019-04-04 Thread Eike Hein
hein updated this revision to Diff 55440. hein added a comment. Do some cleanups suggested by Kai. Invert the enabled state role to please Aleix' eyes. REPOSITORY R119 Plasma Desktop CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D20237?vs=55381&id=55440 BRANCH master REVI

D20237: Port to new KWorkspace API

2019-04-04 Thread Eike Hein
hein added inline comments. INLINE COMMENTS > apol wrote in ItemGridDelegate.qml:33 > so model.enabled you want it to resolve to true? This will be hard to read to > anyone who isn't you. > > How about `model.hasOwnProperty("enabled") && model.enabled`? Or `typeof > model.enabled === "undefine

D20186: [libinput-touchpad-kcm] Use wayland specific touchpad KCM UI when libinput is used on X11

2019-04-04 Thread Nathaniel Graham
ngraham added a comment. In D20186#443262 , @knambiar wrote: > >> I happen to be the ‘accidental’ maintainer of the Touchpad KCM. I’d be more than happy to hand that hat over if you wish to maintain this code. :-D > > > > Hey, I would be hap

D20237: Port to new KWorkspace API

2019-04-04 Thread Eike Hein
hein added inline comments. INLINE COMMENTS > broulik wrote in KickoffItem.qml:31 > This means we now show all logout options and only disable them if not > supported? Yep. REPOSITORY R119 Plasma Desktop BRANCH master REVISION DETAIL https://phabricator.kde.org/D20237 To: hein, #plasm

D19209: [sddm-kcm] Adjust Background label and button

2019-04-04 Thread Björn Feber
GB_2 commandeered this revision. GB_2 edited reviewers, added: rooty; removed: GB_2. GB_2 added a comment. Ok, thanks. REPOSITORY R123 SDDM Configuration Panel (KCM) REVISION DETAIL https://phabricator.kde.org/D19209 To: GB_2, #vdg, #plasma, filipf, ngraham, rooty Cc: GB_2, abetts, plasm

D19209: [sddm-kcm] Adjust Background label and button

2019-04-04 Thread Filip Fila
filipf updated this revision to Diff 55439. filipf added a comment. attempt to allow for commandeering of the revision REPOSITORY R123 SDDM Configuration Panel (KCM) CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D19209?vs=52256&id=55439 BRANCH arcpatch-D19209 REVISION DETAIL

D19209: [sddm-kcm] Adjust Background label and button

2019-04-04 Thread Filip Fila
filipf added a comment. In D19209#443418 , @GB_2 wrote: > @rooty Can you please reopen this? He is participating in KDE for the time being. You should commandeer the revision. REPOSITORY R123 SDDM Configuration Panel (KCM) REVISION DE

Re: Having an application on the correct screen

2019-04-04 Thread David Edmundson
If the app is positioning themselves, they'd need to know the global mouse position which we don't export. That would be a weird thing to export and trying to re-create X rather than do things properly. layer shell (https://github.com/swaywm/wlr-protocols/blob/master/unstable/wlr-layer-shell-unst

D20237: Port to new KWorkspace API

2019-04-04 Thread Kai Uwe Broulik
broulik added inline comments. INLINE COMMENTS > systementry.cpp:26 > + > +int SystemEntry::s_instanceCount = 0; > +SessionManagement* SystemEntry::s_sessionManagement = nullptr; QSharedPointer :P > systemmodel.cpp:42 > + > +for (SystemEntry *entry : m_entries.values()) { > +QObject

D20237: Port to new KWorkspace API

2019-04-04 Thread Aleix Pol Gonzalez
apol added inline comments. INLINE COMMENTS > hein wrote in ItemGridDelegate.qml:33 > QVariant() evaluates to false, and not all models implement this role to > return `true` by default. Hence the check for an explicit false. > > The alternative would be to patch all the models. so model.enabl

D20198: Don't lose list position after installing KNS cursor themes

2019-04-04 Thread Aleix Pol Gonzalez
apol added a comment. Otherwise makes sense to me. INLINE COMMENTS > kcmcursortheme.cpp:468 > +for (const QString& deleted : entry.uninstalledFiles()) { > +QStringList list = deleted.split(QLatin1Char('/')); > +if (list.last(

D20242: Add flatpak mime types

2019-04-04 Thread Aleix Pol Gonzalez
apol accepted this revision. apol added a comment. This revision is now accepted and ready to land. Thanks! REPOSITORY R134 Discover Software Store REVISION DETAIL https://phabricator.kde.org/D20242 To: eszlari, apol Cc: plasma-devel, jraleigh, GB_2, ragreen, Pitel, ZrenBot, lesliezhai,

Having an application on the correct screen

2019-04-04 Thread Aleix Pol
Hi, He have several applications that aspire to place themselves in the screen where the mouse is. yakuake and krunner pop into my head but I'm sure there's others. At the moment, on wayland they just show up in a random display. Do we have a way to implement that properly? Aleix

D20256: Add --replace option in krunner

2019-04-04 Thread Aleix Pol Gonzalez
apol created this revision. Herald added a project: Plasma. Herald added a subscriber: plasma-devel. apol requested review of this revision. REVISION SUMMARY Useful for developing it. Inspired in the plasmashell --replace option. TEST PLAN Replaced krunner REPOSITORY R120 Plasma Workspac

D20253: [Context] Update StreamRestore before inserting it

2019-04-04 Thread Nicolas Fella
nicolasfella added a comment. If obj already exists this would result in having it in m_streamRestores twice, wouldn't it? REPOSITORY R994 Pulseaudio Qt Bindings REVISION DETAIL https://phabricator.kde.org/D20253 To: broulik, nicolasfella, drosca, sitter Cc: plasma-devel, jraleigh, GB_2

D19392: shannon entropy to guess monochrome icon

2019-04-04 Thread Marco Martin
This revision was not accepted when it landed; it landed in state "Needs Review". This revision was automatically updated to reflect the committed changes. Closed by commit R169:8306d82f0a61: shannon entropy to guess monochrome icon (authored by mart). CHANGED PRIOR TO COMMIT https://phabricat

D20253: [Context] Update StreamRestore before inserting it

2019-04-04 Thread Kai Uwe Broulik
broulik created this revision. broulik added reviewers: nicolasfella, drosca, sitter. Herald added a project: Plasma. Herald added a subscriber: plasma-devel. broulik requested review of this revision. REVISION SUMMARY Otherwise we would signal an empty `StreamRestore` only to then signal it has

D19209: [sddm-kcm] Adjust Background label and button

2019-04-04 Thread Björn Feber
GB_2 added a comment. @rooty Can you please reopen this? REPOSITORY R123 SDDM Configuration Panel (KCM) REVISION DETAIL https://phabricator.kde.org/D19209 To: rooty, #vdg, #plasma, filipf, ngraham, GB_2 Cc: GB_2, abetts, plasma-devel, jraleigh, ragreen, Pitel, ZrenBot, lesliezhai, ali-m

D14147: Port from GConf to GSettings

2019-04-04 Thread Kai Uwe Broulik
broulik reopened this revision. broulik added a comment. This revision is now accepted and ready to land. With this it now aborts here (process:114351): GLib-GIO-ERROR **: 18:24:26.823: Settings schema 'org.freedesktop.pulseaudio.module-group' is not installed REPOSITORY R115 Plasma

D19209: [sddm-kcm] Adjust Background label and button

2019-04-04 Thread Björn Feber
GB_2 added a comment. Is this okay with a form layout? F6753594: Adjusted SDDM KCM Background Label and Button.png If yes, I will take over this revision. REPOSITORY R123 SDDM Configuration Panel (KCM) REVISION DETAIL https://phabricator.kde.org

D20249: Make the Configuration button more understandable

2019-04-04 Thread Michail Vourlakos
mvourlakos added a comment. he will be educated to do so REPOSITORY R878 Latte Dock REVISION DETAIL https://phabricator.kde.org/D20249 To: trmdi, #latte_dock, rooty, mvourlakos Cc: mvourlakos, plasma-devel, jraleigh, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, jensreuterberg

D20249: Make the Configuration button more understandable

2019-04-04 Thread Tranter Madi
trmdi added a comment. In D20249#443373 , @mvourlakos wrote: > I think would prefer a hovering mechanism, a rectangle with transparency e.g. 0.5 when this option is hovered How would the user know it's a button to hover it? He's unlike

D20249: Make the Configuration button more understandable

2019-04-04 Thread Michail Vourlakos
mvourlakos added a comment. I am not sure... I think would prefer a hovering mechanism, a rectangle with transparency e.g. 0.5 when this option is hovered REPOSITORY R878 Latte Dock REVISION DETAIL https://phabricator.kde.org/D20249 To: trmdi, #latte_dock, rooty, mvourlakos Cc: mvourl

D20249: Make the Configuration button more understandable

2019-04-04 Thread Michail Vourlakos
mvourlakos added a comment. screenshots please REPOSITORY R878 Latte Dock REVISION DETAIL https://phabricator.kde.org/D20249 To: trmdi, #latte_dock, rooty Cc: mvourlakos, plasma-devel, jraleigh, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol,

D20249: Make the Configuration button more understandable

2019-04-04 Thread Tranter Madi
trmdi created this revision. trmdi added reviewers: Latte Dock, rooty. Herald added a project: Plasma. Herald added a subscriber: plasma-devel. trmdi requested review of this revision. REVISION SUMMARY Without the button background, it's difficult to realize that it's a button. REPOSITORY R87

D8626: DDCUtil: Improved DDCUtil support for brightness control

2019-04-04 Thread Dorian Vogel
dvogel added a comment. Yes it has to be modified. I got it to compile again over lunch on a laptop, however could not test it (has to be on a desktop, since powerdevil picks integrated screens first for brightness). REPOSITORY R122 Powerdevil REVISION DETAIL https://phabricator.kde.org

D8626: DDCUtil: Improved DDCUtil support for brightness control

2019-04-04 Thread Nathaniel Graham
ngraham added a comment. So does this patch need revision now? REPOSITORY R122 Powerdevil REVISION DETAIL https://phabricator.kde.org/D8626 To: dvogel, broulik, davidedmundson Cc: ngraham, asturmlechner, plasma-devel, jraleigh, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, jen

Re: Plasma Dev Docs questions

2019-04-04 Thread David Edmundson
> What areas have received the most interest from new developers? What have > been their most frequently asked questions? Not quite "plasma", but Kirigami and making QtQuick apps which include targeting plasma mobile is definitely the biggest area > - What problems has the team had with the curr

D20237: Port to new KWorkspace API

2019-04-04 Thread Eike Hein
hein added inline comments. INLINE COMMENTS > apol wrote in ItemGridDelegate.qml:33 > `enabled: model.enabled` no? QVariant() evaluates to false, and not all models implement this role to return `true` by default. Hence the check for an explicit false. The alternative would be to patch all the

Re: Plasma Dev Docs questions

2019-04-04 Thread Jonathan Riddell
This long term todo item is yet to be done https://phabricator.kde.org/T2022 On Thu, 4 Apr 2019 at 13:14, Juan Carlos Torres wrote: > > Greetings Plasmates! > > Since Plasma is the KDE Desktop, it is probably one of the first experiences > budding developers have with our software. It has probab

Plasma Dev Docs questions

2019-04-04 Thread Juan Carlos Torres
Greetings Plasmates! Since Plasma is the KDE Desktop, it is probably one of the first experiences budding developers have with our software. It has probably seen its fair share of interested contributors and even "external", third-party developers of plasmoids and alternative shells. If it's not t

D20248: Update link to Kdelibs_Coding_Style

2019-04-04 Thread Méven Car
meven created this revision. Herald added a project: Plasma. Herald added a subscriber: plasma-devel. meven requested review of this revision. REPOSITORY R120 Plasma Workspace BRANCH master REVISION DETAIL https://phabricator.kde.org/D20248 AFFECTED FILES HACKING To: meven Cc: plasma-d

D20198: Don't lose list position after installing KNS cursor themes

2019-04-04 Thread Dan Leinir Turthra Jensen
leinir marked 4 inline comments as done. leinir added inline comments. INLINE COMMENTS > apol wrote in kcmcursortheme.cpp:472 > Maybe another solution would be having the model insert/remove instead of > resetting, although that works too I guess. New patch does this - less invasive change as w

D20198: Don't lose list position after installing KNS cursor themes

2019-04-04 Thread Dan Leinir Turthra Jensen
leinir updated this revision to Diff 55403. leinir edited the summary of this revision. leinir edited the test plan for this revision. leinir added a comment. Less invasive change, but with more (what seem like fairly reasonable) assumptions. We now operate explicitly on installed and uninstal

D20186: [libinput-touchpad-kcm] Use wayland specific touchpad KCM UI when libinput is used on X11

2019-04-04 Thread Rajeesh K Nambiar
knambiar added a subscriber: jriddell. knambiar added a comment. >> I happen to be the ‘accidental’ maintainer of the Touchpad KCM. I’d be more than happy to hand that hat over if you wish to maintain this code. :-D > > Hey, I would be happy to take that responsibility. Fantastic.