On Tue, Feb 21, 2017 at 11:18:04PM +0200, Sagi Grimberg wrote:
> I can maybe do something like:
>
> if (af == AF_INET || af == AF_UNSPEC) {
> ret = inet4_pton();
> if (!ret)
> return 0;
> else if (af != AF_UNSPEC)
> return ret;
> }
>
> if (af == AF_IN
On 19/02/17 19:15, Christoph Hellwig wrote:
On Thu, Feb 16, 2017 at 07:43:34PM +0200, Sagi Grimberg wrote:
Several locations in the stack need to handle ipv4/ipv6
(with scope) and port strings conversion to sockaddr.
Add a helper that takes either AF_INET, AF_INET6 or
AF_UNSPEC (for wildcard)
On Thu, Feb 16, 2017 at 07:43:34PM +0200, Sagi Grimberg wrote:
> Several locations in the stack need to handle ipv4/ipv6
> (with scope) and port strings conversion to sockaddr.
> Add a helper that takes either AF_INET, AF_INET6 or
> AF_UNSPEC (for wildcard) to centralize this handling.
>
> Suggest
Hi Sagi,
[auto build test WARNING on linus/master]
[also build test WARNING on v4.10-rc8 next-20170216]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Sagi-Grimberg/Introduce-a-new-helper-for-pa