On Fri, 2006-08-25 at 12:30 +0200, Thomas Graf wrote:
> That's exactly what I would have done as well.
Alright. Changing it, then I'll repost. Again :)
johannes
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info a
* Johannes Berg <[EMAIL PROTECTED]> 2006-08-25 11:04
> I completely reworked that now so it will:
> * create a nested NL80211_ATTR_INTERFACE_LIST with nested {
>* 1..N attributes, with nested {
> * ATTR_IFINDEX and
> * ATTR_IFNAME
>}
> }
>
> how does that sound? Maybe I should
On Thu, 2006-08-24 at 19:27 +0200, Thomas Graf wrote:
> I'd use normal u32 attributes here as well and simply
> enumerate their type 1..n.
>
> int idx = 1
> list_for_each_entry(drv, &nl80211_drv_list, list)
> NLA_PUT_U32(msg, idx++, drv->wiphy);
>
> The additional heade
* Johannes Berg <[EMAIL PROTECTED]> 2006-08-24 18:07
> +static int nl80211_get_cmdlist(struct sk_buff *skb, struct genl_info *info)
> +{
> + struct nl80211_registered_driver *drv;
> + struct sk_buff *msg;
> + void *hdr;
> + int err;
> + struct nlattr *start;
> + u8 *data;
>
This patch adds nl80211, a netlink based configuration
system for wireless hardware.
It currently features a few helper commands and commands to
add and remove virtual interfaces and to inject packets.
Support for nl80211 in d80211 is in a follow-up patch.
It requires the patches in
http://marc.t
On Thu, 2006-08-24 at 16:36 +0200, Thomas Graf wrote:
> Might want to put this in a header so userspace can see the limit.
Good point, thanks.
> In your case I'd call it GET_CMDLIST and NEW_CMDLIST which
> means you request a command list with GET_CMDLIST and
> receive the answer with a CMD_NEWL
* Johannes Berg <[EMAIL PROTECTED]> 2006-08-22 15:52
> +static struct nla_policy nl80211_policy[NL80211_ATTR_MAX+1] __read_mostly = {
> + [NL80211_ATTR_IFINDEX] = { .type = NLA_U32 },
> + [NL80211_ATTR_WIPHY] = { .type = NLA_U32 },
> + [NL80211_ATTR_FLAGS] = { .type = NLA_U32 },
> +
On Thu, 2006-08-24 at 15:32 +0200, Jiri Benc wrote:
> > + int (*add_virtual_intf)(void *priv, char *name);
>
> What about initial interface type? (Hm, maybe it can be fixed to a STA
> mode, but it should be documented somewhere at least.)
Actually, I already changed that.
> > + int (
On Tue, 22 Aug 2006 15:52:47 +0200, Johannes Berg wrote:
> [...]
> + int (*add_virtual_intf)(void *priv, char *name);
What about initial interface type? (Hm, maybe it can be fixed to a STA
mode, but it should be documented somewhere at least.)
> + int (*del_virtual_intf)(void *pri
On Tue, 2006-08-22 at 15:52 +0200, Johannes Berg wrote:
> + dev = dev_get_by_index(ifindex);
> + result = nl80211_drv_by_priv_locked(dev->ieee80211_ptr);
> + dev_put(dev);
> + if (result)
> + return result;
> + err = -E
On Tue, 2006-08-22 at 15:52 +0200, Johannes Berg wrote:
> + /* make it complain if wiphy is set and is different or invalid */
> + if (info->attrs[NL80211_ATTR_IFINDEX]) {
> + wiphy = nla_get_u32(info->attrs[NL80211_ATTR_IFINDEX]);
That's what you get for writing code too quick
This patch adds nl80211, a netlink based configuration
system for wireless hardware.
It currently features a few helper commands and commands to
add and remove virtual interfaces and to inject packets.
Support for nl80211 in d80211 is in a follow-up patch.
It requires the patches in
http://marc.t
12 matches
Mail list logo