Mainly nits...
Steve Wise wrote:
-static int copy_addr(struct rdma_dev_addr *dev_addr, struct net_device *dev,
+int copy_addr(struct rdma_dev_addr *dev_addr, struct net_device *dev,
unsigned char *dst_dev_addr)
Might want to rename this to something like rdma_copy_addr if
On Wed, 2006-05-31 at 12:17 -0700, Roland Dreier wrote:
> > +EXPORT_SYMBOL(copy_addr);
>
> I think if you want to export this, it needs a less generic name
> (something with an rdma_ prefix probably). Otherwise it's going to
> collide someday...
ok.
The function is needed by the iwcm module,
Steve> The function is needed by the iwcm module, so that's why we
Steve> exported it. I could change the name to rdma_copy_addr(),
Steve> or make the function a static inline in a header file since
Steve> its kinda small anyway...
It looks too big to inline to me, and I don't thi
> +EXPORT_SYMBOL(copy_addr);
I think if you want to export this, it needs a less generic name
(something with an rdma_ prefix probably). Otherwise it's going to
collide someday...
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
Mo
This patch contains modifications to the existing rdma header files,
core files, drivers, and ulp files to support iWARP.
---
drivers/infiniband/core/Makefile |4
drivers/infiniband/core/addr.c |8 -
drivers/infiniband/core/cache.c |8 -
driver