Re: [PATCH 4/9] net/can: can_dropped_invalid_skb can be boolean

2015-10-09 Thread Yaowei Bai
On Fri, Oct 09, 2015 at 12:14:31PM +0200, Marc Kleine-Budde wrote: > On 10/08/2015 03:28 PM, Yaowei Bai wrote: > > This patch makes can_dropped_invalid_skb return bool due to this > > particular function only using either one or zero as its return > > value. > >

[PATCH 5/9] net/dccp: dccp_list_has_service can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes dccp_list_has_service return bool due to this particular function only using either one or zero as its return value. No functional change. Signed-off-by: Yaowei Bai --- include/linux/dccp.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/include/linux

[PATCH 6/9] net/dccp: dccp_bad_service_code can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes dccp_bad_service_code return bool due to these particular functions only using either one or zero as their return value. dccp_list_has_service is also been made return bool in this patchset. No functional change. Signed-off-by: Yaowei Bai --- net/dccp/dccp.h | 4 ++-- 1 file

[PATCH 8/9] net/inetdevice: bad_mask can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes bad_mask return bool due to this particular function only using either one or zero as its return value. No functional change. Signed-off-by: Yaowei Bai --- include/linux/inetdevice.h | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/include/linux

[PATCH 9/9] net/core: lockdep_rtnl_is_held can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes lockdep_rtnl_is_held return bool due to this particular function only using either one or zero as its return value. In another patch lockdep_is_held is also made return bool. No functional change. Signed-off-by: Yaowei Bai --- include/linux/rtnetlink.h | 6 +++--- net/core

[PATCH 2/9] net/ieee80211: ieee80211_is_* can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes ieee80211_is_* return bool to improve readability due to these particular functions only using either one or zero as their return value. No functional change. Signed-off-by: Yaowei Bai --- include/linux/ieee80211.h | 76 +++ 1 file

[PATCH 3/9] net/nfnetlink: lockdep_nfnl_is_held can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes lockdep_nfnl_is_held return bool to improve readability due to this particular function only using either one or zero as its return value. No functional change. Signed-off-by: Yaowei Bai --- include/linux/netfilter/nfnetlink.h | 6 +++--- net/netfilter/nfnetlink.c

[PATCH 7/9] net/inetdevice: inet_ifa_match can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes inet_ifa_match return bool due to this particular function only using either one or zero as its return value. No functional change. Signed-off-by: Yaowei Bai --- include/linux/inetdevice.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux

[PATCH 4/9] net/can: can_dropped_invalid_skb can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes can_dropped_invalid_skb return bool due to this particular function only using either one or zero as its return value. No functional change. Signed-off-by: Yaowei Bai --- include/linux/can/dev.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/include

[PATCH 1/9] net/netlink: lockdep_genl_is_held can be boolean

2015-10-08 Thread Yaowei Bai
This patch makes lockdep_genl_is_held return bool to improve readability due to this particular function only using either one or zero as its return value. No functional change. Signed-off-by: Yaowei Bai --- include/linux/genetlink.h | 2 +- net/netlink/genetlink.c | 2 +- 2 files changed, 2

[PATCH 0/9] net: small improvement

2015-10-08 Thread Yaowei Bai
This patchset makes several functions in net return bool to improve readability and/or simplicity because these functions only use one or zero as their return value. No functional changes. Yaowei Bai (9): net/netlink: lockdep_genl_is_held can be boolean net/ieee80211: ieee80211_is_* can be