For consistency with the behaviour of the arp_ip_target option,
let /sys/class/net/bond0/bonding/xmit_hash_policy accept and report
current policy even if the bonding mode in effect does not use it.
Signed-off-by: Ferenc Wagner <[EMAIL PROTECTED]>
---
drivers/net/bonding/bond_sysfs.c | 21 +++--
Signed-off-by: Ferenc Wagner <[EMAIL PROTECTED]>
---
drivers/net/bonding/bond_sysfs.c |9 ++---
1 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/net/bonding/bond_sysfs.c b/drivers/net/bonding/bond_sysfs.c
index 5c31f5c..9de2c52 100644
--- a/drivers/net/bonding/bond_sy
Code for rendering multivalue sysfs files occurs three times
in this module. Rename 'buffer' to 'buf' in the first, for
the sake of consistency.
Signed-off-by: Ferenc Wagner <[EMAIL PROTECTED]>
---
drivers/net/bonding/bond_sysfs.c |9 -
1 files changed, 4 insertions(+), 5 deletions(-
The previous code returned '\n' (that is, a single empty line)
from most files, with one exception (xmit_hash_policy), where
it returned 'NA\n'. This patch consolidates each file to return
nothing at all if not applicable, not even a '\n'.
I find this behaviour more usual, more useful, more effic
Also remove trailing spaces from multivalued files.
This fixes output like for example:
$ od -c /sys/class/net/bond0/bonding/slaves
000 e t h - l e f t e t h - r i g
020 h t \n \0
025
It mostly entails deleting '+1'-s after sprintf() calls:
Randy Dunlap <[EMAIL PROTECTED]> writes:
> On Wed, 28 Nov 2007 01:49:54 +0100 =?utf-8?q?Ferenc_W=C3=A1gner?= wrote:
>
> Patches 1 & 3 use
>
> if (res) statement;
>
> but the preferred form is
>
> if (res)
> statement;
>
> Even if this style was already used in the source
Andrew Morton <[EMAIL PROTECTED]> writes:
> On Tue, 27 Nov 2007 10:56:43 +0100 Ferenc Wagner <[EMAIL PROTECTED]> wrote:
>
>>> - raise patches against the latest Linus tree
>>> (ftp://ftp.kernel.org/pub/linux/kernel/v2.6/snapshots/)
>>
>> I thought it was better to change to git. Isn't it so?
>>
Andrew Morton <[EMAIL PROTECTED]> writes:
> On Sun, 25 Nov 2007 16:12:57 +0100 Wagner Ferenc <[EMAIL PROTECTED]> wrote:
>
>> I propose it as a fix for trailing NULs and spaces like eg.
>>
>> $ od -c /sys/class/net/bond0/bonding/slaves
>> 000 e