original code and
change the 'if' in a 'while'.
In Guillaume's patch,
"while (__delta > USEC_PER_SEC){ ... }", but I think it should be
"while (__delta >= USEC_PER_SEC){ ... }". Is it right?
Thank you very much.
--
Shuya MAEDA
-
To unsubscribe fr
Excuse me for the corrupted patch. I will send the patch as an
attachment this time.
Thank you very much.
David Miller wrote:
> From: Shuya MAEDA <[EMAIL PROTECTED]>
> Date: Wed, 21 Jun 2006 09:16:03 +0900
>
>> Thank you for the comment.
>> I made the patch that u
Thank you for the comment.
I made the patch that used the loop instead of the divide and modulus.
Are there any comments?
David Miller wrote:
From: Shuya MAEDA <[EMAIL PROTECTED]>
Date: Mon, 19 Jun 2006 14:36:46 +0900
#define PSCHED_TADD2(tv, delta, tv_res) \
({ \
- int _
/ USEC_PER_SEC; \
+__delta -= (delta) % USEC_PER_SEC; \
+ } \
+ (tv).tv_usec += __delta; \
+ if((tv).tv_usec >= USEC_PER_SEC) { \
+(tv).tv_sec++; \
+(tv).tv_usec -= USEC_PER_SEC; \
+ } \
})
/* Set/check