Re: [PATCH net-next v5 07/16] bpf: Add setsockopt helper function to bpf

2017-07-01 Thread kbuild test robot
Hi Lawrence, [auto build test ERROR on net-next/master] url: https://github.com/0day-ci/linux/commits/Lawrence-Brakmo/bpf-Adding-support-for-sock_ops/20170701-203039 config: x86_64-randconfig-i0-07010430 (attached as .config) compiler: gcc-4.9 (Debian 4.9.4-2) 4.9.4 reproduce: # save

Way to Know When cleanup_net() Calls Are Done

2017-07-01 Thread Leon Yang
Hi, I am measuring the time cost of parallel creation and destruction of net namespaces. As cleanup_net() is invoked from workqueue, the exit of a net namespace does not mean the cleanup is completed. Therefore I use ftrace to count the number of net_drop_ns() are called. But I found that the num

Re: [PATCH RFC 21/26] powerpc: Remove spin_unlock_wait() arch-specific definitions

2017-07-01 Thread Boqun Feng
On Thu, Jun 29, 2017 at 05:01:29PM -0700, Paul E. McKenney wrote: > There is no agreed-upon definition of spin_unlock_wait()'s semantics, > and it appears that all callers could do just as well with a lock/unlock > pair. This commit therefore removes the underlying arch-specific > arch_spin_unlock

[net-next:master 1849/1910] net/iucv/af_iucv.c:405:22: error: passing argument 1 of 'atomic_read' from incompatible pointer type

2017-07-01 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next.git master head: bcdb239b456265b927a809c4078f0a1f433a6e18 commit: 14afee4b6092fde451ee17604e5f5c89da33e71e [1849/1910] net: convert sock.sk_wmem_alloc from atomic_t to refcount_t config: s390-default_defconfig (attached as .

[net-next:master 1847/1910] drivers/s390/net/ctcm_fsms.c:220:14: error: passing argument 2 of 'atomic_add' from incompatible pointer type

2017-07-01 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next.git master head: bcdb239b456265b927a809c4078f0a1f433a6e18 commit: 633547973ffc32fd2c815639d4675e1531f0896f [1847/1910] net: convert sk_buff.users from atomic_t to refcount_t config: s390-default_defconfig (attached as .confi

Re: [PATCH RFC 06/26] ipc: Replace spin_unlock_wait() with lock/unlock pair

2017-07-01 Thread Paul E. McKenney
On Sat, Jul 01, 2017 at 09:23:03PM +0200, Manfred Spraul wrote: > On 06/30/2017 02:01 AM, Paul E. McKenney wrote: > >There is no agreed-upon definition of spin_unlock_wait()'s semantics, > >and it appears that all callers could do just as well with a lock/unlock > >pair. This commit therefore repl

Re: [PATCH RFC 01/26] netfilter: Replace spin_unlock_wait() with lock/unlock pair

2017-07-01 Thread Paul E. McKenney
On Sat, Jul 01, 2017 at 09:44:12PM +0200, Manfred Spraul wrote: > Hi Paul, > > On 06/30/2017 02:01 AM, Paul E. McKenney wrote: > >There is no agreed-upon definition of spin_unlock_wait()'s semantics, > >and it appears that all callers could do just as well with a lock/unlock > >pair. This commit

[PATCH net-next 1/7] bpf, net: add skb_mac_header_len helper

2017-07-01 Thread Daniel Borkmann
Add a small skb_mac_header_len() helper similarly as the skb_network_header_len() we have and replace open coded places in BPF's bpf_skb_change_proto() helper. Will also be used in upcoming work. Signed-off-by: Daniel Borkmann Acked-by: John Fastabend Acked-by: Alexei Starovoitov --- include/l

[PATCH net-next 3/7] bpf: simplify narrower ctx access

2017-07-01 Thread Daniel Borkmann
This work tries to make the semantics and code around the narrower ctx access a bit easier to follow. Right now everything is done inside the .is_valid_access(). Offset matching is done differently for read/write types, meaning writes don't support narrower access and thus matching only on offsetof

[PATCH net-next 5/7] bpf: extend bpf_trace_printk to support %i

2017-07-01 Thread Daniel Borkmann
From: John Fastabend Currently, bpf_trace_printk does not support common formatting symbol '%i' however vsprintf does and is what eventually gets called by bpf helper. If users are used to '%i' and currently make use of it, then bpf_trace_printk will just return with error without dumping anythin

[PATCH net-next 4/7] bpf: export whether tail call has jited owner

2017-07-01 Thread Daniel Borkmann
We do export through fdinfo already whether a prog is JITed or not, given a program load can fail in case of either prog or tail call map has JITed property, but neither both are JITed or not JITed, we can facilitate error reporting in loaders like iproute2 through exporting owner_jited of tail cal

[PATCH net-next 2/7] bpf: add bpf_skb_adjust_room helper

2017-07-01 Thread Daniel Borkmann
This work adds a helper that can be used to adjust net room of an skb. The helper is generic and can be further extended in future. Main use case is for having a programmatic way to add/remove room to v4/v6 header options along with cls_bpf on egress and ingress hook of the data path. It reuses mos

[PATCH net-next 7/7] bpf: add various test cases for verifier selftest

2017-07-01 Thread Daniel Borkmann
Add couple of verifier test cases for x|imm += pkt_ptr, including the imm += x extension. Signed-off-by: Daniel Borkmann Acked-by: John Fastabend Acked-by: Alexei Starovoitov --- tools/testing/selftests/bpf/test_verifier.c | 165 1 file changed, 165 insertions(+)

[PATCH net-next 6/7] bpf, verifier: add additional patterns to evaluate_reg_imm_alu

2017-07-01 Thread Daniel Borkmann
From: John Fastabend Currently the verifier does not track imm across alu operations when the source register is of unknown type. This adds additional pattern matching to catch this and track imm. We've seen LLVM generating this pattern while working on cilium. Signed-off-by: John Fastabend Ack

[PATCH net-next 0/7] Misc BPF helper/verifier improvements

2017-07-01 Thread Daniel Borkmann
Miscellanous improvements I still had in my queue, it adds a new bpf_skb_adjust_room() helper for cls_bpf, exports to fdinfo whether tail call array owner is JITed, so iproute2 error reporting can be improved on that regard, a small cleanup and extension to trace printk, two verifier patches, one t

Re: [PATCH net-next v6 00/16] bpf: Adds support for sock_ops

2017-07-01 Thread David Miller
From: Lawrence Brakmo Date: Fri, 30 Jun 2017 20:02:39 -0700 > Created a new BPF program type, BPF_PROG_TYPE_SOCK_OPS, and a corresponding > struct that allows BPF programs of this type to access some of the > socket's fields (such as IP addresses, ports, etc.) and setting > connection parameters

Re: [PATCH net-next v6 00/16] bpf: Adds support for sock_ops

2017-07-01 Thread Daniel Borkmann
On 07/01/2017 05:02 AM, Lawrence Brakmo wrote: [...] v6: fixes to BPF helper function setsockopt (possible NULL deferencing, etc.) Thanks for fixing up, BPF side looks good to me.

Re: pull request: bluetooth-next 2017-07-01

2017-07-01 Thread David Miller
From: Johan Hedberg Date: Sat, 1 Jul 2017 21:19:50 +0300 > Here are some more Bluetooth patches for the 4.13 kernel: > > - Added support for Broadcom BCM43430 controllers > - Added sockaddr length checks before accessing sa_family > - Fixed possible "might sleep" errors in bnep, cmtp and hidp

Re: [PATCH v3] sctp: Add peeloff-flags socket option

2017-07-01 Thread David Miller
From: Neil Horman Date: Fri, 30 Jun 2017 13:32:57 -0400 > Based on a request raised on the sctp devel list, there is a need to > augment the sctp_peeloff operation while specifying the O_CLOEXEC and > O_NONBLOCK flags (simmilar to the socket syscall). Since modifying the > SCTP_SOCKOPT_PEELOFF s

Re: [PATCH net-next 0/2] sfc: small MCDI cleanups

2017-07-01 Thread David Miller
From: Edward Cree Date: Fri, 30 Jun 2017 15:52:58 +0100 > Giving the full MCDI event rather than just the code can aid in > debugging. While fixing this I noticed an outdated comment. Series applied, thanks Edward.

Re: [PATCH v6 05/21] net-next: stmmac: Add dwmac-sun8i

2017-07-01 Thread Florian Fainelli
On 30/06/2017 23:53, Corentin Labbe wrote: > On Tue, Jun 27, 2017 at 10:37:34AM -0700, Florian Fainelli wrote: >> On 06/27/2017 10:29 AM, Maxime Ripard wrote: >>> On Tue, Jun 27, 2017 at 02:37:48PM +0200, Corentin Labbe wrote: On Tue, Jun 27, 2017 at 11:33:56AM +0100, Andre Przywara wrote: >>>

Re: [PATCH][-next] net/mlx5: fix spelling mistake: "Allodating" -> "Allocating"

2017-07-01 Thread David Miller
From: Colin King Date: Fri, 30 Jun 2017 11:59:22 +0100 > From: Colin Ian King > > Trivial fix to spelling mistake in mlx5_core_dbg debug message > > Signed-off-by: Colin Ian King Applied, thanks Colin. Mellanox folks, I don't like how these lib/ objects are built. I absolutely depend upon

Re: [GIT] [4.13] NFC update

2017-07-01 Thread David Miller
From: Samuel Ortiz Date: Fri, 30 Jun 2017 11:37:20 +0200 > This is the NFC pull request for 4.13. We have: > > - A conversion to unified device and GPIO APIs for the > fdp, pn544, and st{21,-nci} drivers. > - A fix for NFC device IDs allocation. > - A fix for the nfcmrvl driver firmware downlo

Re: [PATCH] arm: sunxi: Revert changes merged through net-next.

2017-07-01 Thread David Miller
From: Maxime Ripard Date: Fri, 30 Jun 2017 09:46:17 +0200 > This reverts commits 2c0cba482e79 ("arm: sun8i: sunxi-h3-h5: Add dt node > for the syscon control module") to 2428fd0fe550 ("arm64: defconfig: Enable > dwmac-sun8i driver on defconfig") and 3432a86e641c ("arm: sun8i: > orangepipc: use in

Re: [pull request][net 0/3] Mellanox, mlx5 fixes 2017-06-28

2017-07-01 Thread David Miller
From: Saeed Mahameed Date: Fri, 30 Jun 2017 10:12:26 +0300 > This series contains some fixes for the mlx5 core and netdev driver. > > Please pull and let me know if there's any problem. > > For -stable: > ("net/mlx5e: Fix TX carrier errors report in get stats ndo") Kernels >= v4.7 > > ("net/ml

Re: pull-request: wireless-drivers-next 2017-06-30

2017-07-01 Thread David Miller
From: Kalle Valo Date: Fri, 30 Jun 2017 09:19:37 +0300 > here's a pull request to net-next for 4.13. Actually not really that big > this time, more info in the signed tag below. Please let me know if you > have any problems. > > Intel has new hardware coming up and they just submitted patches to

Re: [PATCH RFC 06/26] ipc: Replace spin_unlock_wait() with lock/unlock pair

2017-07-01 Thread Manfred Spraul
On 06/30/2017 02:01 AM, Paul E. McKenney wrote: There is no agreed-upon definition of spin_unlock_wait()'s semantics, and it appears that all callers could do just as well with a lock/unlock pair. This commit therefore replaces the spin_unlock_wait() call in exit_sem() with spin_lock() followed

pull request: bluetooth-next 2017-07-01

2017-07-01 Thread Johan Hedberg
Hi Dave, Here are some more Bluetooth patches for the 4.13 kernel: - Added support for Broadcom BCM43430 controllers - Added sockaddr length checks before accessing sa_family - Fixed possible "might sleep" errors in bnep, cmtp and hidp modules - A few other minor fixes Please let me know if

Re: [PATCH v3] sctp: Add peeloff-flags socket option

2017-07-01 Thread Marcelo Ricardo Leitner
On Fri, Jun 30, 2017 at 01:32:57PM -0400, Neil Horman wrote: > Based on a request raised on the sctp devel list, there is a need to > augment the sctp_peeloff operation while specifying the O_CLOEXEC and > O_NONBLOCK flags (simmilar to the socket syscall). Since modifying the > SCTP_SOCKOPT_PEELOF

Re: [PATCH net-next v3] datapath: Avoid using stack larger than 1024.

2017-07-01 Thread David Miller
From: nickcooper-zhangtonghao Date: Thu, 29 Jun 2017 17:27:44 -0700 > From: Tonghao Zhang > > When compiling OvS-master on 4.4.0-81 kernel, > there is a warning: > > CC [M] /root/ovs/datapath/linux/datapath.o > /root/ovs/datapath/linux/datapath.c: In function > 'ovs_flow_cmd_set':

Re: [PATCH net-next 00/11] sctp: remove typedefs from structures part 1

2017-07-01 Thread David Miller
From: Xin Long Date: Fri, 30 Jun 2017 11:52:11 +0800 > As we know, typedef is suggested not to use in kernel, even checkpatch.pl > also gives warnings about it. Now sctp is using it for many structures. > > All this kind of typedef's using should be removed. As the 1st part, this > patchset is t

Re: [PATCH net-next v3 0/9] introduce flower offload capabilities

2017-07-01 Thread David Miller
From: Simon Horman Date: Thu, 29 Jun 2017 22:08:10 +0200 > this series adds flower offload to the NFP driver. It builds on recent > work to add representor and a skeleton flower app - now the app does what > its name says. > > In general the approach taken is to allow some flows within > the uni

Re: [PATCH net-next] sctp: remove an unnecessary check from sctp_endpoint_destroy

2017-07-01 Thread David Miller
From: Xin Long Date: Thu, 29 Jun 2017 17:28:06 +0800 > ep->base.sk gets it's value since sctp_endpoint_new, nowhere > will change it. So there's no need to check if it's null, as > it can never be null. > > Signed-off-by: Xin Long Applied, thanks.

Dear Beloved

2017-07-01 Thread Mrs josse willimas
I would like to work with you to carry out a promise i made to God by willing all that have to the charity. Get back to me for more details via my private email: williamsjosse...@gmail.com God bless You

Re: [PATCH net-next 6/7] qed/qede: Read per queue coalesce from hardware

2017-07-01 Thread kbuild test robot
Hi Rahul, [auto build test ERROR on net-next/master] url: https://github.com/0day-ci/linux/commits/Manish-Chopra/qed-qede-Enhancements/20170701-205133 config: i386-randconfig-x018-06250006 (attached as .config) compiler: gcc-6 (Debian 6.3.0-18) 6.3.0 20170516 reproduce: # save the

Re: [PATCH NET V5 2/2] net: hns: Use phy_driver to setup Phy loopback

2017-07-01 Thread Andrew Lunn
On Sat, Jul 01, 2017 at 11:57:32AM +, linyunsheng wrote: > Hi, Andrew > > I am agreed wih you on this. > But self test is also a feature of our product, and our > customer way choose to diagnose a problem using > self test, even if self test does not give a clear > reason to the problem. > we

Re: [PATCH net-next 5/7] qed/qede: Add support for vf coalesce configuration.

2017-07-01 Thread kbuild test robot
Hi Rahul, [auto build test ERROR on net-next/master] url: https://github.com/0day-ci/linux/commits/Manish-Chopra/qed-qede-Enhancements/20170701-205133 config: i386-randconfig-x018-06250006 (attached as .config) compiler: gcc-6 (Debian 6.3.0-18) 6.3.0 20170516 reproduce: # save the

[PATCH] net: cdc_mbim: apply "NDP to end" quirk to HP lt4132

2017-07-01 Thread Tore Anderson
The HP lt4132 LTE/HSPA+ 4G Module (03f0:a31d) is a rebranded Huawei ME906s-158 device. It, like the ME906s-158, requires the "NDP to end" quirk for correct operation. Signed-off-by: Tore Anderson --- drivers/net/usb/cdc_mbim.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/drivers/ne

Re: nf_conntrack: Infoleak via CTA_ID and CTA_EXPECT_ID

2017-07-01 Thread Florian Westphal
Richard Weinberger wrote: > Florian, > > Am 30.06.2017 um 21:55 schrieb Florian Westphal: > >>> Why not use a hash of the address? > >> > >> Would also work. Or xor it with a random number. > >> > >> On the other hand, for user space it would be more useful when the > >> conntrack id > >> does n

Re: nf_conntrack: Infoleak via CTA_ID and CTA_EXPECT_ID

2017-07-01 Thread Pablo Neira Ayuso
On Fri, Jun 30, 2017 at 10:23:24PM +0200, Richard Weinberger wrote: > Florian, > > Am 30.06.2017 um 21:55 schrieb Florian Westphal: > >>> Why not use a hash of the address? > >> > >> Would also work. Or xor it with a random number. > >> > >> On the other hand, for user space it would be more usefu