On Sat, May 6, 2017 at 1:42 PM, Paolo Abeni wrote:
> This patch series implement an idea suggested by Eric Dumazet to
> reduce the contention of the udp sk_receive_queue lock when the socket is
> under flood.
>
> An ancillary queue is added to the udp socket, and the socket always
> tries first to
Okay. My mistake. I just checked the verify function.
Apologies.
Best,
Shubham Bansal
On Sun, May 7, 2017 at 1:57 AM, Shubham Bansal
wrote:
> Thanks David.
>
> Hi all,
>
> I have two questions about the code at arch/arm64/net/bpf_jit_comp.c.
>
> 1. At line 708, " const u8 r1 = bpf2a64[BPF_REG_1
under udp flood the sk_receive_queue spinlock is heavily contended.
This patch try to reduce the contention on such lock adding a
second receive queue to the udp sockets; recvmsg() looks first
in such queue and, only if empty, tries to fetch the data from
sk_receive_queue. The latter is spliced int
On packet reception, when we are forced to splice the
sk_receive_queue, we can keep the related lock held, so
that we can avoid re-acquiring it, if fwd memory
scheduling is required.
Signed-off-by: Paolo Abeni
---
net/ipv4/udp.c | 36 ++--
1 file changed, 26 inser
And update __sk_queue_drop_skb() to work on the specified queue.
This will help the udp protocol to use an additional private
rx queue in a later patch.
Signed-off-by: Paolo Abeni
---
include/linux/skbuff.h | 7
include/net/sock.h | 4 +--
net/core/datagram.c| 90 +
This patch series implement an idea suggested by Eric Dumazet to
reduce the contention of the udp sk_receive_queue lock when the socket is
under flood.
An ancillary queue is added to the udp socket, and the socket always
tries first to read packets from such queue. If it's empty, we splice
the con
sparc64 support was added in 7a12b5031c6b (sparc64: Add eBPF JIT.,
2017-04-17)[0]
and ppc64 in 156d0e290e96 (powerpc/ebpf/jit: Implement JIT compiler for
extended BPF, 2016-06-22)[1].
[0]:
https://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next.git/commit/?id=7a12b5031c6b
[1]:
https://g
Thanks David.
Hi all,
I have two questions about the code at arch/arm64/net/bpf_jit_comp.c.
1. At line 708, " const u8 r1 = bpf2a64[BPF_REG_1]; /* r1: struct
sk_buff *skb */ ".
Why is this code using BPF_REG_1 before saving it? As far as I
know, BPF_REG_1 has pointer to bpf program context a
Hello all,
This patch adds support for modifying VXLAN device attributes. I have
refactored the vxlan_parse_opt() function to be more readable and not
use lot of bool variables.
I have tested my changes by running Linux Test Project's VXLAN
testcases, and I didn't see any regression.
---
v1->v2
-
Ability to change vxlan device attributes was added to kernel through
commit 8bcdc4f3a20b ("vxlan: add changelink support"), however one
cannot do the same through ip(8) command. Changing the allowed vxlan
device attributes using 'ip link set dev type vxlan
' currently fails with 'operation not s
From: Shubham Bansal
Date: Sat, 6 May 2017 22:18:16 +0530
> Hi Daniel,
>
> Thanks for the last reply about the testing of eBPF JIT.
>
> I have one issue though, I am not able to find what BPF_ABS and
> BPF_IND instruction does exactly.
They are not instructions, they are modifiers for the BPF_
On Fri, May 5, 2017 at 8:08 PM, Ding Tianhong wrote:
>
>
> On 2017/5/5 22:04, Alexander Duyck wrote:
>> On Thu, May 4, 2017 at 2:01 PM, Casey Leedom wrote:
>>> | From: Alexander Duyck
>>> | Sent: Wednesday, May 3, 2017 9:02 AM
>>> | ...
>>> | It sounds like we are more or less in agreement. My o
Do not top-post on netdev, please.
On Sat, 2017-05-06 at 05:46 +, Ilya Lesokhin wrote:
> I don't follow.
> Why can't splice use MSG_MORE for the individual pages?
> Why does tcp_sendpage need to know if the MORE indicator is coming from the
> user or from splice?
>
> I also don't understand
Hi Daniel,
Thanks for the last reply about the testing of eBPF JIT.
I have one issue though, I am not able to find what BPF_ABS and
BPF_IND instruction does exactly. It not described on this link -
https://www.kernel.org/doc/Documentation/networking/filter.txt either.
Can you please tell me where
From: Markus Elfring
Date: Sat, 6 May 2017 17:57:36 +0200
A bit of text was put into a sequence by two separate function calls.
Print the same data by a single function call instead.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
net/batman-adv/net
From: Markus Elfring
Date: Sat, 6 May 2017 17:50:13 +0200
Two single characters (line breaks) should be put into a sequence.
Thus use the corresponding function "seq_putc".
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
net/batman-adv/bat_iv_ogm.c
From: Markus Elfring
Date: Sat, 6 May 2017 18:03:45 +0200
Two update suggestions were taken into account
from static source code analysis.
Markus Elfring (2):
Replace a seq_puts() call by seq_putc() in two functions
Combine two seq_puts() calls into one call in batadv_nc_nodes_seq_print_text
Delay ipv4 and ipv6 initializations on lightweight netdevices until an
address is added to the device.
Skip sysctl initialization for neighbor path as well.
Signed-off-by: David Ahern
---
include/linux/netdevice.h | 5 +
net/core/neighbour.c | 3 +++
net/ipv4/devinet.c| 18 ++
Allow users to make new devices lightweight by setting IFLA_LWT_NETDEV
attribute in the newlink request.
Signed-off-by: David Ahern
---
include/uapi/linux/if_link.h | 1 +
net/core/rtnetlink.c | 10 +-
2 files changed, 10 insertions(+), 1 deletion(-)
diff --git a/include/uapi/l
Lightweight netdevices are not added to sysfs; bypass kobject
initialization.
Signed-off-by: David Ahern
---
include/linux/netdevice.h | 3 +++
net/core/dev.c| 9 ++---
net/core/net-sysfs.c | 14 +++---
3 files changed, 20 insertions(+), 6 deletions(-)
diff --git
Used in a later patch to pass in flags at create time
Signed-off-by: David Ahern
---
drivers/net/ethernet/mellanox/mlx5/core/ipoib.c | 2 +-
drivers/net/ethernet/tile/tilegx.c | 2 +-
drivers/net/tun.c | 2 +-
drivers/net/wireless/marvell/mwifiex/cfg802
Add new flag to denote lightweight netdevices. Add helper to identify
such devices.
Signed-off-by: David Ahern
---
include/linux/netdevice.h | 7 +++
1 file changed, 7 insertions(+)
diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
index f47c8712398a..08151fd34973 100644
--
As I have mentioned many times[1], at ~43+kB per instance the use of
net_devices does not scale for deployments needing 10,000+ devices. At
netconf 1.2 there was a discussion about using a net_device_common for
the minimal set of common attributes with other structs built on top of
that one for "fu
Signed-off-by: David Ahern
---
include/linux/netdevice.h | 5 +
net/batman-adv/sysfs.c| 13 +--
net/bridge/br_if.c| 12 ++
net/bridge/br_sysfs_br.c | 17 +-
net/bridge/br_sysfs_if.c | 8 +--
net/core/dev.c| 57 +++
Use memdup_user() helper instead of open-coding to simplify the code.
Signed-off-by: Geliang Tang
---
drivers/net/wireless/ath/wil6210/debugfs.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/net/wireless/ath/wil6210/debugfs.c
b/drivers/net/wireless/ath
Use memdup_user() helper instead of open-coding to simplify the code.
Signed-off-by: Geliang Tang
---
drivers/net/hippi/rrunner.c | 17 +++--
1 file changed, 7 insertions(+), 10 deletions(-)
diff --git a/drivers/net/hippi/rrunner.c b/drivers/net/hippi/rrunner.c
index 9b0d614..1ce623
Use memdup_user() helper instead of open-coding to simplify the code.
Signed-off-by: Geliang Tang
---
net/xfrm/xfrm_state.c | 11 +++
1 file changed, 3 insertions(+), 8 deletions(-)
diff --git a/net/xfrm/xfrm_state.c b/net/xfrm/xfrm_state.c
index fc3c5aa..5780cda 100644
--- a/net/xfrm/x
Use memdup_user() helper instead of open-coding to simplify the code.
Signed-off-by: Geliang Tang
---
drivers/net/wireless/ti/wlcore/debugfs.c | 13 +++--
1 file changed, 3 insertions(+), 10 deletions(-)
diff --git a/drivers/net/wireless/ti/wlcore/debugfs.c
b/drivers/net/wireless/ti/wl
Use memdup_user() helper instead of open-coding to simplify the code.
Signed-off-by: Geliang Tang
---
drivers/net/hamradio/yam.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/net/hamradio/yam.c b/drivers/net/hamradio/yam.c
index b6891ad..7a7c522 100644
--
On Sat, May 06, 2017 at 07:29:45AM +0200, Christophe JAILLET wrote:
> If 'devm_kzalloc' fails, a NULL pointer will be dereferenced.
> Return -ENOMEM instead, as done for some other memory allocation just a
> few lines above.
>
> Fixes: 98cd1552ea27 ("net: dsa: Mock-up driver")
>
> Signed-off-by:
On Sat, 2017-05-06 at 12:40 +0200, Jiri Pirko wrote:
> Thu, May 04, 2017 at 08:10:54PM CEST, bart.vanass...@sandisk.com wrote:
> > On Thu, 2017-05-04 at 21:02 +0300, Leon Romanovsky wrote:
> > > Following our discussion both in mailing list [1] and at the LPC 2016 [2],
> > > we would like to propos
From: Markus Elfring
Date: Sat, 6 May 2017 14:04:02 +0200
A string which did not contain a data format specification should be put
into a sequence. Thus use the corresponding function "seq_puts".
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
net/k
From: Markus Elfring
Date: Sat, 6 May 2017 13:53:41 +0200
Three single characters (line breaks) should be put into a sequence.
Thus use the corresponding function "seq_putc".
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
net/kcm/kcmproc.c | 6 +++-
From: Markus Elfring
Date: Sat, 6 May 2017 14:11:22 +0200
Two update suggestions were taken into account
from static source code analysis.
Markus Elfring (2):
Replace three seq_puts() calls by seq_putc()
Use seq_puts() in kcm_format_psock()
net/kcm/kcmproc.c | 8
1 file changed, 4
Fri, May 05, 2017 at 10:52:47PM CEST, vyasev...@gmail.com wrote:
>This is a version 4 series came out of the conversation that started
>as a result my first attempt to add netdevice event info to netlink messages.
>
>First is the patch to add IFLA_EVENT attribute to the netlink message. It
>suppor
Fri, May 05, 2017 at 03:17:54PM CEST, l...@kernel.org wrote:
>On Fri, May 05, 2017 at 08:54:57AM +0200, Jiri Benc wrote:
>> On Thu, 4 May 2017 21:02:08 +0300, Leon Romanovsky wrote:
>> > In order to close object model, ensure reuse of existing code and make this
>> > tool usable from day one, we d
Thu, May 04, 2017 at 08:10:54PM CEST, bart.vanass...@sandisk.com wrote:
>On Thu, 2017-05-04 at 21:02 +0300, Leon Romanovsky wrote:
>> Following our discussion both in mailing list [1] and at the LPC 2016 [2],
>> we would like to propose this RDMA tool to be part of iproute2 package
>> and finally i
Fri, May 05, 2017 at 09:55:54AM CEST, bardout...@ceid.upatras.gr wrote:
>Yes I think we have faced the same problem,communication with RPL supporting
>devices was failing otherwise.Your patch is also more complete since it also
>implements #ifdef .About the comment,yes I have run checkpatch twice w
Thu, May 04, 2017 at 07:55:56PM CEST, l...@kernel.org wrote:
>On Thu, May 04, 2017 at 09:45:58AM -0700, Stephen Hemminger wrote:
>> On Thu, 4 May 2017 17:37:38 +0300
>> Leon Romanovsky wrote:
>>
>> > On Thu, May 04, 2017 at 11:36:36AM +0200, Daniel Borkmann wrote:
>> > > On 05/04/2017 01:56 AM, St
Hello!
On 5/6/2017 2:18 AM, woojung@microchip.com wrote:
From: Woojung Huh
A sample SPI configuration for Microchip KSZ switches.
Signed-off-by: Woojung Huh
---
Documentation/devicetree/bindings/net/dsa/ksz.txt | 73 +++
1 file changed, 73 insertions(+)
create mode
Recent Chelsio firmware started using few port capablity bits to
manage FEC and as driver was not aware of FEC changes those bits
were zeroed, consequently disabling FEC.
Avoid zeroing those bits and default to whatever the firmware
tells us the Link is currently advertising.
Signed-off-by: Ganes
On Fri, May 05, 2017 at 11:10:17AM -0600, Jason Gunthorpe wrote:
> I recommend immediately sending a kconfig patch cc'd to stable making
> SMC require CONFIG_BROKEN so that nobody inadvertantly turns it on.
Yes, I'll send the patch.
I want to inquire if you can be our regional representative in your region. It
would by no Means interfere with your current job. If you are interested please
contact Mr. Yu Yong
Email: yong...@hblsco.com for more information on the job. I look forward to
hearing from you.
Sincerely,
Yu Yong.
43 matches
Mail list logo