Re: [PATCH 01/10] net: Use cached copy of pfmemalloc to avoid accessing page

2015-05-10 Thread David Miller
From: Alexander Duyck Date: Sun, 10 May 2015 17:01:15 -0700 > The reason for the difference between the two is that in the case of > netdev_alloc_skb/frag the netdev_alloc_cache can only be accessed with > IRQs disabled, whereas in the napi_alloc_skb case we can access the > napi_alloc_cache at a

Re: [PATCH net] Revert "ipv6: Allow for partial checksums on non-ufo packets"

2015-05-10 Thread David Miller
From: Eric Dumazet Date: Fri, 08 May 2015 15:22:45 -0700 > From: Eric Dumazet > > Wolfgang Walter reported crashes using traceroute6, root caused to this > commit. > > UDP packets can be sent from RAW sockets. > > Note that the faulty commit addressed a non problem, as normal > UDP v6 packets

Re: [PATCH net-next] codel: add ce_threshold attribute

2015-05-10 Thread David Miller
From: Eric Dumazet Date: Fri, 08 May 2015 15:05:12 -0700 > From: Eric Dumazet > > For DCTCP or similar ECN based deployments on fabrics with shallow > buffers, hosts are responsible for a good part of the buffering. > > This patch adds an optional ce_threshold to codel & fq_codel qdiscs, > so

Re: [PATCH 5/5] geneve: add initial netdev driver for GENEVE tunnels

2015-05-10 Thread David Miller
From: "John W. Linville" Date: Fri, 8 May 2015 19:22:36 -0400 > On Fri, May 08, 2015 at 01:55:15PM -0700, Cong Wang wrote: >> On Fri, May 8, 2015 at 10:20 AM, John W. Linville >> wrote: >> > + >> > +/* Setup stats when device is created */ >> > +static int geneve_init(struct net_device *dev) >>

Re: [PATCH] net: mdio-gpio: Allow for unspecified bus id

2015-05-10 Thread David Miller
From: Bert Vermeulen Date: Fri, 8 May 2015 16:18:49 +0200 > When the bus id was supplied via a struct platform_device, the driver wasn't > handling -1 to mean an unspecified id of the only instance of this driver, > as the platform spec requires. > > Signed-off-by: Bert Vermeulen Applied, tha

Re: [PATCH-net] af_packet / TX_RING not fully non-blocking (w/ MSG_DONTWAIT).

2015-05-10 Thread David Miller
From: Mathias Kretschmer Date: Fri, 8 May 2015 15:44:37 +0200 > This patch fixes an issue where the send(MSG_DONTWAIT) call > on a TX_RING is not fully non-blocking in cases where the device's sndBuf is > full. We pass nonblock=true to sock_alloc_send_skb() and return any possibly > occuring erro

Re: [PATCH net] bnx2x: limit fw delay in kdump to 5s after boot

2015-05-10 Thread David Miller
From: Michal Schmidt Date: Thu, 7 May 2015 20:37:10 +0200 > Commit 12a8541d5c82 "bnx2x: Delay during kdump load" added a 5 seconds > delay to bnx2x's probe function in the kdump case to let the firmware > realize the old driver is gone. > > The problem with the delay is that it is per-device, s

Re: [PATCH] ARM: net: delegate filter to kernel interpreter when imm_offset() return value can't fit into 12bits.

2015-05-10 Thread David Miller
From: Nicolas Schichan Date: Thu, 7 May 2015 17:14:21 +0200 > The ARM JIT code emits "ldr rX, [pc, #offset]" to access the literal > pool. #offset maximum value is 4095 and if the generated code is too > large, the #offset value can overflow and not point to the expected > slot in the literal po

Re: [PATCH v2] ARM: net fix emit_udiv() for BPF_ALU | BPF_DIV | BPF_K intruction.

2015-05-10 Thread David Miller
From: Nicolas Schichan Date: Wed, 6 May 2015 18:31:56 +0200 > In that case, emit_udiv() will be called with rn == ARM_R0 (r_scratch) > and loading rm first into ARM_R0 will result in jit_udiv() function > being called the same dividend and divisor. Fix that by loading rn > first into ARM_R1 and

Re: [PATCH v2] ARM: net: add JIT support for loads from struct seccomp_data.

2015-05-10 Thread David Miller
From: Russell King - ARM Linux Date: Sun, 10 May 2015 20:40:28 +0100 > I think you have taken previous ARM net JIT patches, so I think it > makes sense if you continue to do so. I'm not knowledgable of the > JIT interface myself, all I can say about many of these patches is > that they look okay

Re: [PATCH 00/10] Refactor netdev page frags and move them into mm/

2015-05-10 Thread David Miller
From: Alexander Duyck Date: Wed, 06 May 2015 21:11:34 -0700 > This patch series addresses several things. > > First I found an issue in the performance of the pfmemalloc check from > build_skb. To work around it I have provided a cached copy of pfmemalloc > to be used in __netdev_alloc_skb and

Re: [PATCH 01/10] net: Use cached copy of pfmemalloc to avoid accessing page

2015-05-10 Thread David Miller
From: Alexander Duyck Date: Wed, 06 May 2015 21:11:40 -0700 > + /* use OR instead of assignment to avoid clearing of bits in mask */ > + if (pfmemalloc) > + skb->pfmemalloc = 1; > + skb->head_frag = 1; ... > + /* use OR instead of assignment to avoid clearing of bits

Re: [PATCH net-next] ethernet: qualcomm: use spi instead of spi_device

2015-05-10 Thread David Miller
From: Varka Bhadram Date: Thu, 7 May 2015 09:17:48 +0530 > All spi based drivers have an instance of struct spi_device > as spi. This patch renames spi_device to spi to synchronize > with all the drivers. > > Signed-off-by: Varka Bhadram Applied, thank you. -- To unsubscribe from this list: s

Re: [PATCH V4 net-next 1/1] hv_netvsc: Use the xmit_more skb flag to optimize signaling the host

2015-05-10 Thread David Miller
From: "K. Y. Srinivasan" Date: Wed, 6 May 2015 15:29:05 -0700 > - ret = vmbus_sendpacket_pagebuffer(out_channel, > - pgbuf, > - packet->page_buf_cnt, > -

Re: [PATCH] net: fec: add support of ethtool get_regs

2015-05-10 Thread Philippe Reynes
Hi david, On 10/05/15 03:01, David Miller wrote: From: Philippe Reynes Date: Sun, 10 May 2015 00:16:21 +0200 Hi Fabio, On 09/05/15 23:59, Fabio Estevam wrote: Philippe, On Sat, May 9, 2015 at 6:17 PM, Russell King - ARM Linux wrote: Using memcpy_fromio() to copy device registers is no

Re: [PATCH net-next v7 23/24] rocker: make checkpatch -f clean

2015-05-10 Thread Jiri Pirko
Sun, May 10, 2015 at 06:48:08PM CEST, sfel...@gmail.com wrote: >From: Scott Feldman > >Well almost clean: ignore the CHECKs for space after cast operator and some >longer-than-80 char cases where for readability it's better to keep as-is. > >Signed-off-by: Scott Feldman Acked-by: Jiri Pirko --

Re: [PATCH net-next v7 16/24] switchdev: cut over to new switchdev_port_bridge_dellink

2015-05-10 Thread Jiri Pirko
Sun, May 10, 2015 at 06:48:01PM CEST, sfel...@gmail.com wrote: >From: Scott Feldman > >Rocker, bonding and team and switch over to the new >switchdev_port_bridge_dellink to avoid duplicating code in each driver. > >Signed-off-by: Scott Feldman Acked-by: Jiri Pirko -- To unsubscribe from this li

Re: [PATCH net-next v7 15/24] switchdev: add new switchdev_port_bridge_dellink

2015-05-10 Thread Jiri Pirko
Sun, May 10, 2015 at 06:48:00PM CEST, sfel...@gmail.com wrote: >From: Scott Feldman > >Same change as setlink. Provide the wrapper op for SELF ndo_bridge_dellink >and call into the switchdev driver to delete afspec VLANs. > >Signed-off-by: Scott Feldman Acked-by: Jiri Pirko -- To unsubscribe f

Re: [PATCH 2/2 net-next] net: move qdisc ingress filtering code where it belongs

2015-05-10 Thread Alexei Starovoitov
On 5/10/15 12:00 PM, Pablo Neira Ayuso wrote: The inlined code into the ingress core path seems to have an impact to people that don't need this, even with the static key. two emails ago you've accused me of non-technical comments and now I've posted real numbers that show no impact on users t

Re: [PATCH 2/2 net-next] net: move qdisc ingress filtering code where it belongs

2015-05-10 Thread Alexei Starovoitov
On 5/10/15 10:59 AM, Pablo Neira Ayuso wrote: On Sun, May 10, 2015 at 10:45:42AM -0700, Alexei Starovoitov wrote: On 5/10/15 9:59 AM, Pablo Neira Ayuso wrote: The qdisc ingress filtering code is embedded into the core most likely because at that time we had no RCU in place to define a hook. Thi

[PATCH 0/2 net-next] critical ingress path performance improvements

2015-05-10 Thread Pablo Neira Ayuso
This patch improves performance of the super-critical ingress path by moving the qdisc ingress code to sch_ingress, where this really belongs. This patchset also removes the Qdisc->enqueue() indirection since this does not enqueue anything. This is roughly 92199pps, ~0.42% more performance on my

[PATCH net-next v7 13/24] switchdev: remove old switchdev_port_bridge_setlink

2015-05-10 Thread sfeldma
From: Scott Feldman New attr-based bridge_setlink can recurse lower devs and recover on err, so remove old wrapper (including ndo_dflt_switchdev_port_bridge_setlink). Signed-off-by: Scott Feldman Acked-by: Jiri Pirko --- include/net/switchdev.h |9 - net/switchdev/switchdev.c |

[PATCH net-next v7 00/24] switchdev: spring cleanup

2015-05-10 Thread sfeldma
From: Scott Feldman v7: Address review comments: - [Jiri] split the br_setlink and br_dellink reverts into their own patches - [Jiri] some parameter cleanup of rocker's memory allocators - [Jiri] pass trans mode as formal parameter rather than hanging off of rocker_port. v6: Address r

[PATCH v3 for-next 09/13] IB/cma: Add compare_data checks to the RDMA CM module

2015-05-10 Thread Haggai Eran
Previously RDMA CM relied on the CM module to check the incoming requests against "compare data" struct to dispatch events for different RDMA CM IDs based on the request parameters (IP address, address family, etc.). With namespace support, multiple namespaces in RDMA CM will need to share a single

[PATCH v3 for-next 06/13] IB/cm: API to retrieve existing listening CM IDs

2015-05-10 Thread Haggai Eran
Enabling network namespaces for RDMA CM will allow processes on different namespaces to listen on the same port. In order to leave namespace support out of the CM layer, this requires that multiple RDMA CM IDs will be able to share a single CM ID. This patch adds infrastructure to retrieve an exis

[PATCH v3 for-next 03/13] IB/core: Find the network namespace matching connection parameters

2015-05-10 Thread Haggai Eran
From: Yotam Kenneth In the case of IPoIB, and maybe in other cases, the network device is managed by an upper-layer protocol (ULP). In order to expose this network device to other users of the IB device, let ULPs implement a callback that returns network device according to connection parameters.

[PATCH v3 for-next 01/13] IB/core: Use SRCU when reading client_list or device_list

2015-05-10 Thread Haggai Eran
Currently the RDMA subsystem's device list and client list are protected by a single mutex. This prevents adding user-facing APIs that iterate these lists, since using them may cause a deadlock. The patch attempts to solve this problem by adding an SRCU to protect the lists. Readers now don't need

[PATCH net-next V3 07/11] net/mlx5_core: Modify CQ moderation parameters

2015-05-10 Thread Amir Vadai
From: Rana Shahout Introduce mlx5_core_modify_cq_moderation() to be used by the netdev, to set hardware coalescing. Signed-off-by: Rana Shahout Signed-off-by: Saeed Mahameed Signed-off-by: Amir Vadai --- drivers/net/ethernet/mellanox/mlx5/core/cq.c | 18 ++ include/linux/mlx5

[PATCH net-next V3 04/11] net/mlx5_core: New device capabilities handling

2015-05-10 Thread Amir Vadai
From: Saeed Mahameed - Query all supported types of dev caps on driver load. - Store the Cap data outbox per cap type into driver private data. - Introduce new Macros to access/dump stored caps (using the auto generated data types). - Obsolete SW representation of dev caps (no need for SW copy

[PATCH net-next V3 10/11] net/mlx5: Ethernet resource handling files

2015-05-10 Thread Amir Vadai
This patch contains the resource handling files: - flow_table.c: This file contains the code to handle the low level API to configure hardware flow table. It is separated from the flow_table_en.c, because it will be used in the future by Raw Ethernet

[PATCH net-next V3 11/11] net/mlx5: Extend mlx5_core to support ConnectX-4 Ethernet functionality

2015-05-10 Thread Amir Vadai
This is the Ethernet part of the driver for the Mellanox ConnectX(R)-4 Single/Dual-Port Adapter supporting 100Gb/s with VPI. The driver extends the existing mlx5 driver with Ethernet functionality. This patch contains the driver entry points but does not include transmit and receive (see the prev

[PATCH net-next V3 05/11] net/mlx5_core: Implement access functions of ptys register fields

2015-05-10 Thread Amir Vadai
From: Saeed Mahameed Those registers will be used by the ethtool to set/get settings. Signed-off-by: Rana Shahout Signed-off-by: Saeed Mahameed Signed-off-by: Amir Vadai --- drivers/net/ethernet/mellanox/mlx5/core/port.c | 77 ++ include/linux/mlx5/driver.h

[PATCH net-next V3 09/11] net/mlx5: Ethernet Datapath files

2015-05-10 Thread Amir Vadai
en_[rt]x.c contains the data path related code specific to tx or rx. en_txrx.c contains data path code which is common for both the rx and tx, this is mainly napi related code. Below are the objects that are being used by the hardware and the driver in the data path: Channel - one channel per IRQ

[PATCH net-next V3 02/11] net/mlx5_core: Add EQ renaming mechanism

2015-05-10 Thread Amir Vadai
From: Saeed Mahameed Introduce mlx5_rename_eq() to rename an EQ. This will be used by a following commit for the Ethernet functionality of the driver. Signed-off-by: Saeed Mahameed Signed-off-by: Amir Vadai --- drivers/net/ethernet/mellanox/mlx5/core/main.c | 25 -- ..