Corey Hickey wrote:
> +/* SFQ parameters exist as individual rtattr attributes, with a nested
> + * "struct tc_sfq_qopt" for compatibility with older userspace tools. If an
> + * individual attribute is set, we want to use it; otherwise, fall back to
> the
> + * nested struct.
> + * There is one c
Note that I have left sfq_print_opt() alone. At this point, there
can be no difference between the data in the nested rtattrs and the
data in the compat rtattr, and I didn't want to add clutter that
isn't useful. Let me know if I should do differently.
Signed-off-by: Corey Hickey <[EMAIL PROTECTED
This can safely be applied either before or after the kernel
patches because the tc_sfq_qopt struct is unchanged:
- old kernels will ignore the new parameters from new iproute2
- new kernels will use the same defaults for the new parameters
---
include/linux/pkt_sched.h |9 -
tc/q_sfq
These patches follow the ESFQ-->SFQ kernel patches. See the kernel
patch summary for general information.
Thanks,
Corey
include/linux/pkt_sched.h | 23 ++-
tc/q_sfq.c| 42 +-
2 files changed, 51 insertions(+), 14 d
This corresponds to the kernel patch doing the same.
Here, too, this will technically break binary compatibility with older
kernels, but that shouldn't be a problem because negative perturb_period
values aren't usable anyway.
---
include/linux/pkt_sched.h |2 +-
tc/q_sfq.c|
This fixes the ambiguity between, for example:
tc qdisc change ... perturb 0
tc qdisc change ...
Without this patch, there is no way for SFQ to differentiate between
a parameter specified to be 0 and a parameter that was omitted.
Signed-off-by: Corey Hickey <[EMAIL PROTECTED]>
---
include/linux/
perturb_period is the only parameter that doesn't match 1:1 with the
value from userspace. Multiplying perturb_period by HZ when used rather
than when assigned makes it easy and clean to use a small function for
setting parameters (in a subsequent patch).
perturb_period is currently a signed integ
Re-implement sfq_change() and enable Qdisc_opts.change so "tc qdisc
change" will work.
Signed-off-by: Corey Hickey <[EMAIL PROTECTED]>
---
net/sched/sch_sfq.c | 67 ++-
1 files changed, 66 insertions(+), 1 deletions(-)
diff --git a/net/sched/sch_
None of these are true anymore (hooray!).
Signed-off-by: Corey Hickey <[EMAIL PROTECTED]>
---
include/linux/pkt_sched.h |8
net/sched/sch_sfq.c | 13 +
2 files changed, 1 insertions(+), 20 deletions(-)
diff --git a/include/linux/pkt_sched.h b/include/linux/pkt_sc
Make a new function sfq_q_enqueue() that operates directly on the
queue data. This will be useful for implementing sfq_change() in
a later patch. A pleasant side-effect is reducing most of the
duplicate code in sfq_enqueue() and sfq_requeue().
Similarly, make a new function sfq_q_dequeue().
Signe
* replace #define with a parameter
* use old hardcoded value as a default
* kcalloc() arrays in sfq_q_init()
* free() arrays in new function sfq_q_destroy()
* move sfq_destroy() to near sfq_q_destroy(), for clarity
Signed-off-by: Corey Hickey <[EMAIL PROTECTED]>
---
net/sched/sch_sfq.c | 104 +++
Make hash divisor user-configurable.
Signed-off-by: Corey Hickey <[EMAIL PROTECTED]>
---
net/sched/sch_sfq.c | 27 +--
1 files changed, 21 insertions(+), 6 deletions(-)
diff --git a/net/sched/sch_sfq.c b/net/sched/sch_sfq.c
index 1c1bf08..c74d5ce 100644
--- a/net/sched/
Factor code out of sfq_init() so that the new function can be used
by sfq_change() later.
Actually, as the diff itself shows, most of the sfq_q_init() code
comes from the original sfq_change(), but sfq_change() is only
called by sfq_init() right now. Thus, it is safe to remove
sfq_change(); "tc qd
Patchset try 2 addresses the review by Michael Buesch.
Patchset try 3 addresses the review by Patrick McHardy.
Patchset try 4 has a few cosmetic improvements.
Patchset try 5 addresses further review by Patrick McHardy.
This set of patches is substantially the same as my previous try, with
changes
From: Andy Gospodarek <[EMAIL PROTECTED]>
Instead of using the default timeout of 3 minutes, this uses the timeout
specific to the protocol used for the connection. The 3 minute timeout
seems somewhat arbitrary (though I know it is used other places in the
ipvs code) and when failing over it would
In article <[EMAIL PROTECTED]> (at Mon, 29 Oct 2007 15:33:20 +0900), Mitsuru
Chinen <[EMAIL PROTECTED]> says:
> Hello Herbert,
>
> Let me ask a question about this patch.
> After this patch was applied, 2 of the protocol stack behaviors were
> changed when it receives a UDP datagram with broken
Hello Herbert,
Let me ask a question about this patch.
After this patch was applied, 2 of the protocol stack behaviors were
changed when it receives a UDP datagram with broken checksum:
1. udp6InDatagrams is incremented instead of udpInErrors
2. In userland, recvfrom() replies an error with EAG
> -Original Message-
> From: Anton Vorontsov [mailto:[EMAIL PROTECTED]
> Sent: Saturday, October 27, 2007 10:38 PM
> To: Sergei Shtylyov
> Cc: Anton Vorontsov; netdev@vger.kernel.org; Li Yang-r58472;
> [EMAIL PROTECTED]; [EMAIL PROTECTED]
> Subject: Re: [PATCH] ucc_geth: add support for n
This bug was introduced by the commit
d12af679bcf8995a237560bdf7a4d734f8df5dbb.
Signed-off-by: YOSHIFUJI Hideaki <[EMAIL PROTECTED]>
---
diff --git a/net/ipv6/ndisc.c b/net/ipv6/ndisc.c
index 20cfc90..36f7dbf 100644
--- a/net/ipv6/ndisc.c
+++ b/net/ipv6/ndisc.c
@@ -1670,7 +1670,7 @@ int ndisc_if
On Sun, 2007-10-28 at 14:01 -0700, Joe Perches wrote:
> probably unsigned long should be u16.
Or not.
x86 u16 performs much worse than u32 (~ 50% worse)
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http:
Hi.
I was trying to use bonding from a guest OS on xen in active-backup
mode with arp monitoring, but the virtual server can't communicate to
the peer server via bonding interface.
The network structure is the following.
+---+
|virtual I/F(eth0) | <- have
Additionally, it doesn't show rate in stats (so it is difficult to measure,
how much is really using each class).
qdisc hfsc 1: root default 200
Sent 1392761062 bytes 965768 pkt (dropped 52, overlimits 1620539 requeues 0)
rate 0bit 0pps backlog 0b 0p requeues 0
qdisc bfifo 200: parent 1:200 lim
Hi All
During testing i found very strange thing.
After applying even example shaper:
http://linux-ip.net/tc/hfsc.en/
-
# Example from Figure 1.
tc qdisc add dev eth0 root handle 1: hfsc
tc class add dev eth0 parent 1: classid 1:1 hfsc sc rate
1000kbit ul
On Fri, 2007-10-26 at 11:33 -0700, Stephen Hemminger wrote:
> Don't call napi_disable if not configured.
> And make sure that any misuse of napi_xxx in future fails
> with a compile error.
Will test as soon as possible (been without internet in the week end).
Thanks.
As a bonus, I tried more th
On Fri, 2007-10-26 at 14:37 +0200, Jan-Bernd Themann wrote:
> eHEA resources that are allocated via H_CALLs have a unique identifier each.
> These identifiers are necessary to free the resources. A reboot notifier
> is used to free all eHEA resources before the indentifiers get lost, i.e
> before
On Sun, 2007-10-28 at 21:18 +0100, Urs Thuermann wrote:
> I have written a short test program to show this and tested it on i686
> (gcc-4.2.2) and powerpc (gcc-3.4.5) without optimization and with -O6.
Thanks for that.
> BTW, shouldn't unsigned long be replaced by unsigned int to avoid
> 64-bit
Sergey S. Kostyliov <[EMAIL PROTECTED]> :
[...]
> After booting 2.6.24-rc1 on my home machine I lost onboard rtl8111b
> network card. It is neither functional nor even visible by lspci
> anymore.
>
> Moreover rebooting to previous 2.6.23-rc9 didn't fix it - card was
> still not available.
It shou
On Sun, Oct 28, 2007 at 01:22:04PM -0700, Stephen Hemminger wrote:
> > -#define MIPSNET_INTCTL_TXDONE ((uint32_t)(1 << 0))
> > -#define MIPSNET_INTCTL_RXDONE ((uint32_t)(1 << 1))
> > -#define MIPSNET_INTCTL_TESTBIT((uint32_t)(1 << 31))
> > -#define MIPSNET_INTCTL_ALLSOURCES (MIPSNET
Stephen Hemminger wrote:
> On Sun, 28 Oct 2007 20:03:08 +
> Thiemo Seufer <[EMAIL PROTECTED]> wrote:
>
> > Ralf Baechle wrote:
> > > On Sun, Oct 28, 2007 at 04:38:46AM +, Thiemo Seufer wrote:
> > >
> > > > Hello All,
> > > >
> > > > currently the mipsnet driver fails after transmitting a
On Sun, 28 Oct 2007 20:03:08 +
Thiemo Seufer <[EMAIL PROTECTED]> wrote:
> Ralf Baechle wrote:
> > On Sun, Oct 28, 2007 at 04:38:46AM +, Thiemo Seufer wrote:
> >
> > > Hello All,
> > >
> > > currently the mipsnet driver fails after transmitting a number of
> > > packages because SKBs are
Herbert Xu <[EMAIL PROTECTED]> writes:
> But your code differs significantly from Stephen's version.
> However, if it is correct it does look like a good improvement.
>
> So please write a simple test program. It can't that bad since
> there are only 65536 values to test :)
I think the code is
Dave,
Please take a look and tell me if this is better than the last attempt.
Main changes:
* Rewrite of the init code:
1. Full rewrite of the generated code into something easier to read.
2. Removed zeroes by adding a zero command.
3. Big chucks of data are read by the
Ralf Baechle wrote:
> On Sun, Oct 28, 2007 at 04:38:46AM +, Thiemo Seufer wrote:
>
> > Hello All,
> >
> > currently the mipsnet driver fails after transmitting a number of
> > packages because SKBs are allocated but never freed. I fixed that
> > and coudn't refrain from removing the most egre
On Sunday 28 October 2007 00:24:10 Alan Stern wrote:
> On Sat, 27 Oct 2007, Maxim Levitsky wrote:
>
> > > Use del_timer_sync(). It guarantees that when it returns, the timer
> > > will be stopped and the timer routine will no longer be running on any
> > > CPU.
> > >
> > Even if the timer re-e
>
> OK, on a process level, my plan is to pull the current driver into a
> "neteffect" branch in my git tree with the intention of merging it for
> 2.6.25. I'll let you know when that's ready (probably early next
> week). I'll probably do some cleanups there, and you can send me
> cleanup/fix pa
Hi,
On Sunday 28 October 2007, Russell King wrote:
> On Sat, Oct 27, 2007 at 03:40:04PM -0700, Joe Perches wrote:
> > and forward declarations of
> >
> > struct proc_dir_entry;
> > struct file_operations;
> >
> > As a general rule, I think it better to use includes
> > than use naked forward decl
Signed-off-by: Francois Romieu <[EMAIL PROTECTED]>
Cc: Avuton Olrich <[EMAIL PROTECTED]>
Cc: Jesse Huang <[EMAIL PROTECTED]>
Cc: Sorbica Shieh <[EMAIL PROTECTED]>
---
drivers/net/Kconfig | 12 ++--
1 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/net/Kconfig b/drive
Fix for the error below while linking vmlinux:
[...]
drivers/built-in.o: In function `ipg_ioctl':
drivers/net/ipg.c:2148: undefined reference to `generic_mii_ioctl'
drivers/built-in.o: In function `ipg_get_settings':
drivers/net/ipg.c:2181: undefined reference to `mii_ethtool_gset'
drivers/built-in
Disabling napi polling early is well enough.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
Signed-off-by: Francois Romieu <[EMAIL PROTECTED]>
Cc: Edward Hsu <[EMAIL PROTECTED]>
---
drivers/net/r8169.c | 12
1 files changed, 4 insertions(+), 8 deletions(-)
diff --git a/drive
Don't call napi_disable if not configured and make sure that any
misuse of napi_xxx in future fails with a compile error.
Signed-off-by: Stephen Hemminger <[EMAIL PROTECTED]>
Signed-off-by: Francois Romieu <[EMAIL PROTECTED]>
Cc: Edward Hsu <[EMAIL PROTECTED]>
---
drivers/net/r8169.c |4
Please pull from branch 'upstream-jeff' in repository
git://git.kernel.org/pub/scm/linux/kernel/git/romieu/netdev-2.6.git
upstream-jeff
to get the changes below.
Distance from 'master' (96fd4cd3e40e240f0c385af87f58e74da8b7099a)
-
On Sun, Oct 28, 2007 at 04:38:46AM +, Thiemo Seufer wrote:
> Hello All,
>
> currently the mipsnet driver fails after transmitting a number of
> packages because SKBs are allocated but never freed. I fixed that
> and coudn't refrain from removing the most egregious warts.
>
> - mipsnet.h fold
* Russell King <[EMAIL PROTECTED]> [2007-10-28 14:04]:
> On Sun, Oct 28, 2007 at 12:59:52PM +0100, Bernhard Walle wrote:
> > * Russell King <[EMAIL PROTECTED]> [2007-10-28 11:34]:
> > >
> > > If you go down that route, you end up with _lots_ of circular
> > > dependencies - header file X needs Y n
On Sun, Oct 28, 2007 at 12:59:52PM +0100, Bernhard Walle wrote:
> * Russell King <[EMAIL PROTECTED]> [2007-10-28 11:34]:
> >
> > If you go down that route, you end up with _lots_ of circular
> > dependencies - header file X needs Y needs Z which needs X. We've
> > been there, several times. It v
* Russell King <[EMAIL PROTECTED]> [2007-10-28 11:34]:
>
> If you go down that route, you end up with _lots_ of circular
> dependencies - header file X needs Y needs Z which needs X. We've
> been there, several times. It very quickly becomes quite
> unmaintainable - you end up with hard to predi
MODPOST 434 modules
ERROR: "ioremap" [drivers/ssb/ssb.ko] undefined!
ERROR: "iounmap" [drivers/ssb/ssb.ko] undefined!
ERROR: "dma_alloc_coherent" [drivers/net/b44.ko] undefined!
ERROR: "dma_get_cache_alignment" [drivers/net/b44.ko] undefined!
ERROR: "dma_free_coherent" [drivers/net/b44.ko] undefi
On Oct 28 2007 10:34, Russell King wrote:
>On Sat, Oct 27, 2007 at 03:40:04PM -0700, Joe Perches wrote:
>> and forward declarations of
>>
>> struct proc_dir_entry;
>> struct file_operations;
>>
>> As a general rule, I think it better to use includes
>> than use naked forward declarations.
>
>If
On Sat, Oct 27, 2007 at 03:40:04PM -0700, Joe Perches wrote:
> and forward declarations of
>
> struct proc_dir_entry;
> struct file_operations;
>
> As a general rule, I think it better to use includes
> than use naked forward declarations.
If you go down that route, you end up with _lots_ of cir
>
> As a general rule, I think it better to use includes
> than use naked forward declarations.
Quite the opposite - at least in the kernel source.
The general rule is that a .h file shall include the
.h files which contain declarations used by said .h files.
But naked declarations as above is pr
- Fixed memory leak by freeing MSI-X local entry memories when vector allocation
fails in s2io_add_isr.
- Added two utility functions do_rem_msix_isr and do_rem_inta_isr to eliminate
code duplication.
Signed-off-by: Veena Parat <[EMAIL PROTECTED]>
Signed-off-by: Ramkrishna Vepa <[EMAIL PROTECTED]>
On Sat, Oct 27, 2007 at 03:40:04PM -0700, Joe Perches wrote:
> On Sat, 2007-10-27 at 23:47 +0400, Alexey Dobriyan wrote:
> > Remove proc_fs.h from headers that doesn't really need it.
>
> > --- a/arch/powerpc/kernel/process.c
> > +++ b/arch/powerpc/kernel/process.c
> > @@ -17,6 +17,7 @@
> > #incl
51 matches
Mail list logo