Re: [PATCH 0/9 Rev3] Implement batching skb API and support in IPoIB

2007-08-25 Thread Bill Fink
On Sat, 25 Aug 2007, Herbert Xu wrote: > On Fri, Aug 24, 2007 at 02:25:03PM -0700, David Miller wrote: > > > > My hunch is that even if in the non-TSO case the TX packets were all > > back to back in the cards TX ring, TSO still spits them out faster on > > the wire. > > If this is the case then

[PATCH 2/3] Change perturb_period to unsigned.

2007-08-25 Thread Corey Hickey
This corresponds to the kernel patch doing the same. Here, too, this will technically break binary compatibility with older kernels, but that shouldn't be a problem because negative perturb_period values aren't usable anyway. --- include/linux/pkt_sched.h |2 +- tc/q_sfq.c|

[PATCH 3/3] Use nested compat attributes for passing parameters to the kernel.

2007-08-25 Thread Corey Hickey
Note that I have left sfq_print_opt() alone. At this point, there can be no difference between the data in the nested rtattrs and the data in the compat rtattr, and I didn't want to add clutter that isn't useful. Let me know if I should do differently. Signed-off-by: Corey Hickey <[EMAIL PROTECTED

[PATCH 0/3][iproute2] SFQ: backport some features from ESFQ

2007-08-25 Thread Corey Hickey
These patches follow the ESFQ-->SFQ kernel patches. See the kernel patch summary for general information. Thanks, Corey include/linux/pkt_sched.h | 23 ++- tc/q_sfq.c| 43 ++- 2 files changed, 52 insertions(+), 14

[PATCH 1/3] SFQ: Support changing depth and divisor.

2007-08-25 Thread Corey Hickey
This can safely be applied either before or after the kernel patches because the tc_sfq_qopt struct is unchanged: - old kernels will ignore the parameters from new iproute2 - new kernels will use the same default parameters --- include/linux/pkt_sched.h |9 - tc/q_sfq.c

[PATCH 09/10] Change perturb_period to unsigned.

2007-08-25 Thread Corey Hickey
perturb_period is currently a signed integer, but I can't see any good reason why this is so--a negative perturbation period will add a timer that expires in the past, causing constant perturbation, which makes hashing useless. if (q->perturb_period) { q->perturb_timer.expi

[PATCH 10/10] Use nested compat attributes to pass parameters.

2007-08-25 Thread Corey Hickey
This fixes the ambiguity between, for example: tc qdisc change ... perturb 0 tc qdisc change ... Without this patch, there is no way for SFQ to differentiate between a parameter specified to be 0 and a parameter that was omitted. Signed-off-by: Corey Hickey <[EMAIL PROTECTED]> --- include/linux/

[PATCH 07/10] Remove comments about hardcoded values.

2007-08-25 Thread Corey Hickey
None of these are true anymore (hooray!). Signed-off-by: Corey Hickey <[EMAIL PROTECTED]> --- include/linux/pkt_sched.h |8 net/sched/sch_sfq.c | 17 +++-- 2 files changed, 3 insertions(+), 22 deletions(-) diff --git a/include/linux/pkt_sched.h b/include/linux/pk

[PATCH 05/10] Add divisor.

2007-08-25 Thread Corey Hickey
Make hash divisor user-configurable. Signed-off-by: Corey Hickey <[EMAIL PROTECTED]> --- net/sched/sch_sfq.c | 18 +- 1 files changed, 13 insertions(+), 5 deletions(-) diff --git a/net/sched/sch_sfq.c b/net/sched/sch_sfq.c index 2e6d607..827b885 100644 --- a/net/sched/sch_sfq.c

[PATCH 08/10] Multiply perturb_period by HZ when used rather than when assigned.

2007-08-25 Thread Corey Hickey
perturb_period is the only parameter that doesn't match 1:1 with the value from userspace. This change makes it easy and clean to use a small macro for setting parameters (in a subsequent patch). Signed-off-by: Corey Hickey <[EMAIL PROTECTED]> --- net/sched/sch_sfq.c | 10 +- 1 files ch

[PATCH 06/10] Make qdisc changeable.

2007-08-25 Thread Corey Hickey
Re-implement sfq_change() and enable Qdisc_opts.change so "tc qdisc change" will work. Signed-off-by: Corey Hickey <[EMAIL PROTECTED]> --- net/sched/sch_sfq.c | 64 ++- 1 files changed, 63 insertions(+), 1 deletions(-) diff --git a/net/sched/sch_

[PATCH 03/10] Move two functions.

2007-08-25 Thread Corey Hickey
Move sfq_q_destroy() to above sfq_q_init() so that it can be used by an error case in a later patch. Move sfq_destroy() as well, for clarity. Signed-off-by: Corey Hickey <[EMAIL PROTECTED]> --- net/sched/sch_sfq.c | 22 +++--- 1 files changed, 11 insertions(+), 11 deletions(-)

[PATCH 04/10] Make "depth" (number of queues) user-configurable:

2007-08-25 Thread Corey Hickey
* replace #define with a parameter * use old hardcoded value as a default * kcalloc() arrays in sfq_q_init() * free() arrays in sfq_q_destroy() Signed-off-by: Corey Hickey <[EMAIL PROTECTED]> --- net/sched/sch_sfq.c | 84 +++ 1 files changed, 58 i

[PATCH 00/10] SFQ: backport some features from ESFQ (try 3)

2007-08-25 Thread Corey Hickey
Patchset try 2 addresses the review by Michael Buesch. Patchset try 3 addresses the review by Patrick McHardy. The first 7 patches in this series resemble the corresponding 7 patches I sent previously. There aren't any major changes--just modifications to address errors noticed in review and sligh

[PATCH 01/10] Preparatory refactoring part 1.

2007-08-25 Thread Corey Hickey
Make a new function sfq_q_enqueue() that operates directly on the queue data. This will be useful for implementing sfq_change() in a later patch. A pleasant side-effect is reducing most of the duplicate code in sfq_enqueue() and sfq_requeue(). Similarly, make a new function sfq_q_dequeue(). Signe

[PATCH 02/10] Preparatory refactoring part 2.

2007-08-25 Thread Corey Hickey
Factor code out of sfq_init() and sfq_destroy(), again so that the new functions can be used by sfq_change() later. Actually, as the diff itself shows, most of the sfq_q_init() code comes from the original sfq_change(), but sfq_change() is only called by sfq_init() right now. Thus, it is safe to r

Re: [XFRM] policy: Replace magic number with XFRM_POLICY_OUT

2007-08-25 Thread David Miller
From: Thomas Graf <[EMAIL PROTECTED]> Date: Sat, 25 Aug 2007 12:53:41 +0200 > Signed-off-by: Thomas Graf <[EMAIL PROTECTED]> Applied, thanks Thomas. - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vge

[PATCH] bmac: add simple ethtool support for network manager

2007-08-25 Thread Olaf Hering
NetworkManager will not start dhcpd on an interface unless it reports link-up state via ethtool. Signed-off-by: Olaf Hering <[EMAIL PROTECTED]> --- drivers/net/bmac.c | 13 + 1 file changed, 13 insertions(+) --- a/drivers/net/bmac.c +++ b/drivers/net/bmac.c @@ -19,6 +19,7 @@ #in

iproute2: no error messages for unsupported table requests

2007-08-25 Thread Martin von Gagern
Hi! A while ago I've tried to configure multiple routing tables using iproute2-2.6.20. As my kernel at that time was configured without CONFIG_IP_MULTIPLE_TABLES this could not work. However, I got no error message from the ip command, the route was added to the main table, and it took me quite a

Re: [Bug 8934] System freeze when restarting network connection with Broadcom driver

2007-08-25 Thread Andrew Morton
On Sat, 25 Aug 2007 03:26:24 -0700 (PDT) [EMAIL PROTECTED] wrote: > http://bugzilla.kernel.org/show_bug.cgi?id=8934 Various nasty box-killing things happening here and http://bugzilla.kernel.org/show_bug.cgi?id=8937 might be related. Michal, 8934 (at least) is a post-2.6.22 regression - can you

Re: [PATCH] ucc_geth: kill unused include

2007-08-25 Thread Kumar Gala
On Aug 24, 2007, at 11:37 PM, Jeff Garzik wrote: Kumar Gala wrote: The ucc_geth_mii code is based on the gianfar_mii code that use to include ocp.h. ucc never need this and it causes issues when we want to kill arch/ppc includes from arch/powerpc. Signed-off-by: Kumar Gala <[EMAIL PROTECTED

[XFRM] policy: Replace magic number with XFRM_POLICY_OUT

2007-08-25 Thread Thomas Graf
Signed-off-by: Thomas Graf <[EMAIL PROTECTED]> Index: net-2.6.24/net/xfrm/xfrm_policy.c === --- net-2.6.24.orig/net/xfrm/xfrm_policy.c 2007-08-24 13:11:17.0 +0200 +++ net-2.6.24/net/xfrm/xfrm_policy.c 2007-08-24 13:11

Re: [PATCH 2.6.23-rc3-mm1] request_irq fix DEBUG_SHIRQ handling Re: 2.6.23-rc2-mm1: rtl8139 inconsistent lock state

2007-08-25 Thread Mariusz Kozlowski
> > = > > [ INFO: inconsistent lock state ] > > 2.6.23-rc2-mm1 #7 > > - > > inconsistent {in-hardirq-W} -> {hardirq-on-W} usage. > > ifconfig/5492 [HC0[0]:SC0[0]:HE1:SE1] takes: > > (&tp->lock){+...}, at: [] rtl8139_interrupt+0x27/0x4

Re: [PATCH 4/5] [TCP]: Discard fuzzy SACK blocks

2007-08-25 Thread Ilpo Järvinen
On Fri, 24 Aug 2007, David Miller wrote: > From: "Ilpo_Järvinen" <[EMAIL PROTECTED]> > Date: Mon, 20 Aug 2007 16:16:32 +0300 > > > SACK processing code has been a sort of russian roulette as no > > validation of SACK blocks is previously attempted. Besides, it > > is not very clear what all kinds

[PATCH 1/1] MAINTAINERS, order NETERION alphabetically

2007-08-25 Thread Jiri Slaby
MAINTAINERS, order NETERION alphabetically Signed-off-by: Jiri Slaby <[EMAIL PROTECTED]> --- commit f5f10b061961546a77300f3ebe92abd9cb5b9b48 tree 90ad6e22504aeaadb17309d01996eb6cd7eb5a93 parent c858c1b27bfb4c58c9ebfa24de0d6442e364db97 author Jiri Slaby <[EMAIL PROTECTED]> Sat, 25 Aug 2007 09:39:0

[PATCH 4/4] Net: ath5k, remove some ieee80211 re-defines

2007-08-25 Thread Jiri Slaby
ath5k, remove some ieee80211 re-defines use mac80211 defines directly instead. this means MODULATION_* to IEEE80211_RATE_* switch. Signed-off-by: Jiri Slaby <[EMAIL PROTECTED]> Cc: <[EMAIL PROTECTED]> --- commit c858c1b27bfb4c58c9ebfa24de0d6442e364db97 tree 1add137b1e95ca1b4905441b5e30c779f8801c

[PATCH 3/4] Net: ath5k, use short preamble for some rates

2007-08-25 Thread Jiri Slaby
ath5k, use short preamble for some rates 2, 5.5 and 11 in b/g are now in short preamble mode Signed-off-by: Jiri Slaby <[EMAIL PROTECTED]> Cc: <[EMAIL PROTECTED]> --- commit 0a11d301ccb5caf1c9738a7307002a5295aecd58 tree f812c3fb91651437c7b434afbd4f8dc8435611f0 parent 0aebc8bb5574b6b0cc8f9f0d7367

[PATCH 1/4] Net: ath5k, comment some EEPROM registers

2007-08-25 Thread Jiri Slaby
ath5k, comment some EEPROM registers make some registers meaning clear Signed-off-by: Jiri Slaby <[EMAIL PROTECTED]> Cc: <[EMAIL PROTECTED]> --- commit 06615d9cdf1ae777821dfcd7845c72c38ff14ffa tree d0c4b9ded4aa541e003b6855e9bde072e01b631d parent 069bfbe93facb3468f579568434d18f1268a487c author Ji

[git patches] net driver fixes

2007-08-25 Thread Jeff Garzik
Please pull from 'upstream-linus' branch of master.kernel.org:/pub/scm/linux/kernel/git/jgarzik/netdev-2.6.git upstream-linus to receive the following updates: drivers/net/dm9000.c| 25 --- drivers/net/ehea/ehea_main.c|8 ++-- drivers/net/ehea/ehea_qmr.c |

Re: [PATCH 1/3] e1000e: retire last_tx_tso workaround

2007-08-25 Thread Jeff Garzik
Auke Kok wrote: This TSO-related workaround is no longer needed since it's only applicable for 8254x silicon. Signed-off-by: Auke Kok <[EMAIL PROTECTED]> --- drivers/net/e1000e/e1000.h | 15 +++ drivers/net/e1000e/netdev.c | 20 ++-- 2 files changed, 5 insertio