Re: [RFC] New driver API to speed up small packets xmits

2007-05-12 Thread Andi Kleen
On Friday 11 May 2007 13:16:44 Roland Dreier wrote: > > I wasn't talking about sending. > > > > But there actually is :- TSO/GSO. > > As I said before, getting multiple packets in one call to xmit would > be nice for amortizing per-xmit overhead in IPoIB. So it would be > nice if the cases wh

Re: [PATCH 1/1] Reverse sense of promisc tests in ip6_mc_input

2007-05-12 Thread David Stevens
Your patch looks correct to me. +-DLS Signed-off-by: David L Stevens <[EMAIL PROTECTED]> [EMAIL PROTECTED] wrote on 05/12/2007 03:51:35 PM: > From: Corey Mutter <[EMAIL PROTECTED]> > > Reverse the sense of the promiscuous-mode tests in ip6_mc_input(). > > Signed-off-b

[PATCH 1/1] Reverse sense of promisc tests in ip6_mc_input

2007-05-12 Thread Corey Mutter
From: Corey Mutter <[EMAIL PROTECTED]> Reverse the sense of the promiscuous-mode tests in ip6_mc_input(). Signed-off-by: Corey Mutter <[EMAIL PROTECTED]> --- I had been suspicious of this code for a while, but just assumed I must have been missing something. However, I did some tests and, sur

[patch 2/4] [v2] pasemi_mac: Interrupt ack fixes

2007-05-12 Thread Olof Johansson
Interrupt ack fixes Fix the packet count resets at interrupt time, using the cacheable packet count status to set number of processed/received packets, since the ack count is the cumulative number of packets processed, and not incremental. Signed-off-by: Olof Johansson <[EMAIL PROTECTED]> ---

Re: default y idiocy

2007-05-12 Thread James Bottomley
On Sat, 2007-05-12 at 20:58 +0100, Simon Arlott wrote: > On 12/05/07 19:23, Jens Axboe wrote: > > Hi, > > > > This has bothered me for a long time, and it just seems to be getting > > worse. Can people please STOP defaulting non-essential stuff to 'y'? > > Grrr. > > Is there a reason why various

Re: default y idiocy

2007-05-12 Thread Jens Axboe
On Sat, May 12 2007, Simon Arlott wrote: > On 12/05/07 19:23, Jens Axboe wrote: > >Hi, > > > >This has bothered me for a long time, and it just seems to be getting > >worse. Can people please STOP defaulting non-essential stuff to 'y'? > >Grrr. > > Is there a reason why various 10/100/1000Mbit net

[patch] ip_local_port_range sysctl has annoying default

2007-05-12 Thread Mark Glines
(resending to netdev and copying maintainers, at Alan Cox's suggestion. Thanks Alan!) On Sat, 12 May 2007 12:12:38 -0700 "H. Peter Anvin" <[EMAIL PROTECTED]> wrote: > Mark Glines wrote: > > > > Well, in that case, is there anything wrong with just using the > > range IANA recommends, in all cas

Re: default y idiocy

2007-05-12 Thread Simon Arlott
On 12/05/07 19:23, Jens Axboe wrote: Hi, This has bothered me for a long time, and it just seems to be getting worse. Can people please STOP defaulting non-essential stuff to 'y'? Grrr. Is there a reason why various 10/100/1000Mbit network cards are 'y' too? There's even a default SCSI 'm' tha

Re: take 3 [RFC] make qdisc_restart more readable

2007-05-12 Thread jamal
On Sat, 2007-12-05 at 19:02 +0200, Patrick McHardy wrote: > jamal wrote: > > diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h > > #define NETDEV_TX_LOCKED -1/* driver tx lock was already taken */ > > +#define NETDEV_TX_DROP -2 /* request caller to drop packet */ > > Th

[patch 2/4] pasemi_mac: Interrupt ack fixes

2007-05-12 Thread olof
Fix the packet count resets at interrupt time, using the cacheable packet count status to set number of processed/received packets. The ack count is the cumulative number of packets processed, and not incremental. Signed-off-by: Olof Johansson <[EMAIL PROTECTED]> Index: netdev-2.6/drivers/net/

[patch 3/4] pasemi_mac: Terminate PCI ID list

2007-05-12 Thread olof
This caused some very interesting behaviour depending on what happened to be built at the same time. Add terminating empty entry to the list of IDs. Signed-off-by: Olof Johansson <[EMAIL PROTECTED]> Index: netdev-2.6/drivers/net/pasemi_mac.c ===

[patch 4/4] pasemi_mac: Fix local-mac-address parsing

2007-05-12 Thread olof
Turns out we have an old version of firmware that stores the mac address in 'mac-address' as a string instead of a byte array. All versions that use local-mac-address should have it as byte array, so no need to do string parsing for that case. Signed-off-by: Olof Johansson <[EMAIL PROTECTED]> In

[patch 0/4] pasemi_mac: Bugfixes for pasemi_mac

2007-05-12 Thread olof
Hi, 4 bugfixes for pasemi_mac: [patch 1/4] pasemi_mac: Fix register defines [patch 2/4] pasemi_mac: Interrupt ack fixes [patch 3/4] pasemi_mac: Terminate PCI ID list [patch 4/4] pasemi_mac: Fix local-mac-address parsing Thanks, -Olof - To unsubscribe from this list: send the line "unsubscribe

[patch 1/4] pasemi_mac: Fix register defines

2007-05-12 Thread olof
Some shift values were obviously wrong. Fix them to correspond with the masks. Signed-off-by: Olof Johansson <[EMAIL PROTECTED]> Index: netdev-2.6/drivers/net/pasemi_mac.h === --- netdev-2.6.orig/drivers/net/pasemi_mac.h +++ netdev-

[PATCH] improved locking performance in rt_run_flush()

2007-05-12 Thread Dave Johnson
While testing adding/deleting large numbers of interfaces, I found rt_run_flush() was the #1 cpu user in a kernel profile by far. The below patch changes rt_run_flush() to only take each spinlock protecting the rt_hash_table once instead of taking a spinlock for every hash table bucket (and endin

Re: take 3 [RFC] make qdisc_restart more readable

2007-05-12 Thread Patrick McHardy
jamal wrote: > diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h > index f671cd2..718d6fd 100644 > --- a/include/linux/netdevice.h > +++ b/include/linux/netdevice.h > @@ -83,6 +83,9 @@ struct wireless_dev; > #define NETDEV_TX_OK 0 /* driver took care of packet */ >

Re: 2.6.20.7 TCP cubic (and bic) initial slow start way too slow?

2007-05-12 Thread SANGTAE HA
Hi Bill, This is the small patch that has been applied to 2.6.22. Also, there is "limited slow start", which is an experimental RFC (RFC3742), to surmount this large increase during slow start. But, your kernel might not have this. Please check there is a sysctl variable "tcp_max_ssthresh". Than

Re: 2.6.20.7 TCP cubic (and bic) initial slow start way too slow?

2007-05-12 Thread Bill Fink
On Thu, 10 May 2007, Injong Rhee wrote: > Oops. I thought Bill was using 2.6.20 instead of 2.6.22 which should contain > our latest update. I am using 2.6.20.7. > Regarding slow start behavior, the latest version should not change though. > I think it would be ok to change the slow start of bi

Re: kernel oops after unloading nf_conntrack_netbios_ns_module

2007-05-12 Thread Patrick McHardy
Gabor Burjan wrote: > EIP is at destroy_conntrack+0x52/0x127 [nf_conntrack] > >>>nmblookup >>>cat /proc/net/ip_conntrack >>> >>>sleep 3 >>> >>>rmmod nf_conntrack_netbios_ns Thanks for the report and good testcase, the crash can only happen with a sleep of >= 3s after the last nmblookup packet wa

Re: APIC error on 32-bit kernel

2007-05-12 Thread Jay Cliburn
Thank you very much for looking at this, Len. On Fri, 11 May 2007 23:28:58 -0400 Len Brown <[EMAIL PROTECTED]> wrote: > > > [ 94.754852] APIC error on CPU0: 08(40) > > > [ 94.806045] APIC error on CPU0: 40(08) > > /* Here is what the APIC error bits mean: >0: Send CS err

take 3 [RFC] make qdisc_restart more readable

2007-05-12 Thread jamal
Ok, heres the next iteration based on feedback from Thomas and Peter. It seems this is good form in matching what the original code does. I have a few doubts in labelled as XXX in there. Thomas, if you have time, do you mind looking at those? The usual testing happened i.e "if you can see this em

Re: [BUG][debian-2.6.20-1-686] bridging + vlans + "vconfig rem" == stuck kernel

2007-05-12 Thread Kyle Moffett
On May 11, 2007, at 01:49:27, Kyle Moffett wrote: On May 10, 2007, at 00:34:11, Kyle Moffett wrote: On May 10, 2007, at 00:25:54, Ben Greear wrote: Looks like a deadlock in the vlan code. Any chance you can run this test with lockdep enabled? You could also add a printk in vlan_device_event

Re: take 2 WAS (RE: [RFC] make qdisc_restart more readable

2007-05-12 Thread jamal
On Sat, 2007-12-05 at 11:46 +0200, Thomas Graf wrote: > > + struct sk_buff *skb = NULL; > > + > > + if (skb = dev->gso_skb) > > This must have caused a warning Possibly (dont recall) - i will move the assignment to the first line. > and you probably want to inline this function. will do.

Re: take 2 WAS (RE: [RFC] make qdisc_restart more readable

2007-05-12 Thread Thomas Graf
* jamal <[EMAIL PROTECTED]> 2007-05-11 15:29 > diff --git a/net/sched/sch_generic.c b/net/sched/sch_generic.c > + netif_schedule(dev); > + return 0; > +} > + > +static struct sk_buff * > +try_get_tx_pkt(struct net_device *dev, struct Qdisc *q) > +{ > + struct sk_buff *skb = NULL; > + >

Re: [PATCH] tbf scheduler: TSO support

2007-05-12 Thread Hirokazu Takahashi
Hi, > > > I think the concept of TBF is quit good but the userspace tools have > > > become old that it doesn't fit to Gb ethernet environment. > > > The tools should be updated to care about much faster network and > > > GbE jumbo frames. I agree with you at this point. > > > > > > On the other

Re: [PATCH] tbf scheduler: TSO support

2007-05-12 Thread Hirokazu Takahashi
Hi, > > I think the concept of TBF is quit good but the userspace tools have > > become old that it doesn't fit to Gb ethernet environment. > > The tools should be updated to care about much faster network and > > GbE jumbo frames. I agree with you at this point. > > > > On the other hand, handli

Re: Pull request for 'r8169-for-jeff' branch

2007-05-12 Thread Francois Romieu
Francois Romieu <[EMAIL PROTECTED]> : > Please pull from branch 'r8169-for-jeff' in repository > > git://electric-eye.fr.zoreil.com/home/romieu/linux/linux-2.6-out > r8169-for-jeff [...] > Shortlog > > > Francois Romieu (10): > r8169: add per-device hw_start handler (1/2) >