[Lldb-commits] [PATCH] D105717: Create "thread trace dump stats" command

2021-07-09 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang created this revision. hanbingwang added reviewers: wallace, clayborg. Herald added a subscriber: dang. hanbingwang requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. When the user types that command 'thread trace dump stats' and t

[Lldb-commits] [PATCH] D105717: [trace] [intel pt] Create a "thread trace dump stats" command

2021-07-16 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 359253. hanbingwang edited the summary of this revision. hanbingwang added a comment. 1. rename "thread trace dump stats" to "thread trace dump info" 2. Additionally, print out the tracing plugin name. CHANGES SINCE LAST ACTION https://reviews.llvm.org

[Lldb-commits] [PATCH] D105717: [trace] [intel pt] Create a "thread trace dump stats" command

2021-07-16 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang marked 2 inline comments as done. hanbingwang added inline comments. Comment at: lldb/include/lldb/Target/Trace.h:155 + /// If \b false, print compact stats + virtual void DumpTraceStats(Thread &thread, Stream &s, bool verbose) = 0; + clayborg w

[Lldb-commits] [PATCH] D105717: [trace] [intel pt] Create a "thread trace dump stats" command

2021-07-18 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 359671. hanbingwang marked an inline comment as done. hanbingwang added a comment. F18016096: Screen Shot 2021-07-18 at 11.07.29 PM.png print out the tracing plugin name exactly once when there are one or more than o

[Lldb-commits] [PATCH] D105717: [trace] [intel pt] Create a "thread trace dump stats" command

2021-07-19 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 359994. hanbingwang added a comment. {F18030885 }add two spaces before the string "Raw trace size : xxx"; add new line between each thread. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D105717/new/ https://re

[Lldb-commits] [PATCH] D105717: [trace] [intel pt] Create a "thread trace dump stats" command

2021-07-20 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 360035. hanbingwang edited the summary of this revision. hanbingwang added a comment. Create a "thread trace dump info" command CHANGES SINCE LAST ACTION https://reviews.llvm.org/D105717/new/ https://reviews.llvm.org/D105717 Files: lldb/include/lld

[Lldb-commits] [PATCH] D105717: [trace] [intel pt] Create a "thread trace dump stats" command

2021-07-20 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 360037. hanbingwang added a comment. Create a "thread trace dump info" command CHANGES SINCE LAST ACTION https://reviews.llvm.org/D105717/new/ https://reviews.llvm.org/D105717 Files: lldb/include/lldb/Target/Trace.h lldb/source/Commands/CommandOb

[Lldb-commits] [PATCH] D105717: [trace] [intel pt] Create a "thread trace dump stats" command

2021-07-20 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 360044. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D105717/new/ https://reviews.llvm.org/D105717 Files: lldb/include/lldb/Target/Trace.h lldb/source/Commands/CommandObjectThread.cpp lldb/source/Commands/Options.td lldb/source/Plugins/Tr

[Lldb-commits] [PATCH] D107669: Create "process trace save" command

2021-08-06 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang created this revision. hanbingwang added reviewers: wallace, clayborg. Herald added subscribers: dang, mgorny. hanbingwang requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. added new command "process trace save -d ". -it only supp

[Lldb-commits] [PATCH] D107669: [trace] [intel pt] Create a "process trace save" command

2021-08-06 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 364893. hanbingwang added a comment. fix a typo. change a string "the trace of ..." from "the trace or ..." CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107669/new/ https://reviews.llvm.org/D107669 Files: lldb/include/lldb/Target/Trace.h l

[Lldb-commits] [PATCH] D107669: [trace] [intel pt] Create a "process trace save" command

2021-08-11 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 365883. hanbingwang marked an inline comment as done. hanbingwang added a comment. *trace.h: -rename SaveToDisk() to SaveLiveTraceToDisk() *IntelPTDecoder.h, IntelPTDecoder.cpp: -removed GetRawTrace() *TraceIntelPT.h, TraceIntelPT.cpp: -removed GetThr

[Lldb-commits] [PATCH] D107669: [trace] [intel pt] Create a "process trace save" command

2021-08-11 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang added inline comments. Comment at: lldb/source/Plugins/Trace/intel-pt/TraceIntelPTSessionFileSaver.cpp:87 +llvm::Expected +TraceIntelPTSessionFileSaver::BuildProcessesSection(lldb::ProcessSP &process_sp, +TraceInte

[Lldb-commits] [PATCH] D107669: [trace] [intel pt] Create a "process trace save" command

2021-08-12 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 366151. hanbingwang edited the summary of this revision. hanbingwang added a comment. Herald added a subscriber: pengfei. *TraceSessionSaver.h, TraceSessionSaver.cpp: -move BuildModulesSection(), BuildThreadsSection(), BuildProcessesSection(), WriteSessio

[Lldb-commits] [PATCH] D107669: [trace] [intel pt] Create a "process trace save" command

2021-08-16 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 366690. hanbingwang added a comment. *TraceIntelPT.h, TraceIntelPT.cpp: -add new function GetLiveProcess() *TraceIntelPTSessionSaver.h, TraceIntelPTSessionSaver.cpp - the function SaveToDisk() no longer requires "m_live_process" as input param. *TestTrac

[Lldb-commits] [PATCH] D107669: [trace] [intel pt] Create a "process trace save" command

2021-08-16 Thread hanbing wang via Phabricator via lldb-commits
hanbingwang updated this revision to Diff 366713. hanbingwang marked an inline comment as not done. hanbingwang added a comment. merge into one line: "json_module["loadAddress"] = oss.str();" CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107669/new/ https://reviews.llvm.org/D107669 Fil