[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2019-12-03 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1767049 , @labath wrote: > In D70840#1767028 , @mstorsjo wrote: > > > In D70840#1765373 , @clayborg > > wrote: > > > > > So some backgrou

[Lldb-commits] [PATCH] D70848: [LLDB] Set the right address size on output DataExtractors from ObjectFile

2019-12-04 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo marked an inline comment as done. mstorsjo added a comment. In D70848#1768730 , @labath wrote: > BTW, I don't know if you've noticed, but the new test is failing on windows: > http://lab.llvm.org:8011/builders/lldb-x64-windows-ninja/builds/11217.

[Lldb-commits] [PATCH] D70848: [LLDB] Set the right address size on output DataExtractors from ObjectFile

2019-12-04 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo marked an inline comment as done. mstorsjo added inline comments. Comment at: lldb/source/Symbol/ObjectFile.cpp:480-486 + size_t ret = data.SetData(m_data, offset, length); + // DataExtractor::SetData copies the address byte size from m_data, but + // m_data's address

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2019-12-06 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1767611 , @mstorsjo wrote: > In D70840#1767049 , @labath wrote: > > > In D70840#1767028 , @mstorsjo > > wrote: > > > > > In D70840#176537

[Lldb-commits] [PATCH] D70848: [LLDB] Set the right address size on output DataExtractors from ObjectFile

2019-12-06 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo marked an inline comment as done. mstorsjo added inline comments. Comment at: lldb/source/Symbol/ObjectFile.cpp:480-486 + size_t ret = data.SetData(m_data, offset, length); + // DataExtractor::SetData copies the address byte size from m_data, but + // m_data's address

[Lldb-commits] [PATCH] D71108: [LLDB] [PECOFF] Make sure to set the address byte size in m_data after parsing headers

2019-12-06 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo created this revision. mstorsjo added reviewers: labath, clayborg. Herald added a project: LLDB. If not set, the address byte size was implied to be the one of the host process. This allows reverting the functional change from 31087b2ae9154, since now PECOFF does the same as ELF and Mac

[Lldb-commits] [PATCH] D71108: [LLDB] [PECOFF] Make sure to set the address byte size in m_data after parsing headers

2019-12-10 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. @labath does this one seem sensible and like what you suggested in D70848 ? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D71108/new/ https://reviews.llvm.org/D71108

[Lldb-commits] [PATCH] D71108: [LLDB] [PECOFF] Make sure to set the address byte size in m_data after parsing headers

2019-12-10 Thread Martin Storsjö via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGa0f72441c898: [LLDB] [PECOFF] Make sure to set the address byte size in m_data after parsing… (authored by mstorsjo). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llv

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2019-12-11 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1763639 , @labath wrote: > - I think we ought to have some kind of a utility function to hold the logic > for the `&~1` stuff. there is something like that in > Architecture::GetOpcodeLoadAddress. The Architecture clas

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2019-12-12 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo updated this revision to Diff 233586. mstorsjo edited the summary of this revision. mstorsjo added a comment. Added ArchSpec::GetOpcodeLoadAddress() (didn't refactor Architecture to use it yet, so this is still duplicated code with the ArchitectureArm and ArchitectureMips plugins, but p

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2019-12-12 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1782951 , @clayborg wrote: > So my idea would be: > 1 - add all virtual functions to from lldb_private::Architecture as normal > members of ArchSpec. > 2 - have ArchSpec grap the the lldb_private::Architecture using

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2019-12-19 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. @clayborg - can you follow up on @labath's reply here? And irrespectively if the ArchSpec vs Architecture design, can you (either of you) comment on the updated form of the patch? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70840/new/ https://reviews.llvm.o

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2019-12-20 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1792498 , @labath wrote: > In D70840#1791292 , @mstorsjo wrote: > > > And irrespectively if the ArchSpec vs Architecture design, can you (either > > of you) comment on the update

[Lldb-commits] [PATCH] D71235: [lldb/Lua] Generate Lua Bindings and Make Them Available to the Script Interpreter

2019-12-22 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added inline comments. Comment at: lldb/CMakeLists.txt:55 - add_subdirectory(scripts) endif () This change here (unconditionally including the scripts subdir) made SWIG a hard dependency, even if both lua and python are disabled. I pushed a commit

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2020-01-24 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1792498 , @labath wrote: > In D70840#1791292 , @mstorsjo wrote: > > > And irrespectively if the ArchSpec vs Architecture design, can you (either > > of you) comment on the update

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2020-01-24 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo updated this revision to Diff 240118. mstorsjo added a comment. Herald added a reviewer: shafik. Hopefully this is a bit less schizophrenic now. It's still quite RFC'y and many of the fixup loops could probably still be refactored, if someone suggests where to place the shared code. C

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2020-01-24 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1838186 , @labath wrote: > Yes, I was keeping this problem in mind when I was working on that patch. :) > I believe more work could be done to reduce the number of places that parse > DW_AT_low/high_pc, but I haven't g

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2020-01-24 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo updated this revision to Diff 240292. mstorsjo added a comment. I tried doing the other alternative; now we primarily touch up the values in DWARFDebugInfoEntry::GetAttributeAddressRange(s) and DWARFDebugInfoEntry::GetDIENamesAndRanges. This variant feels fairly concise and consistent.

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2020-01-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo marked 2 inline comments as done. mstorsjo added inline comments. Comment at: lldb/include/lldb/Expression/DWARFExpression.h:142 + std::pair GetLocationListAddresses() const; + clayborg wrote: > Might be better as two functions? One to get the CU addr

[Lldb-commits] [PATCH] D70840: [LLDB] [DWARF] Strip out the thumb bit from addresses on ARM

2020-01-28 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70840#1844279 , @labath wrote: > Right, your answer implicitly assumes (and I do agree with you) that the > answer is that `getSubroutineForAddress` should return the function that > address is in. That is not unreasonable -

[Lldb-commits] [PATCH] D73839: [LLDB] Add missing declarations for linking to psapi

2020-02-01 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo created this revision. mstorsjo added reviewers: labath, amccarth. Herald added a subscriber: mgorny. Herald added a project: LLDB. This fixes building for mingw with BUILD_SHARED_LIBS. In static builds, the psapi dependency gets linked in transitively from Support, but when linking Sup

[Lldb-commits] [PATCH] D73839: [LLDB] Add missing declarations for linking to psapi

2020-02-03 Thread Martin Storsjö via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGeb5ee9275d7a: [LLDB] Add missing declarations for linking to psapi (authored by mstorsjo). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D73839/new/ https://

[Lldb-commits] [PATCH] D73839: [LLDB] Add missing declarations for linking to psapi

2020-02-03 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D73839#1854328 , @teemperor wrote: > I guess this is causing the windows failure on the bot: > http://lab.llvm.org:8011/builders/lldb-x64-windows-ninja/builds/13320 Yeah, I saw that - highly strange. I'll try to see if I can

[Lldb-commits] [PATCH] D73839: [LLDB] Add missing declarations for linking to psapi

2020-02-03 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D73839#1854333 , @mstorsjo wrote: > In D73839#1854328 , @teemperor wrote: > > > I guess this is causing the windows failure on the bot: > > http://lab.llvm.org:8011/builders/lldb-x64-wi

[Lldb-commits] [PATCH] D74084: [LLDB] Fix compilation with GCC 5

2020-02-05 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo created this revision. mstorsjo added reviewers: labath, aprantl. Herald added a project: LLDB. Repository: rG LLVM Github Monorepo https://reviews.llvm.org/D74084 Files: lldb/source/DataFormatters/FormatCache.cpp lldb/source/DataFormatters/LanguageCategory.cpp lldb/source/Inter

[Lldb-commits] [PATCH] D74084: [LLDB] Fix compilation with GCC 5

2020-02-06 Thread Martin Storsjö via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG5bbaf543585c: [LLDB] Fix compilation with GCC 5 (authored by mstorsjo). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D74084/new/ https://reviews.llvm.org/D7

[Lldb-commits] [PATCH] D74084: [LLDB] Fix compilation with GCC 5

2020-02-06 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a subscriber: hans. mstorsjo added a comment. @hans - this could be applied on 10.x (it seems to apply cleanly), to fix PR44791. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D74084/new/ https://reviews.llvm.org/D74084 ___

<    1   2   3   4   5