[Lldb-commits] [lldb] r370440 - [lldb][NFC] Move Clang-specific flags to ClangUserExpression

2019-08-30 Thread Raphael Isemann via lldb-commits
Author: teemperor Date: Fri Aug 30 00:44:29 2019 New Revision: 370440 URL: http://llvm.org/viewvc/llvm-project?rev=370440&view=rev Log: [lldb][NFC] Move Clang-specific flags to ClangUserExpression LLVMUserExpression doesn't use these variables and they are all specific to Clang. Also removes m_

[Lldb-commits] [PATCH] D66791: [lldb][ELF] Read symbols from .gnu_debugdata sect.

2019-08-30 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D66791#1651300 , @kwk wrote: > Currently the test > `lldb/packages/Python/lldbsuite/test/linux/minidebuginfo/TestMiniDebugInfo.py` > fails if `LLVM_ENABLE_LZMA` is not defined because the test stupidly assumes > that support f

[Lldb-commits] [PATCH] D66962: [lldb][NFC] Remove TestFormats.py as is tests nothing

2019-08-30 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. Actually, it looks like this test was committed with the regex stuff already being commented out (back in 2015/r228207), so the test never really tested anything.. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D66962/new/ https://review

[Lldb-commits] [lldb] r370449 - dotest: improvements to the pexpect tests

2019-08-30 Thread Pavel Labath via lldb-commits
Author: labath Date: Fri Aug 30 02:07:42 2019 New Revision: 370449 URL: http://llvm.org/viewvc/llvm-project?rev=370449&view=rev Log: dotest: improvements to the pexpect tests Summary: While working on r370054, i've found it frustrating that the test output was compeletely unhelpful in case of fai

[Lldb-commits] [PATCH] D66954: dotest: improvements to the pexpect tests

2019-08-30 Thread Pavel Labath via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL370449: dotest: improvements to the pexpect tests (authored by labath, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Repository: rL LLVM CHANGES SINCE LAST ACTI

[Lldb-commits] [PATCH] D66994: [lldb][CMake] Fix windows-x86-debug compilation with python enabled using multi-target generator

2019-08-30 Thread Leonid Mashinskiy via Phabricator via lldb-commits
leonid.mashinskiy created this revision. leonid.mashinskiy added reviewers: labath, JDevlieghere. leonid.mashinskiy added a project: LLDB. Herald added subscribers: lldb-commits, mgorny. Visual Studio CMake generator is multi-target and does not define CMAKE_BUILD_TYPE, so Debug build on VS was f

[Lldb-commits] [lldb] r370462 - [dotest] Finish removing -q

2019-08-30 Thread Pavel Labath via lldb-commits
Author: labath Date: Fri Aug 30 04:02:58 2019 New Revision: 370462 URL: http://llvm.org/viewvc/llvm-project?rev=370462&view=rev Log: [dotest] Finish removing -q One usage of this option remained, and caused dotest to error out if one happened to pass the -v flag. Modified: lldb/trunk/package

[Lldb-commits] [PATCH] D66994: [lldb][CMake] Fix windows-x86-debug compilation with python enabled using multi-target generator

2019-08-30 Thread Pavel Labath via Phabricator via lldb-commits
labath added reviewers: amccarth, stella.stamenova. labath added a comment. +windows folks, then can speak to the substance of this change. As for the implementation, I get the impression that there is a lot of duplicated code in here. The code for finding the release and debug pythons is nearl

[Lldb-commits] [PATCH] D67001: [lldb] Limit the amount of zeroes we use for padding when printing small floats

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added a reviewer: LLDB. Herald added subscribers: lldb-commits, JDevlieghere. Herald added a project: LLDB. We got a radar that printing small floats is not very user-friendly in LLDB as we print them with up to 100 leading zeroes before starting to use

[Lldb-commits] [PATCH] D66863: [lldb] Unify target checking in CommandObject

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor updated this revision to Diff 218084. teemperor added a comment. - Removed target requirement where we already have another flag that's implying that we need a target. - Properly formatted some strings. - Extended check in GetSelectedTarget to also check for flags that imply eCommandRe

[Lldb-commits] [PATCH] D67001: [lldb] Limit the amount of zeroes we use for padding when printing small floats

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor planned changes to this revision. teemperor added a comment. Just realised I didn't update any other tests that are maybe broken now due to the changed format. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D67001/new/ https://reviews.llvm.org/D67001

[Lldb-commits] [PATCH] D66863: [lldb] Unify target checking in CommandObject

2019-08-30 Thread Greg Clayton via Phabricator via lldb-commits
clayborg requested changes to this revision. clayborg added a comment. This revision now requires changes to proceed. Just a few string reflows and fix a typo Comment at: lldb/source/Commands/CommandObjectBreakpointCommand.cpp:593 + : CommandObjectParsed(interpreter, "list

[Lldb-commits] [lldb] r370483 - [lit] Fix my earlier bogus fix to not set DYLD_LIBRARY_PATH with Asan.

2019-08-30 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Fri Aug 30 08:56:14 2019 New Revision: 370483 URL: http://llvm.org/viewvc/llvm-project?rev=370483&view=rev Log: [lit] Fix my earlier bogus fix to not set DYLD_LIBRARY_PATH with Asan. My follow-up commit to mess with DYLD_LIBRARY_PATH was bogus for two reasons: - The c

[Lldb-commits] [PATCH] D66934: [ARM64] Simplify RegisterInfos_arm64.h with macro based RegisterInfo array

2019-08-30 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. Just a few nits around DEFINE_GPR64 and how the "alt" names are specified. See inline comments. Comment at: source/Plugins/Process/Utility/RegisterInfos_arm64.h:492 +// Defines a 64-bit general purpose register +#define DEFINE_GPR64(reg, alt, generic_

[Lldb-commits] [PATCH] D66863: [lldb] Unify target checking in CommandObject

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor updated this revision to Diff 218117. teemperor marked 3 inline comments as done. teemperor added a comment. - Fix typo in code and comment. - Reflow some changed strings. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D66863/new/ https://reviews.llvm.org/D66863 Files: lldb/i

[Lldb-commits] [PATCH] D66994: [lldb][CMake] Fix windows-x86-debug compilation with python enabled using multi-target generator

2019-08-30 Thread Adrian McCarthy via Phabricator via lldb-commits
amccarth added a comment. I'll look at this in detail soon, but a few caveats: - lldb tests don't work with the debug Python interpreter, which is why I've been complaining about test failures approximately forever when the bots seem fine. - Some of these changes you're undoing caused a lot of

[Lldb-commits] [PATCH] D67012: [lit] Only set DYLD_LIBRARY_PATH for shared builds

2019-08-30 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: aprantl, mgorny. Herald added subscribers: llvm-commits, abidh. Herald added projects: LLDB, LLVM. JDevlieghere updated this revision to Diff 218133. In r370135 I committed a temporary workaround for the sanitized bot to not set (D

[Lldb-commits] [PATCH] D67012: [lit] Only set DYLD_LIBRARY_PATH for shared builds

2019-08-30 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 218133. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D67012/new/ https://reviews.llvm.org/D67012 Files: lldb/lit/CMakeLists.txt lldb/lit/Suite/lit.cfg lldb/lit/Suite/lit.site.cfg.in llvm/cmake/modules/LLVMConfig.cmake.in Index: llvm/cm

[Lldb-commits] [PATCH] D66994: [lldb][CMake] Fix windows-x86-debug compilation with python enabled using multi-target generator

2019-08-30 Thread Stella Stamenova via Phabricator via lldb-commits
stella.stamenova added a comment. Is there a way to reduce some of the code duplication? The more duplication there is, the harder it is to maintain. Comment at: cmake/modules/LLDBConfig.cmake:240 + if (NOT DEFINED CMAKE_BUILD_TYPE) +# multiconfiguration generator was sel

[Lldb-commits] [lldb] r370503 - [lldb][NFC] More tests for invalid register command invocations

2019-08-30 Thread Raphael Isemann via lldb-commits
Author: teemperor Date: Fri Aug 30 12:19:25 2019 New Revision: 370503 URL: http://llvm.org/viewvc/llvm-project?rev=370503&view=rev Log: [lldb][NFC] More tests for invalid register command invocations Modified: lldb/trunk/packages/Python/lldbsuite/test/functionalities/register/register_comman

[Lldb-commits] [PATCH] D67018: [lldb][NFC] Add basic test for GUI command

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor added a comment. Given how much fun Pavel had fixing my previous pexpect tests, I thought: "Why stop the fun after just two tests?". So here we go! Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D67018/new/ https://reviews.llvm.org/D67018 __

[Lldb-commits] [PATCH] D67018: [lldb][NFC] Add basic test for GUI command

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added reviewers: labath, clayborg. Herald added subscribers: lldb-commits, JDevlieghere. Herald added a project: LLDB. teemperor added a comment. Given how much fun Pavel had fixing my previous pexpect tests, I thought: "Why stop the fun after just two t

[Lldb-commits] [PATCH] D67018: [lldb][NFC] Add basic test for GUI command

2019-08-30 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. It is great to have tests. The main issue I would see is some of the text might not render correctly if the screen size is too small. Can we control the size (char width and height) of the screen in pexpect tests? Repository: rLLDB LLDB CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D67018: [lldb][NFC] Add basic test for GUI command

2019-08-30 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. Seems like revision 370054 sets the screen size quite wide. Just checking that this change will be used for this test? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D67018/new/ https://reviews.llvm.org/D67018 ___ l

[Lldb-commits] [PATCH] D67018: [lldb][NFC] Add basic test for GUI command

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor updated this revision to Diff 218161. teemperor added a comment. - Set terminal dimension. Yeah, Pavel added support for that (but I forgot to set them here because the test I used as a template didn't had the dimensions set). CHANGES SINCE LAST ACTION https://reviews.llvm.org/D670

[Lldb-commits] [lldb] r370526 - [test] Make sure PROMPT is a string

2019-08-30 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Fri Aug 30 13:46:55 2019 New Revision: 370526 URL: http://llvm.org/viewvc/llvm-project?rev=370526&view=rev Log: [test] Make sure PROMPT is a string Currently tests using expect_prompt are failing on the Python 3 bot with an error saying "argument must be str, not bytes"

[Lldb-commits] [PATCH] D67022: Skip getting declarations for repeated DIEs (WIP)

2019-08-30 Thread Guilherme Andrade via Phabricator via lldb-commits
guiandrade created this revision. guiandrade added reviewers: clayborg, labath. guiandrade added a project: LLDB. Herald added subscribers: lldb-commits, JDevlieghere, aprantl. guiandrade added a comment. Hey guys, This change is more for me to get to know what you guys think. I've noticed that

[Lldb-commits] [PATCH] D67022: Skip getting declarations for repeated DIEs (WIP)

2019-08-30 Thread Guilherme Andrade via Phabricator via lldb-commits
guiandrade added a comment. Hey guys, This change is more for me to get to know what you guys think. I've noticed that GetDeclForUIDFromDWARF() calls inside SymbolFileDWARF::ParseDeclsForContext (https://github.com/llvm/llvm-project/blob/ef82098a800178a1f973abb8af86eaa690a29734/lldb/source/Plu

[Lldb-commits] [PATCH] D66994: [lldb][CMake] Fix windows-x86-debug compilation with python enabled using multi-target generator

2019-08-30 Thread Adrian McCarthy via Phabricator via lldb-commits
amccarth requested changes to this revision. amccarth added inline comments. This revision now requires changes to proceed. Comment at: cmake/modules/LLDBConfig.cmake:164 # if(CMAKE_MSVC_RUNTIME_LIBRARY MATCHES MultiThreadedDebug) - if(CMAKE_BUILD_TYPE STREQUAL Debug) -fi

[Lldb-commits] [PATCH] D67012: [lit] Only set DYLD_LIBRARY_PATH for shared builds

2019-08-30 Thread Frederic Riss via Phabricator via lldb-commits
friss accepted this revision. friss added a comment. This revision is now accepted and ready to land. This looks good to me with one small provision: Comment at: lldb/lit/CMakeLists.txt:72 LLVM_ENABLE_ZLIB + LLVM_SHARED_LIBS LLDB_IS_64_BITS) The other bo

[Lldb-commits] [lldb] r370545 - [test] Fix 'argument must be str, not bytes' for Python 3.

2019-08-30 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Fri Aug 30 15:53:38 2019 New Revision: 370545 URL: http://llvm.org/viewvc/llvm-project?rev=370545&view=rev Log: [test] Fix 'argument must be str, not bytes' for Python 3. Use `sys.stdout.buffer` instead of `sys.stdout` in lldbpexpect.py. Modified: lldb/trunk/packag

[Lldb-commits] [lldb] r370549 - [lit] Only set DYLD_LIBRARY_PATH for shared builds

2019-08-30 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Fri Aug 30 16:16:02 2019 New Revision: 370549 URL: http://llvm.org/viewvc/llvm-project?rev=370549&view=rev Log: [lit] Only set DYLD_LIBRARY_PATH for shared builds In r370135 I committed a temporary workaround for the sanitized bot to not set (DY)LD_LIBRARY_PATH when (DY

[Lldb-commits] [PATCH] D67012: [lit] Only set DYLD_LIBRARY_PATH for shared builds

2019-08-30 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL370549: [lit] Only set DYLD_LIBRARY_PATH for shared builds (authored by JDevlieghere, committed by ). Changed prior to commit: https://reviews.llvm.org/D67012?vs=218133&id=218186#toc Repository: rL L

[Lldb-commits] [lldb] r370552 - [test] Make sys.stdout compatible with both Python 2 & 3

2019-08-30 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Fri Aug 30 16:54:13 2019 New Revision: 370552 URL: http://llvm.org/viewvc/llvm-project?rev=370552&view=rev Log: [test] Make sys.stdout compatible with both Python 2 & 3 This time's the charm. Modified: lldb/trunk/packages/Python/lldbsuite/test/lldbpexpect.py Modif

[Lldb-commits] [PATCH] D67033: [lldb] Restructure test folders to match LLDB command hierarchy

2019-08-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added a reviewer: LLDB. Herald added a reviewer: jfb. Herald added subscribers: lldb-commits, JDevlieghere, arphaman. Herald added a project: LLDB. As discussed on lldb-dev, this patch moves some LLDB tests into a hierarchy that more closely resembles th