[Lldb-commits] [lldb] r260078 - Have lldb-server log the timestamp in its log messages

2016-02-08 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Feb 8 03:35:53 2016 New Revision: 260078 URL: http://llvm.org/viewvc/llvm-project?rev=260078&view=rev Log: Have lldb-server log the timestamp in its log messages Modified: lldb/trunk/tools/lldb-server/lldb-gdbserver.cpp Modified: lldb/trunk/tools/lldb-server/lldb-gd

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Pavel Labath via lldb-commits
labath added a subscriber: labath. labath added a comment. Do we have a test for this? If not, it sounds like it would be an easy thing to add one. http://reviews.llvm.org/D16975 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://list

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Pavel Labath via lldb-commits
labath added a comment. Nevermind, I now see you mention TestReturnValue. :/ http://reviews.llvm.org/D16975 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

[Lldb-commits] [lldb] r260081 - Revert "Enable test_lldbmi_settings_set_target_run_args_before on linux"

2016-02-08 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Feb 8 03:58:27 2016 New Revision: 260081 URL: http://llvm.org/viewvc/llvm-project?rev=260081&view=rev Log: Revert "Enable test_lldbmi_settings_set_target_run_args_before on linux" Test is still flaky. Modified: lldb/trunk/packages/Python/lldbsuite/test/tools/lldb-m

[Lldb-commits] [lldb] r260082 - Show real error message in -data-evaluate-expression

2016-02-08 Thread Eugene Leviant via lldb-commits
Author: evgeny777 Date: Mon Feb 8 04:04:51 2016 New Revision: 260082 URL: http://llvm.org/viewvc/llvm-project?rev=260082&view=rev Log: Show real error message in -data-evaluate-expression Modified: lldb/trunk/packages/Python/lldbsuite/test/tools/lldb-mi/variable/TestMiVar.py lldb/trunk/

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a comment. I agree with the idea in general, but I wanted to ask what is your plan with the android decorators: For them we use the additional `api_levels` flag, which does not exist on other platforms/decorators. I suppose we could add that flag to `

Re: [Lldb-commits] [PATCH] D16938: A number of improvements to decorator conditionals

2016-02-08 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Looks good, after applying one fix. Comment at: packages/Python/lldbsuite/test/decorators.py:148 @@ +147,3 @@ +skip_for_triple = _match_decorator_property(triple, lld

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added inline comments. Comment at: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp:581-591 @@ -580,10 +580,13 @@ { size_t byte_size = compiler_type.GetByteSize(&thread); if (byte_size <= 4) { RegisterValue r0_reg_value;

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added a subscriber: tberghammer. tberghammer added a comment. In http://reviews.llvm.org/D16936#346182, @labath wrote: > I agree with the idea in general, but I wanted to ask what is your plan with > the android decorators: For them we use the additional `api_levels` flag, > which d

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Muhammad Omair Javaid via lldb-commits
omjavaid added inline comments. Comment at: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp:581-591 @@ -580,10 +580,13 @@ { size_t byte_size = compiler_type.GetByteSize(&thread); if (byte_size <= 4) { RegisterValue r0_reg_value;

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added inline comments. Comment at: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp:597 @@ +596,3 @@ +{ +if (base_type.IsFloatingPointType(float_count, is_complex)) +{ omjavaid wrote: > tberghammer wro

Re: [Lldb-commits] [PATCH] D16868: [lldb] Fix invalid shift operator overload in Scalar

2016-02-08 Thread Marianne Mailhot-Sarrasin via lldb-commits
mamai added reviewers: labath, tberghammer. mamai updated this revision to Diff 47190. Repository: rL LLVM http://reviews.llvm.org/D16868 Files: source/Core/Scalar.cpp Index: source/Core/Scalar.cpp === --- source/Core/Scalar.cp

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Muhammad Omair Javaid via lldb-commits
omjavaid updated this revision to Diff 47191. omjavaid added a comment. updated diff after incorporating suggested corrections. http://reviews.llvm.org/D16975 Files: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp Index: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp ===

Re: [Lldb-commits] [PATCH] D16868: [lldb] Fix invalid shift operator overload in Scalar

2016-02-08 Thread Pavel Labath via lldb-commits
labath added a comment. `Scalar::operator<<=` seems to do a `m_integer <<= ...`. Will it suffer from the same recursion problem? In any case, I think the implementations of both methods should use the same API (it doesn't matter which one if both work). Also it would be super great if you coul

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Muhammad Omair Javaid via lldb-commits
omjavaid updated this revision to Diff 47198. omjavaid added a comment. Updated adding float_count check. http://reviews.llvm.org/D16975 Files: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp Index: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp =

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added inline comments. Comment at: source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp:592 @@ +591,3 @@ +{ +if (!is_complex) +{ Please check that "float_count == 1" as well (we don't want to use this code

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Zachary Turner via lldb-commits
zturner added a comment. In http://reviews.llvm.org/D16936#346293, @tberghammer wrote: > In http://reviews.llvm.org/D16936#346182, @labath wrote: > > > I agree with the idea in general, but I wanted to ask what is your plan > > with the android decorators: For them we use the additional `api_lev

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. In http://reviews.llvm.org/D16936#346408, @zturner wrote: > In http://reviews.llvm.org/D16936#346293, @tberghammer wrote: > > > In http://reviews.llvm.org/D16936#346182, @labath wrote: > > > > > I agree with the idea in general, but I wanted to ask what is your plan

Re: [Lldb-commits] [PATCH] D16868: [lldb] Fix invalid shift operator overload in Scalar

2016-02-08 Thread Marianne Mailhot-Sarrasin via lldb-commits
mamai added a comment. Scalar::operator<<= works well as-is because it uses APInt &operator<<=(unsigned shiftAmt), whereas the right shift equivalent is not implemented. Should I add APInt &operator>>=, or should I change Scalar::operator<<= for consistency ? Repository: rL LLVM http://r

Re: [Lldb-commits] [PATCH] D16868: [lldb] Fix invalid shift operator overload in Scalar

2016-02-08 Thread Pavel Labath via lldb-commits
labath added a comment. Ah, ok I understand what's going on now. I guess APInt operator >> probably does not exist because it would be ambiguous (arithmetic or bitwise shift?). Let's just leave this as it is now. Could you add that test though? Repository: rL LLVM http://reviews.llvm.org/D

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Todd Fiala via lldb-commits
tfiala added a comment. > I agree but I also might consider going further where the only thing you can > specify is a function and we remove all arguments. Then we implement > functions like architectureMatches, targetOsMatches, hostOsMatches, etc.. and > some logical function what can combine

Re: [Lldb-commits] [PATCH] D16938: A number of improvements to decorator conditionals

2016-02-08 Thread Todd Fiala via lldb-commits
tfiala accepted this revision. tfiala added a comment. LGTM. Regarding the section Pavel was looking at, on the Apple side we have a simulator target that is not technically remote, but isn't really local either. I'll have to look at that if/when we actually want to mark a simulator test as f

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. In http://reviews.llvm.org/D16936#346536, @tfiala wrote: > > I agree but I also might consider going further where the only thing you > > can specify is a function and we remove all arguments. Then we implement > > functions like architectureMatches, targetOsMatches

[Lldb-commits] [PATCH] D16996: Improve the handling of missing elf symtab and missing symbol sizes

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer created this revision. tberghammer added a reviewer: clayborg. tberghammer added a subscriber: lldb-commits. Improve the handling of missing elf symtab and missing symbol sizes * Generate artificial symbol names from eh_fame during symbol parsing so these symbols are already present

Re: [Lldb-commits] [PATCH] D16868: [lldb] Fix invalid shift operator overload in Scalar

2016-02-08 Thread Marianne Mailhot-Sarrasin via lldb-commits
mamai updated this revision to Diff 47218. mamai added a comment. Added a small unit test for scalar right shift operator, which invokes the >>= operator. Repository: rL LLVM http://reviews.llvm.org/D16868 Files: source/Core/Scalar.cpp unittests/CMakeLists.txt unittests/Core/CMakeList

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Zachary Turner via lldb-commits
zturner added a comment. I'm not opposed to it in principle, but I think we should optimize the design for conciseness at the point where you decorate a class or function. If it makes the point of decoration more verbose or harder to read, then I would probably be against it. I guess I'd need

Re: [Lldb-commits] [PATCH] D16975: Handle floating-point type homogeneous aggregate return values in ABISysV_arm

2016-02-08 Thread Greg Clayton via lldb-commits
clayborg resigned from this revision. clayborg removed a reviewer: clayborg. clayborg added a comment. I am fine as long as tberghammer is happy. http://reviews.llvm.org/D16975 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.l

[Lldb-commits] [lldb] r260135 - A number of improvements to decorator conditionals.

2016-02-08 Thread Zachary Turner via lldb-commits
Author: zturner Date: Mon Feb 8 13:35:18 2016 New Revision: 260135 URL: http://llvm.org/viewvc/llvm-project?rev=260135&view=rev Log: A number of improvements to decorator conditionals. * Change the `not_in` function to be called `no_match`. This makes it clear that keyword arguments can be mo

Re: [Lldb-commits] [PATCH] D16938: A number of improvements to decorator conditionals

2016-02-08 Thread Zachary Turner via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL260135: A number of improvements to decorator conditionals. (authored by zturner). Changed prior to commit: http://reviews.llvm.org/D16938?vs=47068&id=47233#toc Repository: rL LLVM http://reviews.ll

Re: [Lldb-commits] [PATCH] D16996: Improve the handling of missing elf symtab and missing symbol sizes

2016-02-08 Thread Greg Clayton via lldb-commits
clayborg requested changes to this revision. clayborg added a comment. This revision now requires changes to proceed. Make sure we use a consistent naming scheme for symbols that don't have names between all ObjectFile subclasses. Comment at: source/Plugins/ObjectFile/ELF/Objec

[Lldb-commits] [lldb] r260177 - Remove skipIfHostPlatform and skipUnlessHostPlatform decorators.

2016-02-08 Thread Zachary Turner via lldb-commits
Author: zturner Date: Mon Feb 8 18:36:27 2016 New Revision: 260177 URL: http://llvm.org/viewvc/llvm-project?rev=260177&view=rev Log: Remove skipIfHostPlatform and skipUnlessHostPlatform decorators. Modified: lldb/trunk/packages/Python/lldbsuite/test/decorators.py lldb/trunk/packages/Pyt

[Lldb-commits] [lldb] r260176 - Remove the skipUnlessArch decorator.

2016-02-08 Thread Zachary Turner via lldb-commits
Author: zturner Date: Mon Feb 8 18:36:22 2016 New Revision: 260176 URL: http://llvm.org/viewvc/llvm-project?rev=260176&view=rev Log: Remove the skipUnlessArch decorator. Convert everything over to using skipIf. Modified: lldb/trunk/packages/Python/lldbsuite/test/decorators.py lldb/trun

[Lldb-commits] [lldb] r260178 - Remove skip and xfail decorators for target architecture.

2016-02-08 Thread Zachary Turner via lldb-commits
Author: zturner Date: Mon Feb 8 18:36:34 2016 New Revision: 260178 URL: http://llvm.org/viewvc/llvm-project?rev=260178&view=rev Log: Remove skip and xfail decorators for target architecture. This removes the following decorators: * skipIfI386 * expectedFailureI386 * expectedFailurex86_64 * skip

[Lldb-commits] LLVM buildmaster will be restarted tonight

2016-02-08 Thread Galina Kistanova via lldb-commits
Hello everyone, LLVM buildmaster will be updated and restarted after 6 PM Pacific time today. Thanks Galina ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Zachary Turner via lldb-commits
zturner added a comment. In http://reviews.llvm.org/D16936#346594, @zturner wrote: > I'm not opposed to it in principle, but I think we should optimize the design > for conciseness at the point where you decorate a class or function. If it > makes the point of decoration more verbose or harder

[Lldb-commits] [PATCH] D17014: [TestExprsChar] Fix a typo is failure archs list

2016-02-08 Thread Siva Chandra via lldb-commits
sivachandra created this revision. sivachandra added a reviewer: zturner. sivachandra added a subscriber: lldb-commits. http://reviews.llvm.org/D17014 Files: packages/Python/lldbsuite/test/expression_command/char/TestExprsChar.py Index: packages/Python/lldbsuite/test/expression_command/char/Te

[Lldb-commits] [lldb] r260192 - [TestExprsChar] Fix a typo is failure archs list

2016-02-08 Thread Siva Chandra via lldb-commits
Author: sivachandra Date: Mon Feb 8 20:18:50 2016 New Revision: 260192 URL: http://llvm.org/viewvc/llvm-project?rev=260192&view=rev Log: [TestExprsChar] Fix a typo is failure archs list Reviewers: zturner Subscribers: lldb-commits Differential Revision: http://reviews.llvm.org/D17014 Modified

Re: [Lldb-commits] [PATCH] D17014: [TestExprsChar] Fix a typo is failure archs list

2016-02-08 Thread Siva Chandra via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL260192: [TestExprsChar] Fix a typo is failure archs list (authored by sivachandra). Changed prior to commit: http://reviews.llvm.org/D17014?vs=47283&id=47284#toc Repository: rL LLVM http://reviews.l

[Lldb-commits] [lldb] r260199 - Fix an issue where pressing CTRL+C in the interactive script interpreter causes LLDB to crash

2016-02-08 Thread Enrico Granata via lldb-commits
Author: enrico Date: Mon Feb 8 23:46:47 2016 New Revision: 260199 URL: http://llvm.org/viewvc/llvm-project?rev=260199&view=rev Log: Fix an issue where pressing CTRL+C in the interactive script interpreter causes LLDB to crash This is because PyThreadState_Get() assumes a non-NULL thread state a