Re: [Lldb-commits] [Diffusion] rL246639: Fix tab completion for command arguments containing spaces

2015-09-03 Thread Dawn Perchik via lldb-commits
dawn added a subscriber: lldb-commits. Users: tberghammer (Author) http://reviews.llvm.org/rL246639 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [Diffusion] rL246639: Fix tab completion for command arguments containing spaces

2015-09-03 Thread Dawn Perchik via lldb-commits
dawn added a subscriber: dawn. dawn added a comment. We're seeing 2 new failures on OSX since this commit: Failure-TestCompletion.CommandLineCompletionTestCase.test_symbol_name_dsym-x86_64-clang.log Failure-TestCompletion.CommandLineCompletionTestCase.test_symbol_name_dwarf-x86_64-clang.log

Re: [Lldb-commits] [PATCH] D12602: Separate ClangExpressionVariable from ExpressionVariable

2015-09-03 Thread Jim Ingham via lldb-commits
jingham requested changes to this revision. jingham added a comment. This revision now requires changes to proceed. In general this looks good. It seems to me that in almost all the uses of ClangExpressionVariable::CreateVariableInList, you actually only want the ClangExpressionVariable *, sinc

[Lldb-commits] [lldb] r246829 - Set the default language to use when evaluating to that of the frame's CU.

2015-09-03 Thread Dawn Perchik via lldb-commits
Author: dperchik Date: Thu Sep 3 20:02:30 2015 New Revision: 246829 URL: http://llvm.org/viewvc/llvm-project?rev=246829&view=rev Log: Set the default language to use when evaluating to that of the frame's CU. * Use the frame's context (instead of just the target's) when evaluating, so that the

Re: [Lldb-commits] [PATCH] D11102: Set the default language to use when evaluating to that of the frame's CU.

2015-09-03 Thread Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL246829: Set the default language to use when evaluating to that of the frame's CU. (authored by dperchik). Changed prior to commit: http://reviews.llvm.org/D11102?vs=33721&id=34002#toc Repository: rL

Re: [Lldb-commits] [PATCH] D12602: Separate ClangExpressionVariable from ExpressionVariable

2015-09-03 Thread Sean Callanan via lldb-commits
spyffe updated this revision to Diff 34004. spyffe added a comment. According to Jim's suggestions, made CreateVariableInList return a ClangExpressionVariable * rather than a ExpressionVariableSP. Also made ExpressionVariable be able to get a shared pointer from itself, so that the few cases t

Re: [Lldb-commits] [PATCH] D12602: Separate ClangExpressionVariable from ExpressionVariable

2015-09-03 Thread Jim Ingham via lldb-commits
jingham requested changes to this revision. jingham added a comment. This revision now requires changes to proceed. Is there any reason ClangExpression::FindVariableInList doesn't work the same way as CreateVariableInList. It seems like for that one you also usually want the ClangExpressionVari

Re: [Lldb-commits] [PATCH] D11102: Set the default language to use when evaluating to that of the frame's CU.

2015-09-03 Thread Dawn Perchik via lldb-commits
dawn added a comment. In http://reviews.llvm.org/D11102#234730, @spyffe wrote: > I want to follow up and make non-Apple platforms not force ObjC (it doesn't > matter for making the expression parser work). Hi Sean, I have one question about this that still bugs me... I understand that C++ is

[Lldb-commits] [lldb] r246834 - Change the (internal to this file only) enum names from gcc_ to

2015-09-03 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Thu Sep 3 22:40:29 2015 New Revision: 246834 URL: http://llvm.org/viewvc/llvm-project?rev=246834&view=rev Log: Change the (internal to this file only) enum names from gcc_ to ehframe_ & from gdb_ to stabs_ for clarity. Also document the fact that i386 eh_frame on Darwin ha

<    1   2