Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Zachary Turner via lldb-commits
zturner added a subscriber: zturner. zturner added a comment. True about the bugnumbers. Not always diferent bug numbers, but certainly sometimes. The reason I don't like writing them as separate decorators is because we have tons of cases where the condition of multiple decorators pass, and the

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Zachary Turner via lldb-commits
True about the bugnumbers. Not always diferent bug numbers, but certainly sometimes. The reason I don't like writing them as separate decorators is because we have tons of cases where the condition of multiple decorators pass, and the best we can do is report one bugnumber / reason in the output

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Pavel Labath via lldb-commits
On 9 February 2016 at 17:51, Zachary Turner wrote: > I agree that you don't need arbitrary complexity, but I think there are some > things we would greatly benefit from. For example, have you ever seen this? > > @expectedFailureWindows > @expectedFailureGcc > @expectedFailureHostLinux > >

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Zachary Turner via lldb-commits
zturner added a comment. In http://reviews.llvm.org/D16936#347186, @tberghammer wrote: > My main concern is that we have a lot of named argument for > skipIf/expectFailure and I expect it to increase even further as we support > more and more configuration. In my opinion we can have some functi

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Zachary Turner via lldb-commits
zturner added a comment. In http://reviews.llvm.org/D16936#347141, @labath wrote: > I think this is getting way too complicated. I haven't seen any test > which needs such complicated combinations of skip conditions (and I > hope I never see one). I agree that you don't need arbitrary complex

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. My main concern is that we have a lot of named argument for skipIf/expectFailure and I expect it to increase even further as we support more and more configuration. In my opinion we can have some functional style solution as readable as the current solution with gre

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Pavel Labath via lldb-commits
labath added a subscriber: labath. labath added a comment. I think this is getting way too complicated. I haven't seen any test which needs such complicated combinations of skip conditions (and I hope I never see one). Repository: rL LLVM http://reviews.llvm.org/D16936

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-09 Thread Pavel Labath via lldb-commits
I think this is getting way too complicated. I haven't seen any test which needs such complicated combinations of skip conditions (and I hope I never see one). On 9 February 2016 at 01:24, Zachary Turner wrote: > 1. Skips if all conditions are true. @skipIf(all(A=a, B=b, C=c)) > 2. Skips if any

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Zachary Turner via lldb-commits
zturner added a comment. In http://reviews.llvm.org/D16936#346594, @zturner wrote: > I'm not opposed to it in principle, but I think we should optimize the design > for conciseness at the point where you decorate a class or function. If it > makes the point of decoration more verbose or harder

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Zachary Turner via lldb-commits
zturner added a comment. I'm not opposed to it in principle, but I think we should optimize the design for conciseness at the point where you decorate a class or function. If it makes the point of decoration more verbose or harder to read, then I would probably be against it. I guess I'd need

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. In http://reviews.llvm.org/D16936#346536, @tfiala wrote: > > I agree but I also might consider going further where the only thing you > > can specify is a function and we remove all arguments. Then we implement > > functions like architectureMatches, targetOsMatches

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Todd Fiala via lldb-commits
tfiala added a comment. > I agree but I also might consider going further where the only thing you can > specify is a function and we remove all arguments. Then we implement > functions like architectureMatches, targetOsMatches, hostOsMatches, etc.. and > some logical function what can combine

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. In http://reviews.llvm.org/D16936#346408, @zturner wrote: > In http://reviews.llvm.org/D16936#346293, @tberghammer wrote: > > > In http://reviews.llvm.org/D16936#346182, @labath wrote: > > > > > I agree with the idea in general, but I wanted to ask what is your plan

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Zachary Turner via lldb-commits
zturner added a comment. In http://reviews.llvm.org/D16936#346293, @tberghammer wrote: > In http://reviews.llvm.org/D16936#346182, @labath wrote: > > > I agree with the idea in general, but I wanted to ask what is your plan > > with the android decorators: For them we use the additional `api_lev

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Tamas Berghammer via lldb-commits
tberghammer added a subscriber: tberghammer. tberghammer added a comment. In http://reviews.llvm.org/D16936#346182, @labath wrote: > I agree with the idea in general, but I wanted to ask what is your plan with > the android decorators: For them we use the additional `api_levels` flag, > which d

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-08 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a comment. I agree with the idea in general, but I wanted to ask what is your plan with the android decorators: For them we use the additional `api_levels` flag, which does not exist on other platforms/decorators. I suppose we could add that flag to `

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-07 Thread Todd Fiala via lldb-commits
tfiala accepted this revision. tfiala added a comment. This revision is now accepted and ready to land. LGTM with the change you suggested above. I tried that and it worked on OS X. The change itself looked fine as well. Comment at: packages/Python/lldbsuite/test/decorators.p

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-07 Thread Todd Fiala via lldb-commits
tfiala added a comment. Yep, I'll give that a shot now. http://reviews.llvm.org/D16936 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-07 Thread Zachary Turner via lldb-commits
zturner added inline comments. Comment at: packages/Python/lldbsuite/test/decorators.py:170-171 @@ -169,2 +169,4 @@ reason_str = "{} unconditionally" +if bugnumber is not None: +reason_str = reason_str + " [" + bugnumber + "]"

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-07 Thread Todd Fiala via lldb-commits
tfiala added a comment. Here's one: Traceback (most recent call last): File "/Users/tfiala/src/lldb-tot/lldb/packages/Python/lldbsuite/test/lldbtest.py", line 1442, in dsym_test_method return attrvalue(self) File "/Users/tfiala/src/lldb-tot/lldb/packages/Python/lldbsuite/test/d

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-07 Thread Todd Fiala via lldb-commits
tfiala added a comment. I'm seeing 8 errors after applying this diff: ERROR: test_expr_stripped_dwarf (lang/objc/hidden-ivars/TestHiddenIvars.py) ERROR: test_frame_variable_stripped_dwarf (lang/objc/hidden-ivars/TestHiddenIvars.py) ERROR: test_with_python_api_dsym (lang/cpp/class_static/T

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-05 Thread Todd Fiala via lldb-commits
tfiala added a comment. I'll go ahead and run this before and after and compare totals. http://reviews.llvm.org/D16936 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D16936: Remove expectedFailureWindows decorator

2016-02-05 Thread Zachary Turner via lldb-commits
zturner added a comment. One more thing. This patch also causes skips and xfails to include the bugnumber as part of the reason. So you can see bugnumbers on summary output. See the changes to `decorators.py` for the relevant code. http://reviews.llvm.org/D16936 _