clayborg added a comment.
I like the look of this. It seems we would want this kind of auto complete in
many fields that we already have, like the file or directory dialogs to start
with.
My main question is do we need a full window for this, or can be paint a window
that is just the search re
This revision was landed with ongoing or failed builds.
This revision was automatically updated to reflect the committed changes.
Closed by commit rG292f013395f2: [LLDB][GUI] Handle extra navigation keys in
forms (authored by OmarEmaraDev, committed by clayborg).
Changed prior to commit:
https:
Author: Omar Emara
Date: 2021-08-23T22:42:57-07:00
New Revision: 292f013395f2e2eafd803b787a33eddfc5cc4918
URL:
https://github.com/llvm/llvm-project/commit/292f013395f2e2eafd803b787a33eddfc5cc4918
DIFF:
https://github.com/llvm/llvm-project/commit/292f013395f2e2eafd803b787a33eddfc5cc4918.diff
LO
This revision was landed with ongoing or failed builds.
This revision was automatically updated to reflect the committed changes.
Closed by commit rG945cde8b6a45: [LLDB][GUI] Add submit form key combination
(authored by OmarEmaraDev, committed by clayborg).
Changed prior to commit:
https://revi
Author: Omar Emara
Date: 2021-08-23T22:07:04-07:00
New Revision: 945cde8b6a4579406886d08f803b632e00f0b1ec
URL:
https://github.com/llvm/llvm-project/commit/945cde8b6a4579406886d08f803b632e00f0b1ec
DIFF:
https://github.com/llvm/llvm-project/commit/945cde8b6a4579406886d08f803b632e00f0b1ec.diff
LO
clayborg accepted this revision.
clayborg added a comment.
This revision is now accepted and ready to land.
Just tried it out. Works nicely.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108410/new/
https://reviews.llvm.org/D108410
___
This revision was landed with ongoing or failed builds.
This revision was automatically updated to reflect the committed changes.
Closed by commit rGd95d2a8e4aaa: [LLDB][GUI] Add extra keys to text field
(authored by OmarEmaraDev, committed by clayborg).
Repository:
rG LLVM Github Monorepo
CHA
Author: Omar Emara
Date: 2021-08-23T21:16:48-07:00
New Revision: d95d2a8e4aaae9521278c2968fb6f1baa820b817
URL:
https://github.com/llvm/llvm-project/commit/d95d2a8e4aaae9521278c2968fb6f1baa820b817
DIFF:
https://github.com/llvm/llvm-project/commit/d95d2a8e4aaae9521278c2968fb6f1baa820b817.diff
LO
clayborg accepted this revision.
clayborg added a comment.
This revision is now accepted and ready to land.
Finally got to try this out. Works great.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108385/new/
https://reviews.llvm.org/D108385
__
clayborg accepted this revision.
clayborg added a comment.
This revision is now accepted and ready to land.
I am so happy that the memory region trick worked! Thanks for working on this
and trying out the extra fixes, we now have great support for debugging via the
dynamic linker!
Repository:
jingham accepted this revision.
jingham added a comment.
This revision is now accepted and ready to land.
I like the change in general, anywhere that we're explicitly listing languages
in generic code we're probably doing it wrong... So far as I can tell you've
reconstructed the old behaviors c
jingham added a comment.
I appreciate the aim, but I don't think moving a whole bunch of platform
specific files from Plugins/Process/Utility to Target is the right way to go.
If anything that's moving platform specific files further up into generic code.
Since the list of valid signals and th
jingham added a comment.
One of the key reasons to use "frame recognizers" is to provide argument values
to functions that don't have debug information. That generally only works when
stopped at the first instruction, since otherwise you have to follow the value
as it moves through the code, w
jingham added a comment.
Raphael's analysis of what the test needs is right. We always check pointers
for validity before we do operations on them, so we wouldn't have tried to get
the summary.
The reason I passed the string reference to a function and check it there is
because from many year
Author: Alex Langford
Date: 2021-08-23T11:45:55-07:00
New Revision: 23c19395c085306cf229341523b6a8909b3b70a9
URL:
https://github.com/llvm/llvm-project/commit/23c19395c085306cf229341523b6a8909b3b70a9
DIFF:
https://github.com/llvm/llvm-project/commit/23c19395c085306cf229341523b6a8909b3b70a9.diff
bulbazord added a comment.
ping!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108229/new/
https://reviews.llvm.org/D108229
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.or
tammela accepted this revision.
tammela added a comment.
LGTM
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D104281/new/
https://reviews.llvm.org/D104281
___
lldb-commits mailing list
lldb-commits@lists.l
tammela accepted this revision.
tammela added a comment.
This revision is now accepted and ready to land.
LGTM
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108515/new/
https://reviews.llvm.org/D108515
_
Aj0SK updated this revision to Diff 368110.
Aj0SK added a comment.
Herald added a subscriber: dang.
Move minidump save-core functionality to separate plugin
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108233/new/
https://reviews.llvm.org/D108233
mgorny created this revision.
mgorny added reviewers: labath, emaste, krytarowski, jasonmolenda, JDevlieghere.
mgorny requested review of this revision.
Update GetRegisterInfoByName() methods to support getting registers
by a generic name independently of alt_name entries in the register
context.
mgorny created this revision.
mgorny added reviewers: labath, krytarowski, jasonmolenda, JDevlieghere, emaste.
mgorny requested review of this revision.
Enhance the generic register fallback code to support "eflags" register
name in addition to "rflags", as the former is used by gdbserver. This
p
OmarEmaraDev added a comment.
Herald added a subscriber: JDevlieghere.
An example searcher window for source files:
F18633042: 20210823-141344.mp4 <https://reviews.llvm.org/F18633042>
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D1085
OmarEmaraDev created this revision.
OmarEmaraDev added a reviewer: clayborg.
Herald added a reviewer: teemperor.
OmarEmaraDev requested review of this revision.
Herald added a project: LLDB.
Herald added a subscriber: lldb-commits.
This patch adds a new type of reusable UI components. Searcher Win
23 matches
Mail list logo